summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-07-08 10:18:18 +0000
committerPeter Volkov <pva@gentoo.org>2009-07-08 10:18:18 +0000
commita34e515a8bec047ec658ed3083c23fe739bd4c78 (patch)
treea166c7140576e5a05143a838f69bda9f7db47e07 /net-analyzer
parentImport bzr.eclass from Bazaar overlay: (diff)
downloadgentoo-2-a34e515a8bec047ec658ed3083c23fe739bd4c78.tar.gz
gentoo-2-a34e515a8bec047ec658ed3083c23fe739bd4c78.tar.bz2
gentoo-2-a34e515a8bec047ec658ed3083c23fe739bd4c78.zip
Version bump, fixes bug #274813, thank Andrew Savchenko for report.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpreplay/ChangeLog7
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-3.4.3.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-analyzer/tcpreplay/ChangeLog b/net-analyzer/tcpreplay/ChangeLog
index 90be51e8f09e..d5cf1c6af60b 100644
--- a/net-analyzer/tcpreplay/ChangeLog
+++ b/net-analyzer/tcpreplay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/tcpreplay
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/ChangeLog,v 1.32 2009/05/24 19:06:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/ChangeLog,v 1.33 2009/07/08 10:18:18 pva Exp $
+
+*tcpreplay-3.4.3 (08 Jul 2009)
+
+ 08 Jul 2009; Peter Volkov <pva@gentoo.org> +tcpreplay-3.4.3.ebuild:
+ Version bump, fixes bug #274813, thank Andrew Savchenko for report.
*tcpreplay-3.4.2 (24 May 2009)
diff --git a/net-analyzer/tcpreplay/tcpreplay-3.4.3.ebuild b/net-analyzer/tcpreplay/tcpreplay-3.4.3.ebuild
new file mode 100644
index 000000000000..2d38dafdf21c
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-3.4.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-3.4.3.ebuild,v 1.1 2009/07/08 10:18:18 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="replay saved tcpdump or snoop files at arbitrary speeds"
+HOMEPAGE="http://tcpreplay.synfin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+DEPEND="
+ >=sys-devel/autogen-5.9.7
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ tcpdump? ( net-analyzer/tcpdump )
+ pcapnav? ( net-libs/libpcapnav )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ echo "We don't use bundled libopts" > libopts/options.h
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug 252940
+ econf --enable-shared \
+ --disable-local-libopts \
+ $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
+ $(use_enable debug)
+}
+
+src_test() {
+ if hasq userpriv "${FEATURES}"; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ make -C test tcpprep || die "self test failed - see ${S}/test/test.log"
+ else
+ make test || {
+ ewarn "Note, that some tests require eth0 iface to be UP." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README docs/{CHANGELOG,CREDIT,HACKING,TODO} || die
+}