summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-27 17:55:36 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-27 17:55:36 +0000
commit65bf30d5f46f6324084a52dad5ad00ba72103604 (patch)
treecd6fa27f76b1a37b4b2d81e94f280375c6b2f48a /net-analyzer
parentDepend on sec-policy/selinux-dracut if USE=selinux, fixes bug #489080 (diff)
downloadgentoo-2-65bf30d5f46f6324084a52dad5ad00ba72103604.tar.gz
gentoo-2-65bf30d5f46f6324084a52dad5ad00ba72103604.tar.bz2
gentoo-2-65bf30d5f46f6324084a52dad5ad00ba72103604.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/scanlogd/ChangeLog8
-rw-r--r--net-analyzer/scanlogd/files/scanlogd-2.2.6-Makefile.patch5
-rw-r--r--net-analyzer/scanlogd/files/scanlogd-2.2.7-gentoo.patch21
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.7.ebuild47
4 files changed, 77 insertions, 4 deletions
diff --git a/net-analyzer/scanlogd/ChangeLog b/net-analyzer/scanlogd/ChangeLog
index e6c872ac8173..4f0a7083ec1d 100644
--- a/net-analyzer/scanlogd/ChangeLog
+++ b/net-analyzer/scanlogd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/scanlogd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/ChangeLog,v 1.32 2013/01/02 23:33:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/ChangeLog,v 1.33 2013/10/27 17:55:35 jer Exp $
+
+*scanlogd-2.2.7 (27 Oct 2013)
+
+ 27 Oct 2013; Jeroen Roovers <jer@gentoo.org> +scanlogd-2.2.7.ebuild,
+ files/scanlogd-2.2.6-Makefile.patch, +files/scanlogd-2.2.7-gentoo.patch:
+ Version bump.
02 Jan 2013; Ulrich Müller <ulm@gentoo.org> scanlogd-2.2.6-r2.ebuild:
Fix LICENSE, see scanlogd.c, bug 449834.
diff --git a/net-analyzer/scanlogd/files/scanlogd-2.2.6-Makefile.patch b/net-analyzer/scanlogd/files/scanlogd-2.2.6-Makefile.patch
index 07dbd9b834f3..ef36abda0911 100644
--- a/net-analyzer/scanlogd/files/scanlogd-2.2.6-Makefile.patch
+++ b/net-analyzer/scanlogd/files/scanlogd-2.2.6-Makefile.patch
@@ -1,6 +1,5 @@
-diff -urN ./scanlogd-2.2.6.orig/Makefile ./scanlogd-2.2.6/Makefile
---- ./scanlogd-2.2.6.orig/Makefile 2006-03-05 11:03:15.000000000 +0100
-+++ ./scanlogd-2.2.6/Makefile 2006-03-27 00:39:16.000000000 +0200
+--- a/./scanlogd-2.2.6/Makefile 2006-03-05 11:03:15.000000000 +0100
++++ b/./scanlogd-2.2.6/Makefile 2006-03-27 00:39:16.000000000 +0200
@@ -1,8 +1,6 @@
CC = gcc
LD = $(CC)
diff --git a/net-analyzer/scanlogd/files/scanlogd-2.2.7-gentoo.patch b/net-analyzer/scanlogd/files/scanlogd-2.2.7-gentoo.patch
new file mode 100644
index 000000000000..4d1d2f01c643
--- /dev/null
+++ b/net-analyzer/scanlogd/files/scanlogd-2.2.7-gentoo.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,11 @@
+-CC = gcc
+ LD = $(CC)
+ RM = rm -f
+-CFLAGS = -Wall -O2 -fomit-frame-pointer
+-LDFLAGS = -s
+
+-PCAP_H = -I/usr/include/pcap
+-PCAP_L = -lpcap
++PCAP_H = $(shell pcap-config --cflags)
++PCAP_L = $(shell pcap-config --libs)
+
+-NIDS_H = -I/usr/local/include
+-NIDS_L = -L/usr/local/lib -lnids -lnet -lpcap
++NIDS_H = -I/usr/include
++NIDS_L = -lnids
+
+ PROJ = scanlogd
+
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild
new file mode 100644
index 000000000000..27b423c658d3
--- /dev/null
+++ b/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.7.ebuild,v 1.1 2013/10/27 17:55:35 jer Exp $
+
+EAPI=5
+inherit eutils savedconfig toolchain-funcs user
+
+DESCRIPTION="a port scan detection tool"
+SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
+
+LICENSE="scanlogd GPL-2" # GPL-2 for initscript
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+nids pcap"
+REQUIRED_USE="?? ( nids pcap )"
+
+DEPEND="
+ nids? ( net-libs/libnids )
+ pcap? ( net-libs/libpcap )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ restore_config params.h
+ tc-export CC
+}
+
+src_compile() {
+ local target=linux
+ use nids && target=libnids
+ use pcap && target=libpcap
+ emake ${target}
+}
+
+src_install() {
+ dosbin scanlogd
+ doman scanlogd.8
+ newinitd "${FILESDIR}"/scanlogd.rc scanlogd
+ save_config params.h
+}
+
+pkg_preinst() {
+ enewgroup scanlogd
+ enewuser scanlogd -1 -1 /dev/null scanlogd
+}