summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-12-10 22:36:28 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-12-10 22:36:28 +0000
commit42ccc44c647609e23221487988f74eafc42a91be (patch)
tree4ef496f9051a91c66295da9b97912220b9bb4713 /net-analyzer/upnpscan
parentStable on alpha. (diff)
downloadgentoo-2-42ccc44c647609e23221487988f74eafc42a91be.tar.gz
gentoo-2-42ccc44c647609e23221487988f74eafc42a91be.tar.bz2
gentoo-2-42ccc44c647609e23221487988f74eafc42a91be.zip
Initial commit. Fixes bug 98046.
(Portage version: 2.0.53)
Diffstat (limited to 'net-analyzer/upnpscan')
-rw-r--r--net-analyzer/upnpscan/ChangeLog11
-rw-r--r--net-analyzer/upnpscan/Manifest2
-rw-r--r--net-analyzer/upnpscan/files/digest-upnpscan-0.41
-rw-r--r--net-analyzer/upnpscan/metadata.xml9
-rw-r--r--net-analyzer/upnpscan/upnpscan-0.4.ebuild29
5 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/upnpscan/ChangeLog b/net-analyzer/upnpscan/ChangeLog
new file mode 100644
index 000000000000..e9a357ea19e9
--- /dev/null
+++ b/net-analyzer/upnpscan/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/upnpscan
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/ChangeLog,v 1.1 2005/12/10 22:36:28 vanquirius Exp $
+
+*upnpscan-0.4 (10 Dec 2005)
+
+ 10 Dec 2005; Marcelo Goes <vanquirius@gentoo.org> +metadata.xml,
+ +upnpscan-0.4.ebuild:
+ Initial commit. Fixes bug 98046. Thanks to Michael Zanetta <grimmlin at
+ pentoo dot ch>.
+
diff --git a/net-analyzer/upnpscan/Manifest b/net-analyzer/upnpscan/Manifest
new file mode 100644
index 000000000000..74084d498989
--- /dev/null
+++ b/net-analyzer/upnpscan/Manifest
@@ -0,0 +1,2 @@
+MD5 6faae962fe4cdcfaa1d77503f32730cb files/digest-upnpscan-0.4 66
+MD5 2f3d73c5411b1fc131bf4a7183a47c30 upnpscan-0.4.ebuild 540
diff --git a/net-analyzer/upnpscan/files/digest-upnpscan-0.4 b/net-analyzer/upnpscan/files/digest-upnpscan-0.4
new file mode 100644
index 000000000000..5895480d2849
--- /dev/null
+++ b/net-analyzer/upnpscan/files/digest-upnpscan-0.4
@@ -0,0 +1 @@
+MD5 23db71f206cefd67a5d4c1397577d77f upnpscan-v0.4-src.tgz 309011
diff --git a/net-analyzer/upnpscan/metadata.xml b/net-analyzer/upnpscan/metadata.xml
new file mode 100644
index 000000000000..18cbfd72c907
--- /dev/null
+++ b/net-analyzer/upnpscan/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<maintainer>
+ <email>vanquirius@gentoo.org</email>
+ <name>Marcelo Goes</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/upnpscan/upnpscan-0.4.ebuild b/net-analyzer/upnpscan/upnpscan-0.4.ebuild
new file mode 100644
index 000000000000..106cb12d37b6
--- /dev/null
+++ b/net-analyzer/upnpscan/upnpscan-0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/upnpscan-0.4.ebuild,v 1.1 2005/12/10 22:36:28 vanquirius Exp $
+
+DESCRIPTION="Scans the network for UPNP capable devices"
+HOMEPAGE="http://www.cqure.net/tools.jsp?id=23"
+SRC_URI="http://www.cqure.net/tools/${PN}-v${PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ if use static ; then
+ econf || die
+ else
+ econf --enable-static=no || die
+ fi
+ emake || die
+}
+
+src_install() {
+ dobin "${S}"/src/upnpscan || die
+}