summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-04 11:05:42 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-04 11:05:42 +0000
commitad14d1c9b4ba3de83cf9e9cf998a449360cbd78a (patch)
tree0fa199c50dafe1166915ae3be9ff24a82c1994e5 /net-analyzer/snort
parentFix keywords (diff)
downloadgentoo-2-ad14d1c9b4ba3de83cf9e9cf998a449360cbd78a.tar.gz
gentoo-2-ad14d1c9b4ba3de83cf9e9cf998a449360cbd78a.tar.bz2
gentoo-2-ad14d1c9b4ba3de83cf9e9cf998a449360cbd78a.zip
Security update.
Diffstat (limited to 'net-analyzer/snort')
-rw-r--r--net-analyzer/snort/ChangeLog7
-rw-r--r--net-analyzer/snort/files/digest-snort-1.9.11
-rw-r--r--net-analyzer/snort/snort-1.9.1.ebuild103
3 files changed, 110 insertions, 1 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index e94d379fdc38..0860a523a500 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/snort
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.10 2003/02/12 07:49:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.11 2003/03/04 11:05:42 aliz Exp $
+
+*snort-1.9.1 (04 Mar 2003)
+
+ 04 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-analyzer/snort/files/digest-snort-1.9.1 b/net-analyzer/snort/files/digest-snort-1.9.1
new file mode 100644
index 000000000000..1d2e3073e602
--- /dev/null
+++ b/net-analyzer/snort/files/digest-snort-1.9.1
@@ -0,0 +1 @@
+MD5 50bb526b41f48fb7689bb8342b27e44d snort-1.9.1.tar.gz 1466151
diff --git a/net-analyzer/snort/snort-1.9.1.ebuild b/net-analyzer/snort/snort-1.9.1.ebuild
new file mode 100644
index 000000000000..8b11427b23be
--- /dev/null
+++ b/net-analyzer/snort/snort-1.9.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.1.ebuild,v 1.1 2003/03/04 11:05:42 aliz Exp $
+
+IUSE="ssl postgres mysql snmp"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
+SRC_URI="http://www.snort.org/dl/${P}.tar.gz"
+HOMEPAGE="http://www.snort.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.6.2-r1
+ ~net-libs/libnet-1.0.2a
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ snmp? ( >=net-analyzer/net-snmp-5.0 )"
+
+RDEPEND="virtual/glibc
+ sys-devel/perl
+ >=net-libs/libpcap-0.6.2-r1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -l -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+
+ use postgres && myconf="${myconf} --with-postgresql" \
+ || myconf="${myconf} --without-postgresql"
+ use mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+ use ssl && myconf="${myconf} --with-openssl" \
+ || myconf="${myconf} --without-openssl"
+ use snmp && myconf="${myconf} --with-snmp" \
+ || myconf="${myconf} --without-snmp"
+
+
+ ./configure \
+ --prefix=/usr \
+ --without-odbc \
+ --without-oracle \
+ --enable-pthreads \
+ --enable-flexresp \
+ --enable-smbalerts \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodir /var/log/snort
+ touch ${D}/var/log/snort/.keep
+
+ insinto /usr/lib/snort/bin
+ doins contrib/{create_mysql,snortlog,*.pl}
+
+ dodoc COPYING LICENSE doc/*
+ docinto contrib ; dodoc contrib/*
+
+ insinto /etc/snort
+ doins etc/classification.config rules/*.rules
+ newins etc/snort.conf snort.conf.distrib
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/snort.rc6 snort
+ insinto /etc/conf.d ; newins ${FILESDIR}/snort.confd snort
+}
+
+pkg_postinst() {
+
+ if ! grep -q ^snort: /etc/group ; then
+ groupadd snort || die "problem adding group snort"
+ fi
+ if ! grep -q ^snort: /etc/passwd ; then
+ useradd -g snort -s /dev/null -d /var/log/snort -c "snort" snort
+ assert "problem adding user snort"
+ fi
+ usermod -c "snort" snort || die "usermod problem"
+ usermod -d "/var/log/snort" snort || die "usermod problem"
+ usermod -g "snort" snort || die "usermod problem"
+ usermod -s "/dev/null" snort || die "usermod problem"
+ echo "ignore any message about CREATE_HOME above..."
+
+ chown snort.snort /var/log/snort
+ chmod 0770 /var/log/snort
+}