summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-01-28 10:39:51 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-01-28 10:39:51 +0000
commitc46d088f5fd001a4d33a91f28df803fd0083aa13 (patch)
tree50d1aec8e67d70fbe8ecd711e8cfaa02d13ce87d /net-analyzer/netio
parentVersion bump. (diff)
downloadgentoo-2-c46d088f5fd001a4d33a91f28df803fd0083aa13.tar.gz
gentoo-2-c46d088f5fd001a4d33a91f28df803fd0083aa13.tar.bz2
gentoo-2-c46d088f5fd001a4d33a91f28df803fd0083aa13.zip
Minor ebuild cleansing; respect CFLAGS. Also added pkg_postinst for messages regarding the license.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-analyzer/netio')
-rw-r--r--net-analyzer/netio/ChangeLog8
-rw-r--r--net-analyzer/netio/Manifest4
-rw-r--r--net-analyzer/netio/netio-1.23.ebuild46
3 files changed, 42 insertions, 16 deletions
diff --git a/net-analyzer/netio/ChangeLog b/net-analyzer/netio/ChangeLog
index 5de31c62b218..4bba23ed8218 100644
--- a/net-analyzer/netio/ChangeLog
+++ b/net-analyzer/netio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/netio
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.8 2004/11/20 04:02:37 weeve Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.9 2005/01/28 10:39:51 ka0ttic Exp $
+
+ 28 Jan 2005; Aaron Walker <ka0ttic@gentoo.org> netio-1.23.ebuild:
+ Minor ebuild cleansing; respect CFLAGS. Also added pkg_postinst for messages
+ regarding the license.
19 Nov 2004; Jason Wever <weeve@gentoo.org> netio-1.23.ebuild:
Stable on sparc.
diff --git a/net-analyzer/netio/Manifest b/net-analyzer/netio/Manifest
index 97c5cfc4ff4b..4ab77646925e 100644
--- a/net-analyzer/netio/Manifest
+++ b/net-analyzer/netio/Manifest
@@ -1,4 +1,4 @@
-MD5 a892feeb79ef9df1e43c00909203c02e ChangeLog 3887
-MD5 570ed4df895bea1b03c75ba1bf477992 netio-1.23.ebuild 1082
+MD5 8d3e3a49a34954cbc05853654a57ed66 netio-1.23.ebuild 1478
+MD5 6eac3eea283ff479eda3ca21fe923193 ChangeLog 4060
MD5 f34e3c8858756da0001b12d2d3fa1af2 metadata.xml 159
MD5 e2011a67f325086737a95017b12456d1 files/digest-netio-1.23 57
diff --git a/net-analyzer/netio/netio-1.23.ebuild b/net-analyzer/netio/netio-1.23.ebuild
index c93e9ce64391..238d03eae237 100644
--- a/net-analyzer/netio/netio-1.23.ebuild
+++ b/net-analyzer/netio/netio-1.23.ebuild
@@ -1,33 +1,55 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/netio-1.23.ebuild,v 1.11 2004/11/20 04:02:37 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/netio-1.23.ebuild,v 1.12 2005/01/28 10:39:51 ka0ttic Exp $
+
+inherit toolchain-funcs
DESCRIPTION="a network benchmark for DOS, OS/2, Windows NT and Unix that measures net througput with NetBIOS and TCP/IP protocols."
HOMEPAGE="http://freshmeat.net/projects/netio/"
SRC_URI="http://ftp.leo.org/pub/comp/os/os2/leo/systools/netio123.zip"
+
LICENSE="free-noncomm"
SLOT="0"
KEYWORDS="x86 ppc sparc ppc-macos"
IUSE=""
+
DEPEND="virtual/libc
- app-arch/unzip"
+ app-arch/unzip
+ >=sys-apps/sed-4"
RDEPEND="virtual/libc"
-S=${WORKDIR}/
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's|\(CFLAGS\)=|\1?=|g' \
+ -e 's|\(CC\)=|\1?=|g' Makefile || die "sed Makefile failed"
+}
src_compile() {
- emake linux || die
+ emake linux \
+ CC="$(tc-getCC)" \
+ CFLAGS="-DUNIX ${CFLAGS}" \
+ || die "emake failed"
}
src_install() {
- into /usr
- dobin netio
+ dobin netio || die "dobin failed"
# to be sure to comply with the license statement in netio.doc,
# just install everything included in the package to doc
- dodoc netio.doc FILE_ID.DIZ getopt.h netb_1_c.h netbios.h netio.c\
- getopt.o netb_2_c.h netbios.o netio.doc getopt.c Makefile netbios.c\
- netio netio.o
+ dodoc netio.doc FILE_ID.DIZ getopt.h netb_1_c.h netbios.h netio.c \
+ netb_2_c.h netio.doc getopt.c Makefile netbios.c
+
+ # also install binaries
+ dodoc bin/os2-i386.exe bin/win32-i386.exe bin/linux-i386
+}
- # also install binaries for other platforms than linux
- dodoc bin/os2-i386.exe bin/win32-i386.exe
+pkg_postinst() {
+ echo
+ einfo "NOTE: all files included in the upstream zip file have"
+ einfo "been installed to /usr/share/doc/${PF}, as required by"
+ einfo "the license."
+ echo
}