summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-11-21 09:34:57 +0000
committerEldad Zack <eldad@gentoo.org>2004-11-21 09:34:57 +0000
commit9b9fc74de94b9fbbef85cbdb28513294f713e372 (patch)
treeba5e25c50c154db67d835f9ab4378bdb8b996b12 /net-analyzer/ettercap
parentAdded ~mips, bug #71769 (Manifest recommit) (diff)
downloadgentoo-2-9b9fc74de94b9fbbef85cbdb28513294f713e372.tar.gz
gentoo-2-9b9fc74de94b9fbbef85cbdb28513294f713e372.tar.bz2
gentoo-2-9b9fc74de94b9fbbef85cbdb28513294f713e372.zip
version bump, ~amd64
Diffstat (limited to 'net-analyzer/ettercap')
-rw-r--r--net-analyzer/ettercap/ChangeLog7
-rw-r--r--net-analyzer/ettercap/Manifest14
-rw-r--r--net-analyzer/ettercap/ettercap-0.7.1.ebuild66
-rw-r--r--net-analyzer/ettercap/files/digest-ettercap-0.7.11
4 files changed, 76 insertions, 12 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index b26db5815ccf..b84ccf7447e7 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.41 2004/11/11 19:24:14 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.42 2004/11/21 09:34:57 eldad Exp $
+
+*ettercap-0.7.1 (21 Nov 2004)
+
+ 21 Nov 2004; Eldad Zack <eldad@gentoo.org> +ettercap-0.7.1.ebuild:
+ Version bump. Added ~amd64 after testing on amd64.g.o. Closes #64797.
11 Nov 2004; Bryan Østergaard <kloeri@gentoo.org> ettercap-0.7.0.ebuild:
~alpha keyword.
diff --git a/net-analyzer/ettercap/Manifest b/net-analyzer/ettercap/Manifest
index ecb66588be87..45dc2608bb1e 100644
--- a/net-analyzer/ettercap/Manifest
+++ b/net-analyzer/ettercap/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 da773da55056406ca7e1d74cdbb01741 ChangeLog 4535
+MD5 e7366c65103d446288c9bacfd4408bcb ettercap-0.7.1.ebuild 1696
MD5 d893e54934c2a1c8270bbf037efb8895 ettercap-0.6.11.ebuild 1740
+MD5 da773da55056406ca7e1d74cdbb01741 ChangeLog 4535
MD5 e7366c65103d446288c9bacfd4408bcb ettercap-0.7.0.ebuild 1696
MD5 61da3c68a3ae57136cdc2a17fbaedfaf metadata.xml 223
MD5 6dc46b78f823aea675d64411673851a2 files/digest-ettercap-0.7.0 70
+MD5 2dfc113de5700233c282ca6a0d7c8ea0 files/digest-ettercap-0.7.1 70
MD5 0a3618a8adc8c1c2764bb531dbf68810 files/digest-ettercap-0.6.11 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBk7xnugEuf3OQ0akRAt7SAJ9HEYjQD0KDSyUJyBUnXCQnm8r6iACfe3Tk
-bqOR0dlm65Tx7yfXpR6VzZ8=
-=Q8ay
------END PGP SIGNATURE-----
diff --git a/net-analyzer/ettercap/ettercap-0.7.1.ebuild b/net-analyzer/ettercap/ettercap-0.7.1.ebuild
new file mode 100644
index 000000000000..fe9e0b6b4dc0
--- /dev/null
+++ b/net-analyzer/ettercap/ettercap-0.7.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.1.ebuild,v 1.1 2004/11/21 09:34:57 eldad Exp $
+
+# the actual version is "NG-0.7.0" but I suppose portage people will not be
+# happy with it (as for the 0.6.b version), so let's set it to "0.7.0".
+# since 'ettercap NG' has to be intended as an upgrade to 0.6.x series and not as
+# a new project or branch, this will be fine...
+
+inherit flag-o-matic
+
+MY_P=${PN}-NG-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A suite for man in the middle attacks and network mapping"
+HOMEPAGE="http://ettercap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha ~amd64"
+IUSE="ssl ncurses gtk debug"
+
+# libtool is needed because it provides libltdl (needed for plugins)
+RDEPEND="virtual/libc
+ sys-libs/zlib
+ >=sys-devel/libtool-1.4.3
+ >=net-libs/libnet-1.1.2.1
+ >=net-libs/libpcap-0.8.1
+ ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )
+ gtk? ( >=x11-libs/gtk+-2.2.2 )"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ >=sys-apps/portage-2.0.45-r3
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:exec_prefix="/usr/local":exec_prefix="$prefix":' configure
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-openssl"
+ fi
+
+ econf ${myconf} \
+ `use_enable gtk gtk` \
+ `use_enable debug debug` \
+ `use_with ncurses ncurses` \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+}
diff --git a/net-analyzer/ettercap/files/digest-ettercap-0.7.1 b/net-analyzer/ettercap/files/digest-ettercap-0.7.1
new file mode 100644
index 000000000000..7f74eca66f06
--- /dev/null
+++ b/net-analyzer/ettercap/files/digest-ettercap-0.7.1
@@ -0,0 +1 @@
+MD5 a78b914b9863668f962c9bd7b8733fc1 ettercap-NG-0.7.1.tar.gz 1112490