summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2014-06-04 13:26:30 +0000
committerLuca Barbato <lu_zero@gentoo.org>2014-06-04 13:26:30 +0000
commit9ae67311d0f9d1c8fd2e7ec526b741be94ebc9e9 (patch)
tree6ca9414530996adb28b55f2d2770acdbf735577c /media-video
parentapp-admin/ngxtop: Fix compatibility with >= py3.3, #512380 (diff)
downloadgentoo-2-9ae67311d0f9d1c8fd2e7ec526b741be94ebc9e9.tar.gz
gentoo-2-9ae67311d0f9d1c8fd2e7ec526b741be94ebc9e9.tar.bz2
gentoo-2-9ae67311d0f9d1c8fd2e7ec526b741be94ebc9e9.zip
Multilib support thanks to Christian Schmidt, bug #501098
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/rtmpdump/ChangeLog6
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild27
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild34
3 files changed, 46 insertions, 21 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index 35b66baa5097..5fe3ecfe6742 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/rtmpdump
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.30 2014/01/19 10:29:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.31 2014/06/04 13:26:30 lu_zero Exp $
+
+ 04 Jun 2014; Luca Barbato <lu_zero@gentoo.org> rtmpdump-2.4_p20131018.ebuild,
+ rtmpdump-9999.ebuild:
+ Multilib support thanks to Christian Schmidt, bug #501098
19 Jan 2014; Agostino Sarubbo <ago@gentoo.org> rtmpdump-2.4_p20131018.ebuild:
Stable for ppc64, wrt bug #496436
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild
index a466ce7a7e33..8e38dcd8f648 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild,v 1.6 2014/01/19 10:29:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild,v 1.7 2014/06/04 13:26:29 lu_zero Exp $
EAPI="4"
-inherit multilib toolchain-funcs
+inherit multilib toolchain-funcs multilib-minimal
DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
@@ -23,15 +23,20 @@ DEPEND="ssl? (
)
sys-libs/zlib"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
pkg_setup() {
- if ! use ssl && ( use gnutls || use polarssl ) ; then
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
}
+src_unpack() {
+ mkdir -p "${S}" || die "Can't create source directory"
+ cd "${S}"
+ unpack "${A}"
+}
+
src_prepare() {
# fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
sed -i 's/\$(MAKEFLAGS)//g' Makefile \
@@ -40,9 +45,10 @@ src_prepare() {
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
+ multilib_copy_sources
}
-src_compile() {
+multilib_src_compile() {
if use ssl ; then
if use gnutls ; then
crypto="GNUTLS"
@@ -54,13 +60,20 @@ src_compile() {
fi
#fix multilib-script support. Bug #327449
sed -i "/^libdir/s:lib$:$(get_libdir)$:" librtmp/Makefile
+ if ! multilib_build_binaries; then
+ cd librtmp
+ fi
emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
}
-src_install() {
+multilib_src_install() {
mkdir -p "${ED}"/${DESTTREE}/$(get_libdir)
+ if multilib_is_native_abi; then
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+ else
+ cd librtmp
+ fi
emake DESTDIR="${ED}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
CRYPTO="${crypto}" install
- dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
}
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index f0565c3ba8c3..f8764271872f 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-9999.ebuild,v 1.4 2012/11/25 10:53:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-9999.ebuild,v 1.5 2014/06/04 13:26:30 lu_zero Exp $
EAPI="4"
-inherit git-2 multilib toolchain-funcs
+inherit git-2 multilib toolchain-funcs multilib-minimal
DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
@@ -17,15 +17,15 @@ KEYWORDS=""
IUSE="gnutls polarssl ssl"
DEPEND="ssl? (
- gnutls? ( net-libs/gnutls )
- polarssl? ( !gnutls? ( >=net-libs/polarssl-0.14.0 ) )
- !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ gnutls? ( net-libs/gnutls[${MULTILIB_USEDEP}] )
+ polarssl? ( !gnutls? ( >=net-libs/polarssl-0.14.0[${MULTILIB_USEDEP}] ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl[${MULTILIB_USEDEP}] ) )
)
- sys-libs/zlib"
+ sys-libs/zlib[${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! use ssl && ( use gnutls || use polarssl ) ; then
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
@@ -39,11 +39,12 @@ src_prepare() {
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
+ multilib_copy_sources
}
-src_compile() {
+multilib_src_compile() {
if use ssl ; then
- if use gnutls ; then
+ if use gnutls ; then
crypto="GNUTLS"
elif use polarssl ; then
crypto="POLARSSL"
@@ -53,13 +54,20 @@ src_compile() {
fi
#fix multilib-script support. Bug #327449
sed -i "/^libdir/s:lib$:$(get_libdir)$:" librtmp/Makefile
+ if ! multilib_build_binaries; then
+ cd librtmp
+ fi
emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
}
-src_install() {
+multilib_src_install() {
mkdir -p "${ED}"/${DESTTREE}/$(get_libdir)
+ if multilib_is_native_abi; then
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+ else
+ cd librtmp
+ fi
emake DESTDIR="${ED}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
- CRYPTO="${crypto}" install
- dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+ CRYPTO="${crypto}" install
}