summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-27 12:37:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-27 12:37:46 +0000
commita6aa804a64f4874011ea539cc1dcf8736c3f1c44 (patch)
tree1501610d250e98813e19e1769335edffcfcbb69e /media-video/undvd
parentSlight adjustment in SRC_URI for qtsoftware.com (diff)
downloadgentoo-2-a6aa804a64f4874011ea539cc1dcf8736c3f1c44.tar.gz
gentoo-2-a6aa804a64f4874011ea539cc1dcf8736c3f1c44.tar.bz2
gentoo-2-a6aa804a64f4874011ea539cc1dcf8736c3f1c44.zip
Bump to 0.7.5. Fixes #259844. Ebuild fixups by Tim Harder.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/undvd')
-rw-r--r--media-video/undvd/ChangeLog9
-rw-r--r--media-video/undvd/undvd-0.7.5.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/media-video/undvd/ChangeLog b/media-video/undvd/ChangeLog
index eec88745fa07..88b69a078f37 100644
--- a/media-video/undvd/ChangeLog
+++ b/media-video/undvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/undvd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/undvd/ChangeLog,v 1.8 2008/09/19 23:02:20 coldwind Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/undvd/ChangeLog,v 1.9 2009/06/27 12:37:46 patrick Exp $
+
+*undvd-0.7.5 (27 Jun 2009)
+
+ 27 Jun 2009; Patrick Lauer <patrick@gentoo.org> +undvd-0.7.5.ebuild:
+ Bump to 0.7.5. Fixes #259844. Ebuild fixups by Tim Harder.
19 Sep 2008; Santiago M. Mola <coldwind@gentoo.org> undvd-0.6.0.ebuild:
Added ~amd64 keyword.
diff --git a/media-video/undvd/undvd-0.7.5.ebuild b/media-video/undvd/undvd-0.7.5.ebuild
new file mode 100644
index 000000000000..49083390494b
--- /dev/null
+++ b/media-video/undvd/undvd-0.7.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/undvd/undvd-0.7.5.ebuild,v 1.1 2009/06/27 12:37:46 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Simple dvd ripping command line app"
+HOMEPAGE="http://sourceforge.net/projects/undvd/"
+SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac css ffmpeg matroska mp4 ogm xvid"
+
+DEPEND="sys-apps/coreutils
+ >=dev-lang/perl-5.8.8
+ media-video/lsdvd
+ media-video/mplayer[encode,dvd,mp3,x264,aac?,xvid?]
+ css? ( media-libs/libdvdcss
+ media-video/vobcopy )
+ ffmpeg? ( media-video/ffmpeg )
+ matroska? ( media-video/mkvtoolnix )
+ mp4? ( media-video/mpeg4ip )
+ ogm? ( media-sound/ogmtools )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}