summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-07-17 09:19:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-07-17 09:19:30 +0000
commit32f17b1d02d8d43de57eda1f4471108c3091ce07 (patch)
treefd528fde767a9b31334c3d996d3b2117884e18b1 /media-video/clive
parentVersion bump. (diff)
downloadgentoo-2-32f17b1d02d8d43de57eda1f4471108c3091ce07.tar.gz
gentoo-2-32f17b1d02d8d43de57eda1f4471108c3091ce07.tar.bz2
gentoo-2-32f17b1d02d8d43de57eda1f4471108c3091ce07.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-2.2.2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index f8d3b4f328f6..77fd34c95710 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.46 2009/05/13 18:54:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.47 2009/07/17 09:19:30 aballier Exp $
+
+*clive-2.2.2 (17 Jul 2009)
+
+ 17 Jul 2009; Alexis Ballier <aballier@gentoo.org> +clive-2.2.2.ebuild:
+ version bump
*clive-2.1.12 (13 May 2009)
diff --git a/media-video/clive/clive-2.2.2.ebuild b/media-video/clive/clive-2.2.2.ebuild
new file mode 100644
index 000000000000..5c14a2dd0508
--- /dev/null
+++ b/media-video/clive/clive-2.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.2.ebuild,v 1.1 2009/07/17 09:19:30 aballier Exp $
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="http://clive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clipboard pager password"
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND=""
+
+src_compile() {
+ perl Makefile.PL INSTALL_BASE=/usr || die
+ emake || die
+}
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ emake test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README TODO
+}