summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-26 08:39:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-26 08:39:54 +0000
commit87a1f17ee10a820be8a3a1bfde6ea11c51c18f80 (patch)
tree853ceb19e6f6b2a6adc76ef859b471171bfd2534 /media-tv
parentStable on x86. (diff)
downloadgentoo-2-87a1f17ee10a820be8a3a1bfde6ea11c51c18f80.tar.gz
gentoo-2-87a1f17ee10a820be8a3a1bfde6ea11c51c18f80.tar.bz2
gentoo-2-87a1f17ee10a820be8a3a1bfde6ea11c51c18f80.zip
Add patch to fix installation when using parallel make.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xdtv/ChangeLog6
-rw-r--r--media-tv/xdtv/files/xdtv-2.3.2-parallel-install.patch13
-rw-r--r--media-tv/xdtv/xdtv-2.3.2-r1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/media-tv/xdtv/ChangeLog b/media-tv/xdtv/ChangeLog
index eeb196da194b..e29ad6be309c 100644
--- a/media-tv/xdtv/ChangeLog
+++ b/media-tv/xdtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/xdtv
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xdtv/ChangeLog,v 1.32 2006/06/23 22:42:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xdtv/ChangeLog,v 1.33 2006/06/26 08:39:54 flameeyes Exp $
+
+ 26 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/xdtv-2.3.2-parallel-install.patch, xdtv-2.3.2-r1.ebuild:
+ Add patch to fix installation when using parallel make.
23 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> xdtv-2.3.2-r1.ebuild:
Replace PIC conditionals with __PIC__ conditionals, as suggested by
diff --git a/media-tv/xdtv/files/xdtv-2.3.2-parallel-install.patch b/media-tv/xdtv/files/xdtv-2.3.2-parallel-install.patch
new file mode 100644
index 000000000000..00f9332d424d
--- /dev/null
+++ b/media-tv/xdtv/files/xdtv-2.3.2-parallel-install.patch
@@ -0,0 +1,13 @@
+Index: xdtv-2.3.2/src/Makefile.am
+===================================================================
+--- xdtv-2.3.2.orig/src/Makefile.am
++++ xdtv-2.3.2/src/Makefile.am
+@@ -149,7 +149,7 @@ xdtv_v4l_conf_LDADD = @X_LIBS@ -lX11 @LI
+ xdtv_wizard_SOURCES = xdtv_wizard.c translation.c
+ xdtv_wizard_LDADD = @X_LIBS@ @LIBXAW@ @LIBXMU@ @LIBXT@ @LIBXPM@ @LIBXEXT@ -lX11
+
+-install-exec-local:
++install-exec-local: install-binPROGRAMS
+ chmod u+s $(DESTDIR)$(prefix)/bin/xdtv_v4l-conf
+
+ xdtv_scantv_LDADD = @LIBZVBI@ @LIBM@ @LIBPTHREAD@
diff --git a/media-tv/xdtv/xdtv-2.3.2-r1.ebuild b/media-tv/xdtv/xdtv-2.3.2-r1.ebuild
index 52bb7a2d9cd8..3112fe98f74a 100644
--- a/media-tv/xdtv/xdtv-2.3.2-r1.ebuild
+++ b/media-tv/xdtv/xdtv-2.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xdtv/xdtv-2.3.2-r1.ebuild,v 1.2 2006/06/23 22:42:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xdtv/xdtv-2.3.2-r1.ebuild,v 1.3 2006/06/26 08:39:54 flameeyes Exp $
inherit font multilib autotools flag-o-matic
@@ -108,6 +108,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-2.3.0-setXid.patch"
epatch "${FILESDIR}/${P}-strict-aliasing.patch"
+ epatch "${FILESDIR}/${P}-parallel-install.patch"
# ffmpeg doesn'g use libtool, so the condition for PIC code
# is __PIC__, not PIC.