summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-03-08 05:09:02 +0000
committerBrian Jackson <iggy@gentoo.org>2004-03-08 05:09:02 +0000
commit1ad887d1f257d03d1d6fd586b4c183ab98e97c5f (patch)
tree88507e041f6e472621ed86c72ff1bb25a12038c2 /media-tv/ivtv
parentMoved to app-laptop from sys-apps (Manifest recommit) (diff)
downloadgentoo-2-1ad887d1f257d03d1d6fd586b4c183ab98e97c5f.tar.gz
gentoo-2-1ad887d1f257d03d1d6fd586b4c183ab98e97c5f.tar.bz2
gentoo-2-1ad887d1f257d03d1d6fd586b4c183ab98e97c5f.zip
initial version
Diffstat (limited to 'media-tv/ivtv')
-rw-r--r--media-tv/ivtv/ChangeLog10
-rw-r--r--media-tv/ivtv/Manifest3
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.1.9-r13
-rw-r--r--media-tv/ivtv/ivtv-0.1.9-r1.ebuild105
4 files changed, 121 insertions, 0 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
new file mode 100644
index 000000000000..56deab6d182c
--- /dev/null
+++ b/media-tv/ivtv/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-tv/ivtv
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.1 2004/03/08 05:09:02 iggy Exp $
+
+*ivtv-0.1.9-r1 (07 Mar 2004)
+
+ 07 Mar 2004; Brian Jackson <iggy@gentoo.org> ivtv-0.1.9-r1.ebuild:
+ initial version, I've had this locally for a little while, maybe more people
+ can use it now
+
diff --git a/media-tv/ivtv/Manifest b/media-tv/ivtv/Manifest
new file mode 100644
index 000000000000..5a793622a3f9
--- /dev/null
+++ b/media-tv/ivtv/Manifest
@@ -0,0 +1,3 @@
+MD5 e67d701da76af2e1f4c6b0da8fceac00 ivtv-0.1.9-r1.ebuild 2929
+MD5 5c19f8081e8cb92b74b76e7582745736 files/driver_makefile.patch 495
+MD5 5f8ee4e434626f37d191131c01e61bf2 files/digest-ivtv-0.1.9-r1 191
diff --git a/media-tv/ivtv/files/digest-ivtv-0.1.9-r1 b/media-tv/ivtv/files/digest-ivtv-0.1.9-r1
new file mode 100644
index 000000000000..8943c7fb0bbc
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.1.9-r1
@@ -0,0 +1,3 @@
+MD5 ff350ebc9f3f593031085e63381ca362 ivtv-0.1.9.tar.gz 168331
+MD5 c34803bc1ca86567076ac7dc0df91076 pvr250_17_21288.exe 2615322
+MD5 30cbbc40ded9fc30431001e2ee31924b ivtv-0.1.9-r1.patch 160604
diff --git a/media-tv/ivtv/ivtv-0.1.9-r1.ebuild b/media-tv/ivtv/ivtv-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..c90cffe4e173
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.1.9-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.1.9-r1.ebuild,v 1.1 2004/03/08 05:09:02 iggy Exp $
+
+# TODO
+# the "Gentoo way" is to use /usr/src/linux, not the running kernel
+# make it detect whether it's a 2.6 kernel and patch if necessary
+
+inherit eutils
+
+DESCRIPTION="ivtv driver for Hauppauge PVR[23]50 cards"
+HOMEPAGE="http://ivtv.sourceforge.net"
+
+SRC_URI="mirror://sourceforge/ivtv/${P}.tar.gz
+ http://hauppauge.lightpath.net/software/pvr250/pvr250_17_21288.exe
+ mirror://gentoo/${PF}.patch"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE="lirc"
+
+DEPEND="lirc? app-misc/lirc
+ !virtual/ivtv-driver"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/ivtv-driver"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${WORKDIR}/ivtv
+ epatch ${DISTDIR}/${PF}.patch || die "${PF} patch failed"
+}
+
+src_compile() {
+ cd ${WORKDIR}/ivtv/utils
+ cp ${DISTDIR}/pvr250_17_21288.exe .
+ dodir /lib/modules
+ touch ${D}/lib/modules/ivtv-{enc,dec}-fw.bin
+ ./ivtvfwextract.pl pvr250_17_21288.exe \
+ ${D}/lib/modules/ivtv-enc-fw.bin \
+ ${D}/lib/modules/ivtv-dec-fw.bin
+
+# if `grep -q I2C_VERSION.*2\.8 /usr/src/linux/include/linux/i2c.h` ;then
+# einfo "found new i2c in your kernel source"
+# sed -i -e \
+# 's:^#CFLAGS += -DNEW_I2C:CFLAGS += -DNEW_I2C:' \
+# ${WORKDIR}/ivtv/driver/Makefile
+# fi
+
+ cd ${WORKDIR}/ivtv/driver
+ make || die "build of driver failed"
+
+ cd ${WORKDIR}/ivtv/utils
+ make || die "build of utils failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/ivtv
+ dodoc README doc/*
+
+ cd ${WORKDIR}/ivtv/utils
+ dobin test_ioctl ivtvfbctl ivtvplay ptune-ui.pl ptune.pl record-v4l2.pl
+ newdoc README README.utils
+ dodoc README.mythtv-ivtv README.ptune
+
+ cd ${WORKDIR}/ivtv/driver
+ make DESTDIR=${D} install || die "installation of driver failed"
+
+ dodir /etc/modules.d
+
+ echo <<-myEOF >${D}/etc/modules.d/ivtv
+ alias char-major-81 videodev
+ alias char-major-81-0 ivtv
+ options ivtv debug=1
+ options tuner type=2
+ options saa7127 enable_output=1 output_select=0
+ options msp3400 once=1 simple=1
+ add below ivtv msp3400 saa7115 tuner
+ post-install ivtv /usr/local/bin/test_ioctl -d /dev/video0 -u 0x3000
+ myEOF
+
+ if [ `has app-misc/lirc` ] || [ `use lirc` ] ; then
+ echo "alias char-major-61 lirc_i2c" >> ${D}/etc/modules.d/ivtv
+ echo "add above ivtv lirc_dev lirc_i2c" >> ${D}/etc/modules.d/ivtv
+ else
+ einfo "Not enabling lirc support. emerge lirc to get it."
+ fi
+
+}
+
+pkg_postinst() {
+ depmod -ae
+
+ einfo "You now have the driver for the Hauppauge PVR-[23]50 cards."
+ einfo "Add ivtv to /etc/modules.autoload.d/kernel-2.X"
+ einfo "You'll now need an application to watch tv. MythTV is the only choice at"
+ einfo "the moment. To get the ir remote working, you'll need to emerge lirc"
+ einfo "with the following env variable set:"
+ einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61"
+ einfo " --with-port=none --with-irq=none\""
+ einfo "see http://ivtv.sourceforge.net for more info"
+}