summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-09 09:02:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-09 09:02:52 +0000
commita835ebbb0f2a624dea5c8394db48379f6fa4f710 (patch)
treef5e3f10582431928fdc540a24ffd65e65057bec8 /media-sound
parentversion bump (diff)
downloadgentoo-2-a835ebbb0f2a624dea5c8394db48379f6fa4f710.tar.gz
gentoo-2-a835ebbb0f2a624dea5c8394db48379f6fa4f710.tar.bz2
gentoo-2-a835ebbb0f2a624dea5c8394db48379f6fa4f710.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/patchage/ChangeLog9
-rw-r--r--media-sound/patchage/files/patchage-0.4.1-gcc43.patch12
-rw-r--r--media-sound/patchage/patchage-0.4.1.ebuild (renamed from media-sound/patchage/patchage-0.4.0.ebuild)28
3 files changed, 39 insertions, 10 deletions
diff --git a/media-sound/patchage/ChangeLog b/media-sound/patchage/ChangeLog
index 5e6808895507..11fd7fa79977 100644
--- a/media-sound/patchage/ChangeLog
+++ b/media-sound/patchage/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/patchage
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/ChangeLog,v 1.1 2008/05/29 08:46:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/ChangeLog,v 1.2 2008/07/09 09:02:51 aballier Exp $
+
+*patchage-0.4.1 (09 Jul 2008)
+
+ 09 Jul 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/patchage-0.4.1-gcc43.patch, -patchage-0.4.0.ebuild,
+ +patchage-0.4.1.ebuild:
+ version bump
*patchage-0.4.0 (29 May 2008)
diff --git a/media-sound/patchage/files/patchage-0.4.1-gcc43.patch b/media-sound/patchage/files/patchage-0.4.1-gcc43.patch
new file mode 100644
index 000000000000..23a126753c51
--- /dev/null
+++ b/media-sound/patchage/files/patchage-0.4.1-gcc43.patch
@@ -0,0 +1,12 @@
+Index: patchage-0.4.1/src/PatchageEvent.hpp
+===================================================================
+--- patchage-0.4.1.orig/src/PatchageEvent.hpp
++++ patchage-0.4.1/src/PatchageEvent.hpp
+@@ -24,6 +24,7 @@
+ #include <alsa/asoundlib.h>
+ #endif
+ #include "PatchagePort.hpp"
++#include <cstring>
+
+ class Patchage;
+
diff --git a/media-sound/patchage/patchage-0.4.0.ebuild b/media-sound/patchage/patchage-0.4.1.ebuild
index dabca0bf2c37..9432e93c0821 100644
--- a/media-sound/patchage/patchage-0.4.0.ebuild
+++ b/media-sound/patchage/patchage-0.4.1.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/patchage-0.4.0.ebuild,v 1.1 2008/05/29 08:46:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/patchage-0.4.1.ebuild,v 1.1 2008/07/09 09:02:51 aballier Exp $
+
+EAPI=1
+
+inherit eutils
DESCRIPTION="Modular patch bay for audio and MIDI systems"
HOMEPAGE="http://wiki.drobilla.net/Patchage"
@@ -9,27 +13,33 @@ SRC_URI="http://download.drobilla.net/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="alsa debug jack lash"
+IUSE="alsa -dbus debug lash"
-RDEPEND=">=media-libs/raul-0.4.0
- >=x11-libs/flowcanvas-0.4.0
+RDEPEND=">=media-libs/raul-0.5.0
+ >=x11-libs/flowcanvas-0.5.0
dev-cpp/glibmm
dev-cpp/libglademm
dev-cpp/libgnomecanvasmm
dev-libs/boost
- jack? ( >=media-sound/jack-audio-connection-kit-0.107 )
+ >=media-sound/jack-audio-connection-kit-0.107
lash? ( >=media-sound/lash-0.5.2 )
- alsa? ( media-libs/alsa-lib )"
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-libs/dbus-glib )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_compile() {
econf $(use_enable debug) \
$(use_enable debug pointer-debug) \
$(use_enable alsa ) \
- $(use_enable jack enable-jack) \
- $(use_enable jack) \
- $(use_enable lash)
+ $(use_enable lash) \
+ $(use_enable dbus jack-dbus)
emake || die "make failed"
}