summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-11 14:05:10 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-11 14:05:10 +0000
commit89583c91b92ba757d1b5dce09de0fea7d0f85367 (patch)
tree692c74cee09c2fc0883873736f327ab19007fa43 /media-sound
parentVersion bump (see bug #188314). (diff)
downloadgentoo-2-89583c91b92ba757d1b5dce09de0fea7d0f85367.tar.gz
gentoo-2-89583c91b92ba757d1b5dce09de0fea7d0f85367.tar.bz2
gentoo-2-89583c91b92ba757d1b5dce09de0fea7d0f85367.zip
Fixed depends, USE flags, dodoc, installation, and more.
(Portage version: 2.1.3.4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mp3blaster/ChangeLog8
-rw-r--r--media-sound/mp3blaster/files/digest-mp3blaster-3.2.3-r1 (renamed from media-sound/mp3blaster/files/digest-mp3blaster-3.2.3)0
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild56
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.3.ebuild45
4 files changed, 63 insertions, 46 deletions
diff --git a/media-sound/mp3blaster/ChangeLog b/media-sound/mp3blaster/ChangeLog
index f259c81a176d..6a975f8aa8f6 100644
--- a/media-sound/mp3blaster/ChangeLog
+++ b/media-sound/mp3blaster/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mp3blaster
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.29 2007/07/30 12:14:26 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.30 2007/08/11 14:05:10 drac Exp $
+
+*mp3blaster-3.2.3-r1 (11 Aug 2007)
+
+ 11 Aug 2007; Samuli Suominen <drac@gentoo.org>
+ +mp3blaster-3.2.3-r1.ebuild:
+ Fixed depends, USE flags, dodoc, installation, and more.
30 Jul 2007; Markus Rothe <corsair@gentoo.org> mp3blaster-3.2.3.ebuild:
Added ~ppc64; bug #187111
diff --git a/media-sound/mp3blaster/files/digest-mp3blaster-3.2.3 b/media-sound/mp3blaster/files/digest-mp3blaster-3.2.3-r1
index 7f3ae2a8446c..7f3ae2a8446c 100644
--- a/media-sound/mp3blaster/files/digest-mp3blaster-3.2.3
+++ b/media-sound/mp3blaster/files/digest-mp3blaster-3.2.3-r1
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..043bee1baea6
--- /dev/null
+++ b/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild,v 1.1 2007/08/11 14:05:10 drac Exp $
+
+DESCRIPTION="Text console based program for playing audio files."
+HOMEPAGE="http://mp3blaster.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="esd lirc nas sdl sid vorbis"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ lirc? ( app-misc/lirc )
+ vorbis? ( >=media-libs/libvorbis-1 )
+ nas? ( >=media-libs/nas-1.8b )
+ sid? ( =media-libs/libsidplay-1* )
+ esd? ( media-sound/esound )
+ !sdl? ( dev-libs/pth )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ x11-misc/imake"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # File collision with media-sound/splay.
+ sed -i -e "s:splay.1:splay_mp3blaster.1:" Makefile.in
+ mv splay.1 splay_mp3blaster.1
+}
+
+src_compile() {
+ local myconf
+
+ if use sdl; then
+ myconf="${myconf} --disable-newthreads --without-pth --with-sdl --with-oss"
+ else
+ myconf="${myconf} --enable-newthreads --with-pth --with-oss"
+ fi
+
+ econf ${myconf} \
+ $(use_with lirc) \
+ $(use_with vorbis oggvorbis) \
+ $(use_with nas) \
+ $(use_with sid sidplay) \
+ $(use_with esd)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ # File collision with media-sound/splay.
+ mv "${D}"/usr/bin/splay "${D}"/usr/bin/splay_mp3blaster
+ dodoc AUTHORS BUGS ChangeLog CREDITS FAQ NEWS README TODO
+}
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
deleted file mode 100644
index 30279ab533ca..000000000000
--- a/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild,v 1.3 2007/07/30 12:14:26 corsair Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="Command line MP3 player."
-HOMEPAGE="http://mp3blaster.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86"
-LICENSE="GPL-2"
-IUSE="lirc mysql vorbis"
-
-DEPEND=">=sys-libs/ncurses-5.2
- mysql? ( virtual/mysql )
- lirc? ( app-misc/lirc )
- vorbis? ( >=media-libs/libvorbis-1.0_beta1 )"
-
-src_compile() {
- local myconf
- # Prevents collisions with media-sound/splay
- sed -i "s/splay.1/splay_mp3blaster.1/" Makefile.in\
- || die "sedding makefile failed"
- mv splay.1 splay_mp3blaster.1 || die "renaming splay man failed"
- ### Looks like NAS support is broken, at least with NAS 1.5 and
- ### mp3player 3.1.1 (Aug 13, agenkin@thpoon.com)
- ### Ditto nas-1.6c-r1, mp3blaster-3.2.0 (2004.06.23 - eradicator)
- myconf="${myconf} --without-nas \
- `use_with lirc` \
- `use_with mysql` \
- `use_with vorbis oggvorbis`"
-
- econf ${myconf} || die
- make CC="$(tc-getCC) ${CFLAGS}" CXX="$(tc-getCXX) ${CXXFLAGS}" || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- # Prevent collisions with media-sound/splay
- mv "${D}/usr/bin/splay" "${D}/usr/bin/splay_mp3blaster"\
- || die "moving splay to splay_mp3blaster failed"
- dodoc ANNOUNCE AUTHORS CREDITS ChangeLog FAQ NEWS README TODO
-}