summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-13 03:04:21 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-13 03:04:21 +0000
commit6dfc48308eee688aa19faa712e25cc61e2c277c6 (patch)
treeadc4ffdd7967e1b73e4c2a64f64a3f62e0a49e97 /media-sound
parentRAR license (shareware/proprietary) for app-arch/rar (diff)
downloadgentoo-2-6dfc48308eee688aa19faa712e25cc61e2c277c6.tar.gz
gentoo-2-6dfc48308eee688aa19faa712e25cc61e2c277c6.tar.bz2
gentoo-2-6dfc48308eee688aa19faa712e25cc61e2c277c6.zip
The init script 'alsasound' now loads before the kernel modules in
/etc/modules.autoload get loaded. This allows you to put stuff like snd-mixer-oss and snd-pcm-oss in /etc/modules.autoload and still use alsa's init script. Beware: this revision of the ebuild may upgrade your baselayout.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r6.ebuild81
-rw-r--r--media-sound/alsa-driver/files/alsasound8
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r61
4 files changed, 95 insertions, 3 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 1624d9d939fd..29215cd70755 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.9 2002/05/08 05:53:41 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.10 2002/05/13 03:04:21 agenkin Exp $
*alsa-driver-0.9.0_rc1 (27 Apr 2002)
+ 12 May 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-driver-0.9.0_rc1-r6.ebuild :
+
+ Updated the 'alsasound' init script so that it runs before the modules
+ from /etc/modules.autoload get loaded. This relies on baselayout >=1.7.9.
+
8 May 2002; Jon Nelson <jnelson@gentoo.org>
alsa-driver-0.9.0_rc1-r5.ebuild :
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r6.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r6.ebuild
new file mode 100644
index 000000000000..96b3a0599d37
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r6.ebuild,v 1.1 2002/05/13 03:04:21 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment variable accordingly
+[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/alsa"
+
+src_unpack() {
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ unpack ${A}
+ cd ${S}
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards=${ALSA_CARDS} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You might want to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/alsasound b/media-sound/alsa-driver/files/alsasound
index 45bdc6e2b6d8..d7dd7c69fde5 100644
--- a/media-sound/alsa-driver/files/alsasound
+++ b/media-sound/alsa-driver/files/alsasound
@@ -1,5 +1,8 @@
#!/sbin/runscript
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsasound,v 1.5 2002/04/27 21:19:32 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsasound,v 1.6 2002/05/13 03:04:21 agenkin Exp $
+#
+# Gentoo users: add this script to 'boot' run level.
+# ==================================================
#
# alsasound This shell script takes care of starting and stopping
# the ALSA sound driver.
@@ -31,7 +34,8 @@ aconnect=/usr/bin/aconnect
alsascrdir=/etc/alsa.d
depend() {
- need modules
+ need bootmisc localmount
+ before modules
provide alsa-modules
}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r6 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r6
new file mode 100644
index 000000000000..ab82b0c07726
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r6
@@ -0,0 +1 @@
+MD5 440feeb7a0932a9f40a059fe78b3d6b2 alsa-driver-0.9.0rc1.tar.bz2 1103418