summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-07-22 14:16:03 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-07-22 14:16:03 +0000
commit2dcbc031944c786e4c6395638f8dc4dd50501e53 (patch)
treeeb147b553499f9f1665240bfc1753ef66f85b3ea /media-sound
parentAdd local USE-flag scrobbler for media-plugins/audacious-plugins. (diff)
downloadgentoo-2-2dcbc031944c786e4c6395638f8dc4dd50501e53.tar.gz
gentoo-2-2dcbc031944c786e4c6395638f8dc4dd50501e53.tar.bz2
gentoo-2-2dcbc031944c786e4c6395638f8dc4dd50501e53.zip
Revision bump. Upstream patch from Matti Hamalainen <ccr@tnsp.org> closes bug #228365.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog9
-rw-r--r--media-sound/audacious/audacious-1.5.1-r1.ebuild77
-rw-r--r--media-sound/audacious/files/1.5.1-commandline-options.patch43
3 files changed, 128 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index e1bdbdc65cac..ffc72aba7a72 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.148 2008/05/24 00:34:54 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.149 2008/07/22 14:16:02 chainsaw Exp $
+
+*audacious-1.5.1-r1 (22 Jul 2008)
+
+ 22 Jul 2008; <chainsaw@gentoo.org> +files/1.5.1-commandline-options.patch,
+ +audacious-1.5.1-r1.ebuild:
+ Revision bump. Upstream patch from Matti Hamalainen <ccr@tnsp.org> closes
+ bug #228365.
*audacious-1.5.1 (24 May 2008)
diff --git a/media-sound/audacious/audacious-1.5.1-r1.ebuild b/media-sound/audacious/audacious-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..bd86e86ed6e3
--- /dev/null
+++ b/media-sound/audacious/audacious-1.5.1-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.5.1-r1.ebuild,v 1.1 2008/07/22 14:16:02 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec chardet nls libsamplerate session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.14
+ >=dev-libs/libmcs-0.7.1-r1
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=x11-libs/cairo-1.2.4
+ >=x11-libs/gtk+-2.10
+ >=x11-libs/pango-1.8.0
+ libsamplerate? ( media-libs/libsamplerate )
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.5.1-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Bug #228365, patch by Matti Hamalainen <ccr@tnsp.org>
+ epatch "${FILESDIR}/${PV}-commandline-options.patch"
+}
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 1.5"
+ elog "Plugins compiled against 1.3 or 1.4 will not be loaded."
+}
diff --git a/media-sound/audacious/files/1.5.1-commandline-options.patch b/media-sound/audacious/files/1.5.1-commandline-options.patch
new file mode 100644
index 000000000000..f30e27f515b1
--- /dev/null
+++ b/media-sound/audacious/files/1.5.1-commandline-options.patch
@@ -0,0 +1,43 @@
+
+--- a/src/audacious/main.c Sun May 25 15:12:17 2008 +0200
++++ b/src/audacious/main.c Thu May 29 01:03:13 2008 +0300
+@@ -315,7 +315,7 @@ parse_cmd_line_options(gint *argc, gchar
+ }
+
+ static void
+-handle_cmd_line_options()
++handle_cmd_line_options(gboolean skip)
+ {
+ gchar **filenames = options.filenames;
+ #ifdef USE_DBUS
+@@ -430,7 +430,7 @@ handle_cmd_line_options()
+ } /* is_running */
+ else
+ #endif
+- { /* !is_running */
++ if (!skip) { /* !is_running */
+ if (filenames != NULL)
+ {
+ gint pos = 0;
+@@ -715,7 +715,7 @@ main(gint argc, gchar ** argv)
+
+ signal_handlers_init();
+
+- handle_cmd_line_options();
++ handle_cmd_line_options(TRUE);
+
+ if (options.headless == FALSE)
+ {
+@@ -734,6 +734,8 @@ main(gint argc, gchar ** argv)
+
+ plugin_system_init();
+ playlist_system_init();
++
++ handle_cmd_line_options(FALSE);
+
+ #ifdef USE_DBUS
+ init_dbus();
+
+
+
+