summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-10 20:25:32 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-10 20:25:32 +0000
commit142841ebe7eff9c9e0cbd4951f5f5d571df02a09 (patch)
treedec79fdfe2887ddb2ec66541c0776b2a4c663854 /media-sound/zinf
parentversion bump (diff)
downloadgentoo-2-142841ebe7eff9c9e0cbd4951f5f5d571df02a09.tar.gz
gentoo-2-142841ebe7eff9c9e0cbd4951f5f5d571df02a09.tar.bz2
gentoo-2-142841ebe7eff9c9e0cbd4951f5f5d571df02a09.zip
Replacement for Freeamp. Submitted by CJ Kucera. Fixes #4090
Diffstat (limited to 'media-sound/zinf')
-rw-r--r--media-sound/zinf/ChangeLog13
-rw-r--r--media-sound/zinf/files/digest-zinf-2.2.01
-rw-r--r--media-sound/zinf/zinf-2.2.0.ebuild64
3 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/zinf/ChangeLog b/media-sound/zinf/ChangeLog
new file mode 100644
index 000000000000..cc117afd00bd
--- /dev/null
+++ b/media-sound/zinf/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-sound/zinf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.1 2002/07/10 20:25:32 rphillips Exp $
+
+*zinf-2.2.0 (10 Jul 2002)
+
+ 10 Jul 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-sound/zinf/files/digest-zinf-2.2.0 b/media-sound/zinf/files/digest-zinf-2.2.0
new file mode 100644
index 000000000000..5440be49fc40
--- /dev/null
+++ b/media-sound/zinf/files/digest-zinf-2.2.0
@@ -0,0 +1 @@
+MD5 0484ae0c4a462a347054892b32fdcfe9 zinf-2.2.0.tar.gz 2163858
diff --git a/media-sound/zinf/zinf-2.2.0.ebuild b/media-sound/zinf/zinf-2.2.0.ebuild
new file mode 100644
index 000000000000..90df0a01a6a8
--- /dev/null
+++ b/media-sound/zinf/zinf-2.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.0.ebuild,v 1.1 2002/07/10 20:25:32 rphillips Exp $
+
+use arts &&
+use arts && inherit kde-functions && set-kdedir
+
+DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support, previously called FreeAmp"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.zinf.org/"
+S=${WORKDIR}/${P}
+
+RDEPEND="virtual/glibc
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=sys-libs/zlib-1.1.3 >=sys-libs/ncurses-5.2
+ ~media-libs/freetype-1.3.1 >=media-libs/musicbrainz-1.0.1
+ esd? ( media-sound/esound ) alsa? ( media-libs/alsa-lib )
+ gnome? ( gnome-base/ORBit )
+ gtk? ( >=media-libs/gdk-pixbuf-0.8 )
+ X? ( virtual/x11 ) arts? ( kde-base/kdelibs )
+ oggvorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND} dev-lang/nasm sys-devel/perl"
+LICENSE="GPL-2"
+SLOT="0"
+
+# Unfortunately you can't selectively build a lot of the features. Therefore
+# this whole package is essentially a judgement call. However, I've made the
+# DEPEND in a strategic manner to ensure that your USE variable is respected
+# when the knobs are *set*.
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`use arts`" ]; then
+ cd ${S}/io/arts/src
+ cp artspmo.cpp 1
+ sed -e 's:artsc/artsc.h:artsc.h:g' 1 > artspmo.cpp
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+ use alsa || myconf="${myconf} --disable-alsa"
+ use esd || myconf="${myconf} --disable-esd"
+ use arts && myconf="${myconf} --with-extra-includes=${KDEDIR}/include"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ make ; assert "compile problem :("
+}
+
+src_install() {
+
+ into /usr ; dobin zinf
+ exeinto /usr/lib/zinf/plugins ; doexe plugins/*
+ insinto /usr/share/zinf/themes ; doins themes/*
+ dodir /usr/share/zinf/fonts
+
+ dodoc AUTHORS CHANGES COPYING NEWS README README.linux
+
+}