summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
commit67c8b060271109f68d8b0a44de61d297ddfbe2e7 (patch)
tree42ce8164da9dd6d55caa82dfe6832b4a2a0a6ad5 /media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.gz
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.bz2
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.zip
Diffstat (limited to 'media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild')
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild b/media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild
index 33d4b39e2c8d..ebb63b3aa823 100644
--- a/media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild
+++ b/media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild,v 1.4 2005/07/25 13:42:03 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.1.1.ebuild,v 1.1 2005/04/29 21:37:17 luckyduck Exp $
inherit flag-o-matic eutils
@@ -12,14 +12,14 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug howl vorbis"
DEPEND="sys-libs/zlib
media-libs/libid3tag
sys-libs/gdbm
- debug? ( dev-util/efence )
howl? ( >=net-misc/howl-0.9.2 )
+ debug? ( dev-util/efence )
vorbis? ( media-libs/libvorbis )"
src_compile() {
@@ -38,9 +38,10 @@ src_compile() {
myconf="--disable-howl"
fi
- econf \
- $(use_enable vorbis oggvorbis) \
- ${myconf} || die "configure failed"
+ # vorbis support?
+ use vorbis && myconf="${myconf} --enable-oggvorbis"
+
+ econf ${myconf} || die "configure failed"
emake || die "make failed"
}