summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-23 01:50:22 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-23 01:50:22 +0000
commit5926d0937c684938d7047a6b2c86fbb4749eada5 (patch)
tree6ad413ed9763b42ea0ddbf951117824eda854981 /media-sound/mpg123
parentFix error building docs, bug 470856. (diff)
downloadgentoo-2-5926d0937c684938d7047a6b2c86fbb4749eada5.tar.gz
gentoo-2-5926d0937c684938d7047a6b2c86fbb4749eada5.tar.bz2
gentoo-2-5926d0937c684938d7047a6b2c86fbb4749eada5.zip
Version bump.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog7
-rw-r--r--media-sound/mpg123/mpg123-1.15.4.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index 2de0b3bd8a85..3a314304cdd5 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpg123
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.282 2013/04/04 06:47:17 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.283 2013/05/23 01:50:22 radhermit Exp $
+
+*mpg123-1.15.4 (23 May 2013)
+
+ 23 May 2013; Tim Harder <radhermit@gentoo.org> +mpg123-1.15.4.ebuild:
+ Version bump.
*mpg123-1.15.3 (04 Apr 2013)
diff --git a/media-sound/mpg123/mpg123-1.15.4.ebuild b/media-sound/mpg123/mpg123-1.15.4.ebuild
new file mode 100644
index 000000000000..453f07d1fa9d
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.15.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-1.15.4.ebuild,v 1.1 2013/05/23 01:50:22 radhermit Exp $
+
+EAPI=5
+inherit toolchain-funcs libtool
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://www.mpg123.org/"
+SRC_URI="http://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="3dnow 3dnowext alsa altivec coreaudio int-quality ipv6 jack mmx nas oss portaudio pulseaudio sdl sse"
+
+RDEPEND="app-admin/eselect-mpg123
+ >=sys-devel/libtool-2.2.6b
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ elibtoolize # for Darwin bundles
+}
+
+src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio="${_audio} ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+
+ use altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
+ _cpu=generic_fpu
+ elif use x86-macos ; then
+ # ASM doesn't work quite as expected with the Darwin linker
+ _cpu=generic_fpu
+ else
+ use mmx && _cpu=mmx
+ use 3dnow && _cpu=3dnow
+ use sse && _cpu=x86
+ use 3dnowext && _cpu=x86
+ fi
+
+ econf \
+ --with-optimization=0 \
+ --with-audio="${_audio}" \
+ --with-default-audio=${_output} \
+ --with-cpu=${_cpu} \
+ --enable-network \
+ $(use_enable ipv6) \
+ --enable-int-quality=$(usex int-quality)
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}