summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-09-11 06:23:50 +0000
committerChristoph Mende <angelos@gentoo.org>2010-09-11 06:23:50 +0000
commitcb6bbfd6296bb2d8bfd759ab019a7d275f5fe8a9 (patch)
treee45a07e55d4d24d1fe582c590d821c7e0a060530 /media-sound/mpdscribble
parentVersion bump, remove old (diff)
downloadgentoo-2-cb6bbfd6296bb2d8bfd759ab019a7d275f5fe8a9.tar.gz
gentoo-2-cb6bbfd6296bb2d8bfd759ab019a7d275f5fe8a9.tar.bz2
gentoo-2-cb6bbfd6296bb2d8bfd759ab019a7d275f5fe8a9.zip
Fix config file install path (bug #327959)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpdscribble')
-rw-r--r--media-sound/mpdscribble/ChangeLog6
-rw-r--r--media-sound/mpdscribble/files/mpdscribble-0.19-config_path.patch22
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.19.ebuild6
3 files changed, 31 insertions, 3 deletions
diff --git a/media-sound/mpdscribble/ChangeLog b/media-sound/mpdscribble/ChangeLog
index 864373293660..15e815de1bb6 100644
--- a/media-sound/mpdscribble/ChangeLog
+++ b/media-sound/mpdscribble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mpdscribble
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.37 2010/07/08 19:13:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.38 2010/09/11 06:23:50 angelos Exp $
+
+ 06 Sep 2010; <angelos@gentoo.org> mpdscribble-0.19.ebuild,
+ +files/mpdscribble-0.19-config_path.patch:
+ Fix config file install path (bug #327959)
08 Jul 2010; Raúl Porcel <armin76@gentoo.org> mpdscribble-0.19.ebuild:
sparc stable wrt #320929
diff --git a/media-sound/mpdscribble/files/mpdscribble-0.19-config_path.patch b/media-sound/mpdscribble/files/mpdscribble-0.19-config_path.patch
new file mode 100644
index 000000000000..c352410ef6be
--- /dev/null
+++ b/media-sound/mpdscribble/files/mpdscribble-0.19-config_path.patch
@@ -0,0 +1,22 @@
+diff --git a/work/mpdscribble-0.19/Makefile.am b/work/mpdscribble-0.19/Makefile.am
+index 626fde8..40862cb 100644
+--- a/work/mpdscribble-0.19/Makefile.am
++++ b/work/mpdscribble-0.19/Makefile.am
+@@ -61,12 +61,12 @@ install-dist_sysconfDATA:
+ test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
+ @list='$(dist_sysconf_DATA)'; \
+ for p in $$list; do \
+- dest=$(am__strip_dir) \
+- if test -f $(DESTDIR)$(sysconfdir)/$$dest; then \
+- echo "$@ will not overwrite existing $(DESTDIR)$(sysconfdir)/$$dest"; \
++ $(am__strip_dir) \
++ if test -f $(DESTDIR)$(sysconfdir)/$$f; then \
++ echo "$@ will not overwrite existing $(DESTDIR)$(sysconfdir)/$$f"; \
+ else \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- echo " $(INSTALL_SECURE) $$d$$p $(DESTDIR)$(sysconfdir)/$$dest"; \
+- $(INSTALL_SECURE) $$d$$p $(DESTDIR)$(sysconfdir)/$$dest; \
++ echo " $(INSTALL_SECURE) $$d$$p $(DESTDIR)$(sysconfdir)/$$f"; \
++ $(INSTALL_SECURE) $$d$$p $(DESTDIR)$(sysconfdir)/$$f; \
+ fi; \
+ done
diff --git a/media-sound/mpdscribble/mpdscribble-0.19.ebuild b/media-sound/mpdscribble/mpdscribble-0.19.ebuild
index 602daef1a81e..78add76ef384 100644
--- a/media-sound/mpdscribble/mpdscribble-0.19.ebuild
+++ b/media-sound/mpdscribble/mpdscribble-0.19.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.19.ebuild,v 1.6 2010/07/08 19:13:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.19.ebuild,v 1.7 2010/09/11 06:23:50 angelos Exp $
EAPI=2
+WANT_AUTOMAKE="1.11"
inherit autotools eutils
DESCRIPTION="An MPD client that submits information to Audioscrobbler"
@@ -22,7 +23,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.18-ldadd_gthread.patch
+ epatch "${FILESDIR}"/${PN}-0.18-ldadd_gthread.patch \
+ "${FILESDIR}"/${P}-config_path.patch
eautoreconf
}