summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-06 12:10:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-06 12:10:08 +0000
commit4387f013dcb64e4f55010eba523ff8f0d15be5d2 (patch)
tree3fe56732a187c09a32f008916f6e70fb1b9ca152 /media-sound/exaile
parentset VARTEXFONTS to avoid sandbox violations, bug #312343 (diff)
downloadgentoo-2-4387f013dcb64e4f55010eba523ff8f0d15be5d2.tar.gz
gentoo-2-4387f013dcb64e4f55010eba523ff8f0d15be5d2.tar.bz2
gentoo-2-4387f013dcb64e4f55010eba523ff8f0d15be5d2.zip
Version bump and remove USE="hal" wrt #313397.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog9
-rw-r--r--media-sound/exaile/exaile-0.3.0_alpha2.ebuild7
-rw-r--r--media-sound/exaile/exaile-0.3.1.0.ebuild73
-rw-r--r--media-sound/exaile/exaile-0.3.1_beta.ebuild5
4 files changed, 86 insertions, 8 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index 4a0805a3ff9b..7512907bf85e 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.64 2010/03/02 17:42:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.65 2010/04/06 12:10:08 ssuominen Exp $
+
+*exaile-0.3.1.0 (06 Apr 2010)
+
+ 06 Apr 2010; Samuli Suominen <ssuominen@gentoo.org>
+ exaile-0.3.0_alpha2.ebuild, exaile-0.3.1_beta.ebuild,
+ +exaile-0.3.1.0.ebuild:
+ Version bump and remove USE="hal" wrt #313397.
*exaile-0.3.1_beta (02 Mar 2010)
diff --git a/media-sound/exaile/exaile-0.3.0_alpha2.ebuild b/media-sound/exaile/exaile-0.3.0_alpha2.ebuild
index dbd81faf59ec..19ece008b0ec 100644
--- a/media-sound/exaile/exaile-0.3.0_alpha2.ebuild
+++ b/media-sound/exaile/exaile-0.3.0_alpha2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0_alpha2.ebuild,v 1.9 2009/08/09 13:58:31 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0_alpha2.ebuild,v 1.10 2010/04/06 12:10:08 ssuominen Exp $
EAPI=2
inherit eutils fdo-mime multilib python
@@ -14,7 +14,7 @@ SRC_URI="http://www.exaile.org/files/${PN}_${MY_PV}.tar.gz"
LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
-IUSE="cddb doc hal libnotify +libsexy nls"
+IUSE="cddb doc libnotify +libsexy nls"
RDEPEND="dev-python/dbus-python
>=media-libs/mutagen-1.10
@@ -25,7 +25,6 @@ RDEPEND="dev-python/dbus-python
media-plugins/gst-plugins-meta:0.10
libnotify? ( dev-python/notify-python )
libsexy? ( dev-python/sexy-python )
- hal? ( sys-apps/hal )
cddb? ( dev-python/cddb-py )"
DEPEND="doc? ( dev-python/epydoc )
nls? ( dev-util/intltool
diff --git a/media-sound/exaile/exaile-0.3.1.0.ebuild b/media-sound/exaile/exaile-0.3.1.0.ebuild
new file mode 100644
index 000000000000..b385a347380c
--- /dev/null
+++ b/media-sound/exaile/exaile-0.3.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.1.0.ebuild,v 1.1 2010/04/06 12:10:08 ssuominen Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/exaile/0.3.1/0.3.1/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.10
+ >=dev-python/pygtk-2.14
+ >=dev-python/pygobject-2.18
+ dev-python/gst-python:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ libnotify? ( dev-python/notify-python )
+ cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:exec python:exec $(PYTHON):" \
+ exaile tools/generate-launcher || die
+}
+
+src_compile() {
+ if use nls; then
+ emake locale || die
+ fi
+}
+
+src_install() {
+ local _no_locale
+ use nls || _no_locale=_no_locale
+
+ emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+ install${_no_locale} || die
+
+ dodoc README
+
+ insinto /usr/share/exaile/data
+ doins -r data/migrations || die
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/exaile-0.3.1_beta.ebuild b/media-sound/exaile/exaile-0.3.1_beta.ebuild
index 5be6294f9335..c95ae81e571b 100644
--- a/media-sound/exaile/exaile-0.3.1_beta.ebuild
+++ b/media-sound/exaile/exaile-0.3.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.1_beta.ebuild,v 1.1 2010/03/02 17:42:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.1_beta.ebuild,v 1.2 2010/04/06 12:10:08 ssuominen Exp $
EAPI=2
inherit eutils fdo-mime multilib python
@@ -15,7 +15,7 @@ SRC_URI="http://launchpad.net/exaile/${PV/_beta}/${MY_PV}/+download/${MY_P}.tar.
LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="cddb hal libnotify +libsexy nls"
+IUSE="cddb libnotify +libsexy nls"
RDEPEND="dev-python/dbus-python
>=media-libs/mutagen-1.10
@@ -26,7 +26,6 @@ RDEPEND="dev-python/dbus-python
media-plugins/gst-plugins-meta:0.10
libnotify? ( dev-python/notify-python )
libsexy? ( dev-python/sexy-python )
- hal? ( sys-apps/hal )
cddb? ( dev-python/cddb-py )"
DEPEND="nls? ( dev-util/intltool
sys-devel/gettext )"