summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-27 00:42:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-27 00:42:27 +0000
commiteed6c911401f725d53b1d62fd2a1c7522fe9280a (patch)
tree30df294b36f8ee5ce95bf8f631c2f4bbb6abb252 /media-sound/amarok
parentVersion bump. (diff)
downloadgentoo-2-eed6c911401f725d53b1d62fd2a1c7522fe9280a.tar.gz
gentoo-2-eed6c911401f725d53b1d62fd2a1c7522fe9280a.tar.bz2
gentoo-2-eed6c911401f725d53b1d62fd2a1c7522fe9280a.zip
Add patch t fix libvisual 0.4 support, thanks to Ian Monroe for providing the commit diff. Closes bug #140563.
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-1.4.1-r3.ebuild85
-rw-r--r--media-sound/amarok/files/amarok-1.4.1-libvisual.patch40
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.1-r33
4 files changed, 136 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 9aab775349a9..cd1401cba536 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.154 2006/07/26 21:21:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.155 2006/07/27 00:42:27 flameeyes Exp $
+
+*amarok-1.4.1-r3 (27 Jul 2006)
+
+ 27 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/amarok-1.4.1-libvisual.patch, +amarok-1.4.1-r3.ebuild:
+ Add patch t fix libvisual 0.4 support, thanks to Ian Monroe for providing
+ the commit diff. Closes bug #140563.
26 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> amarok-1.4.1-r2.ebuild:
Remove special case for automake 1.9, the ebuild forces that already when
diff --git a/media-sound/amarok/amarok-1.4.1-r3.ebuild b/media-sound/amarok/amarok-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..9ea2a0778b58
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.1-r3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.1-r3.ebuild,v 1.1 2006/07/27 00:42:27 flameeyes Exp $
+
+LANGS="az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it ja ka
+km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sl sr sr@Latn sv ta tg th tr uk uz
+zh_CN zh_TW"
+LANGS_DOC="da de es et fr it nl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+MY_PV="${PV/_rc/_RC}"
+MY_PV="${MY_PV/_beta/-beta}${PKG_SUFFIX}"
+MY_BASE_PV="${MY_PV/_RC*/}"
+MY_BASE_PV="${MY_BASE_PV/-beta*/}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+SRC_URI="mirror://sourceforge/amarok/${PN}-${MY_PV}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="aac kde mysql noamazon opengl postgres
+xmms visualization ipod ifp real njb"
+# kde: enables compilation of the konqueror sidebar plugin
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ >=media-libs/taglib-1.4
+ mysql? ( >=dev-db/mysql-4.0.16 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( media-libs/libgpod )
+ aac? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )
+ njb? ( >=media-libs/libnjb-2.2.4 )"
+
+RDEPEND="${DEPEND}
+ dev-lang/ruby"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+PATCHES="${FILESDIR}/${P}-libvisual.patch"
+
+need-kde 3.3
+
+src_compile() {
+ append-flags -fno-inline
+
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with ipod libgpod)
+ $(use_with aac mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ $(use_with njb libnjb)
+ --without-musicbrainz
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ mv "${D}/usr/share/services/lastfm.protocol" \
+ "${D}/usr/share/services/amaroklastfm.protocol"
+} \ No newline at end of file
diff --git a/media-sound/amarok/files/amarok-1.4.1-libvisual.patch b/media-sound/amarok/files/amarok-1.4.1-libvisual.patch
new file mode 100644
index 000000000000..8388aefd9bfb
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.4.1-libvisual.patch
@@ -0,0 +1,40 @@
+From: Ian Monroe <ian.monroe@gmail.com>
+Date: Jul 18, 2006 12:00 PM
+Subject: extragear/multimedia/amarok
+To: kde-commits@kde.org
+Cc: 130584-done@bugs.kde.org
+
+
+SVN commit 563853 by ianmonroe:
+
+ r5938@wasabi: ian | 2006-07-18 11:57:06 -0500
+ ProjectM works!
+ Fix libvisual 0.4.0 support. Patch by Dennis Smit, thanks to Joe Rabinoff
+ for the good bug report.
+ BUG:130584
+
+
+ _M . (directory)
+ M +1 -0 ChangeLog
+ M +5 -6 src/vis/libvisual/libvisual.cpp
+
+
++++ trunk/extragear/multimedia/amarok/src/vis/libvisual/libvisual.cpp #563852:563853
+@@ -301,13 +301,12 @@
+ static int
+ upload_callback( VisInput*, VisAudio *audio, void* )
+ {
+- for( uint i = 0; i < 1024; i+=2 )
+- {
+- // amarok provides us with dual channel interleaved PCM
+- audio->plugpcm[0][i] = pcm_data[i];
+- audio->plugpcm[1][i] = pcm_data[i+1];
+- }
++ VisBuffer buf;
+
++ visual_buffer_init( &buf, pcm_data, 1024, 0 );
++ visual_audio_samplepool_input( audio->samplepool, &buf, VISUAL_AUDIO_SAMPLE_RATE_44100,
++ VISUAL_AUDIO_SAMPLE_FORMAT_S16, VISUAL_AUDIO_SAMPLE_CHANNEL_STEREO );
++
+ return 0;
+ }
diff --git a/media-sound/amarok/files/digest-amarok-1.4.1-r3 b/media-sound/amarok/files/digest-amarok-1.4.1-r3
new file mode 100644
index 000000000000..62510a3d95d4
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.4.1-r3
@@ -0,0 +1,3 @@
+MD5 4ed6e766541c4227d1d8c8eb93d0b891 amarok-1.4.1.tar.bz2 13509939
+RMD160 d9df29c2a2a7b81aabb73c66b83190f0bc109094 amarok-1.4.1.tar.bz2 13509939
+SHA256 dbe4397d041a77f7ded063f50d5cfd2faf0e9efce9b4483589f751c20ff89ccd amarok-1.4.1.tar.bz2 13509939