summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-07-10 21:02:08 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-07-10 21:02:08 +0000
commit3b32a64ea258a728fe8026c7d0b991ddb2c3103b (patch)
tree6eafc66c3cc381b0989d1334c30f49fb0c4136a0 /media-sound/amarok
parentAdded new amarok version to the libmp4v2 mask. (diff)
downloadgentoo-2-3b32a64ea258a728fe8026c7d0b991ddb2c3103b.tar.gz
gentoo-2-3b32a64ea258a728fe8026c7d0b991ddb2c3103b.tar.bz2
gentoo-2-3b32a64ea258a728fe8026c7d0b991ddb2c3103b.zip
Added a patch to amarok-1.4.10_p20090130-r3 to support the new libmp4v2 - thanks to Samuli Suominen <ssuominen@gentoo.org> for the patch.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-1.4.10_p20090130-r3.ebuild123
-rw-r--r--media-sound/amarok/files/amarok-libmp4v2.patch70
3 files changed, 201 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 16ae844ab6a2..2171c3498f56 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.333 2009/07/04 15:55:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.334 2009/07/10 21:02:07 jmbsvicetto Exp $
+
+*amarok-1.4.10_p20090130-r3 (10 Jul 2009)
+
+ 10 Jul 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +files/amarok-libmp4v2.patch, +amarok-1.4.10_p20090130-r3.ebuild:
+ Added a patch to amarok-1.4.10_p20090130-r3 to support the new libmp4v2 -
+ thanks to Samuli Suominen <ssuominen@gentoo.org> for the patch.
04 Jul 2009; Raúl Porcel <armin76@gentoo.org>
amarok-1.4.10_p20090130-r2.ebuild:
diff --git a/media-sound/amarok/amarok-1.4.10_p20090130-r3.ebuild b/media-sound/amarok/amarok-1.4.10_p20090130-r3.ebuild
new file mode 100644
index 000000000000..ff04e0d46e7a
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.10_p20090130-r3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.10_p20090130-r3.ebuild,v 1.1 2009/07/10 21:02:07 jmbsvicetto Exp $
+
+EAPI="2"
+
+ARTS_REQUIRED="never"
+
+LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
+fr ga gl he hi hu id is it ja km ko ku lo lt mk ms nb nds ne nl nn pa
+pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn ss sv ta tg th tr uk uz
+zh_CN zh_TW"
+
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING="1"
+
+inherit kde
+
+PKG_SUFFIX=""
+
+MY_P="${P/_*/}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI="mirror://kde/stable/amarok/${PV/_*/}/src/${MY_P}.tar.bz2
+ mirror://gentoo/amarok-1.4.10-post20090130.diff.tar.bz2"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+
+SLOT="3.5"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mp4 kde mysql amazon opengl postgres
+visualization ipod ifp real njb mtp musicbrainz daap
+python"
+# kde: enables compilation of the konqueror sidebar plugin
+
+# Blocking previous amarok-1.4:0 versions
+RDEPEND="
+ !<media-sound/amarok-1.4.10_p20090130-r2
+ =dev-lang/ruby-1.8*
+ >=media-libs/taglib-1.4
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ ifp? ( media-libs/libifp )
+ ipod? ( >=media-libs/libgpod-0.5.2 )
+ kde? ( kde-base/konqueror:3.5 )
+ mp4? ( media-libs/libmp4v2 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ musicbrainz? ( media-libs/tunepimp )
+ mysql? ( >=virtual/mysql-4.0 )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ opengl? ( virtual/opengl )
+ postgres? ( virtual/postgresql-base )
+ real? (
+ media-libs/alsa-lib
+ media-video/realplayer
+ )
+ visualization? (
+ media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4*
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="${RDEPEND}
+ app-arch/unzip
+ daap? ( www-servers/mongrel )
+ python? ( dev-python/PyQt )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.9.1-libmtp-0.3.0-API.patch"
+ "${FILESDIR}/${PN}-1.4.10-gcc-4.3.patch"
+ "${FILESDIR}/${PN}-1.4.10-gcc44.patch"
+ "${FILESDIR}/${PN}-libmp4v2.patch"
+ "${WORKDIR}/${PN}-1.4.10-post20090130.diff"
+ "${WORKDIR}/${PN}-1.4.10-desktop-entry.diff"
+)
+
+need-kde 3.5
+
+src_configure() {
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="
+ $(use_enable amazon)
+ $(use_enable mysql)
+ $(use_enable postgres postgresql)
+ $(use_with daap)
+ $(use_with ifp)
+ $(use_with ipod libgpod)
+ $(use_with mp4 mp4v2)
+ $(use_with mtp libmtp)
+ $(use_with musicbrainz)
+ $(use_with njb libnjb)
+ $(use_with opengl)
+ $(use_with real helix)
+ $(use_with visualization libvisual)
+ --with-xine
+ --without-nmm
+ "
+
+ kde_src_configure
+}
+
+src_install() {
+ kde_src_install
+
+ # As much as I respect Ian, I'd rather leave Amarok to use mongrel
+ # from Portage, for security and policy reasons.
+ rm -rf "${D}${KDEDIR}"/share/apps/amarok/ruby_lib/rbconfig \
+ "${D}${KDEDIR}"/share/apps/amarok/ruby_lib/mongrel* \
+ "${D}${KDEDIR}"/share/apps/amarok/ruby_lib/rubygems* \
+ "${D}${KDEDIR}"/share/apps/amarok/ruby_lib/gem* \
+ "${D}${KDEDIR}"/$(get_libdir)/ruby_lib
+
+ if ! use python; then
+ rm -r "${D}${KDEDIR}"/share/apps/amarok/scripts/webcontrol \
+ || die "Unable to remove webcontrol."
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-libmp4v2.patch b/media-sound/amarok/files/amarok-libmp4v2.patch
new file mode 100644
index 000000000000..3ea88f053562
--- /dev/null
+++ b/media-sound/amarok/files/amarok-libmp4v2.patch
@@ -0,0 +1,70 @@
+diff -ur amarok-1.4.10.orig/amarok/configure.in.in amarok-1.4.10/amarok/configure.in.in
+--- amarok-1.4.10.orig/amarok/configure.in.in 2008-08-14 00:21:51.000000000 +0300
++++ amarok-1.4.10/amarok/configure.in.in 2009-07-10 17:58:31.000000000 +0300
+@@ -977,7 +977,7 @@
+ ac_cppflags_save=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS -I."
+ AC_CHECK_HEADERS(systems.h)
+- AC_CHECK_HEADERS([mp4.h], [have_mp4_h=yes], [],
++ AC_CHECK_HEADERS([mp4v2/mp4v2.h], [have_mp4_h=yes], [],
+ [#ifdef HAVE_SYSTEMS_H
+ # include <systems.h>
+ #endif
+diff -ur amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4properties.h amarok-1.4.10/amarok/src/metadata/mp4/mp4properties.h
+--- amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4properties.h 2008-08-14 00:21:51.000000000 +0300
++++ amarok-1.4.10/amarok/src/metadata/mp4/mp4properties.h 2009-07-10 17:57:45.000000000 +0300
+@@ -24,7 +24,7 @@
+
+ #include <audioproperties.h>
+ #include <tstring.h>
+-#include <mp4.h>
++#include <mp4v2/mp4v2.h>
+ // mp4.h drags in mp4_config.h that defines these
+ // get rid of them so they don't conflict with our config.h
+ #undef VERSION
+diff -ur amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4tag.h amarok-1.4.10/amarok/src/metadata/mp4/mp4tag.h
+--- amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4tag.h 2008-08-14 00:21:51.000000000 +0300
++++ amarok-1.4.10/amarok/src/metadata/mp4/mp4tag.h 2009-07-10 17:57:52.000000000 +0300
+@@ -23,7 +23,7 @@
+
+ #include <tag.h>
+ #include "mp4file.h"
+-#include <mp4.h>
++#include <mp4v2/mp4v2.h>
+
+ namespace TagLib {
+ diff -ur amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4file.cpp amarok-1.4.10/amarok/src/metadata/mp4/mp4file.cpp
+--- amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4file.cpp 2009-07-10 18:58:13.000000000 +0000
++++ amarok-1.4.10/amarok/src/metadata/mp4/mp4file.cpp 2009-07-10 18:59:11.000000000 +0000
+@@ -30,6 +30,8 @@
+ #include <audioproperties.h>
+
+ #include <stdint.h>
++#include <stdlib.h>
++#include <sys/types.h>
+
+ #define MP4V2_HAS_WRITE_BUG 1
+
+diff -ur amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4properties.cpp amarok-1.4.10/amarok/src/metadata/mp4properties.cpp
+--- amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4properties.cpp 2009-07-10 18:58:13.000000000 +0000
++++ amarok-1.4.10/amarok/src/metadata/mp4/mp4properties.cpp 2009-07-10 18:58:39.000000000 +0000
+@@ -30,6 +30,7 @@
+ #endif
+
+ #include <stdint.h>
++#include <sys/types.h>
+
+ #ifndef UINT64_TO_DOUBLE
+ #define UINT64_TO_DOUBLE(a) ((double)((int64_t)(a)))
+diff -ur amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4tag.cpp amarok-1.4.10/amarok/src/metadata/mp4/mp4tag.cpp
+--- amarok-1.4.10.orig/amarok/src/metadata/mp4/mp4tag.cpp 2009-07-10 18:58:13.000000000 +0000
++++ amarok-1.4.10/amarok/src/metadata/mp4/mp4tag.cpp 2009-07-10 18:59:36.000000000 +0000
+@@ -24,6 +24,8 @@
+
+ #include <tag.h>
+ #include <stdint.h>
++#include <stdlib.h>
++#include <sys/types.h>
+
+ using namespace TagLib;
+