summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-12-10 21:39:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-12-10 21:39:17 +0000
commit1f77eff5def593538a5efde3b0890292f2cbbb87 (patch)
treef21f190400571275c800eb65667821988086226c /media-sound/amarok
parentAdd weisso as proxy maintainer. (diff)
downloadgentoo-2-1f77eff5def593538a5efde3b0890292f2cbbb87.tar.gz
gentoo-2-1f77eff5def593538a5efde3b0890292f2cbbb87.tar.bz2
gentoo-2-1f77eff5def593538a5efde3b0890292f2cbbb87.zip
Version bump. Only ~x86 feel free to add any other keywords if it works for you, but i think the mysql problem needs to be handled first. See bug #238487.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/amarok-2.0.ebuild94
-rw-r--r--media-sound/amarok/metadata.xml5
3 files changed, 105 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index d35268107024..000088e60560 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.290 2008/12/08 14:07:24 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.291 2008/12/10 21:39:17 scarabeus Exp $
+
+*amarok-2.0 (10 Dec 2008)
+
+ 10 Dec 2008; <scarab@gentoo.org> metadata.xml, +amarok-2.0.ebuild:
+ Version bump.
08 Dec 2008; Tomas Chvatal <scarabeus@gentoo.org> amarok-1.90-r1.ebuild:
Make amarok optionaly depend on qt-opengl
diff --git a/media-sound/amarok/amarok-2.0.ebuild b/media-sound/amarok/amarok-2.0.ebuild
new file mode 100644
index 000000000000..f8d3973d0df5
--- /dev/null
+++ b/media-sound/amarok/amarok-2.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.0.ebuild,v 1.1 2008/12/10 21:39:17 scarabeus Exp $
+
+EAPI="2"
+
+NEED_KDE="4.1"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="2"
+IUSE="cdaudio daap debug ifp ipod mp3tunes mp4 mtp njb +semantic-desktop"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+
+DEPEND=">=app-misc/strigi-0.5.7
+ || (
+ >=dev-db/mysql-5.0[embedded]
+ >=dev-db/mysql-community-5.0[embedded]
+ )
+ >=media-libs/taglib-1.5
+ || ( media-sound/phonon x11-libs/qt-phonon:4 )
+ >=kde-base/kdelibs-${NEED_KDE}[opengl?,semantic-desktop?]
+ >=kde-base/plasma-workspace-${NEED_KDE}
+ x11-libs/qt-webkit:4
+ cdaudio? (
+ >=kde-base/libkcompactdisc-${NEED_KDE}
+ >=kde-base/libkcddb-${NEED_KDE}
+ )
+ ifp? ( media-libs/libifp )
+ ipod? ( >=media-libs/libgpod-0.4.2 )
+ mp3tunes? (
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ )
+ mp4? ( media-libs/libmp4v2 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ semantic-desktop? ( dev-libs/soprano[sesame2] )
+ !media-sound/amarok:4.1
+ kdeprefix? ( !media-sound/amarok:0 )
+ "
+
+RDEPEND="${DEPEND}
+ app-arch/unzip
+ daap? ( www-servers/mongrel )"
+
+src_configure() {
+ if use debug; then
+ mycmakeargs="${mycmakeargs} -DCMAKE_BUILD_TYPE=debugfull"
+ fi
+
+ if ! use mp3tunes; then
+ sed -e'/mp3tunes/ s:^:#DONOTWANT :' \
+ -i "${S}"/src/services/CMakeLists.txt \
+ || die "Deactivating mp3tunes failed."
+ fi
+
+ # Remove superfluous QT_WEBKIT
+ sed -e 's/ -DQT_WEBKIT//g' \
+ -i "${S}"/src/scriptengine/generator/generator/CMakeLists.txt \
+ || die "Removing unnecessary -DQT_WEBKIT failed."
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ipod Ipod)
+ $(cmake-utils_use_with ifp Ifp)
+ $(cmake-utils_use_with mp4 Mp4v2)
+ $(cmake-utils_use_with mtp Mtp)
+ $(cmake-utils_use_with njb Njb)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ #provided by kdelibs
+ rm "${D}"/"${KDEDIR}"/share/kde4/servicetypes/plasma-animator.desktop
+ rm "${D}"/"${KDEDIR}"/share/kde4/servicetypes/plasma-applet.desktop
+ rm "${D}"/"${KDEDIR}"/share/kde4/servicetypes/plasma-dataengine.desktop
+ rm "${D}"/"${KDEDIR}"/share/kde4/servicetypes/plasma-runner.desktop
+ rm "${D}"/"${KDEDIR}"/share/kde4/servicetypes/plasma-scriptengine.desktop
+ rm "${D}"/"${KDEDIR}"/share/kde4/servicetypes/plasma-containment.desktop
+ #provided by plasma-workspace
+ rm "${D}"/"${KDEDIR}"/share/kde4/services/plasma-animator-default.desktop
+ rm "${D}"/"${KDEDIR}"/lib64/kde4/plasma_animator_default.so
+}
diff --git a/media-sound/amarok/metadata.xml b/media-sound/amarok/metadata.xml
index 927a691cd63f..4b9ca5a5c6c2 100644
--- a/media-sound/amarok/metadata.xml
+++ b/media-sound/amarok/metadata.xml
@@ -38,6 +38,11 @@
package will not be redistributable, as it links to the non-GPL compatible
RealPlayer.
</flag>
+ <flag name="semantic-desktop">
+ Semantic desktop allows for storage of digital informationand its
+ metadata to allow the user to express his personal mental models, making
+ all information become intuitively accessible
+ </flag>
<flag name="visualization">Support visualization plugins through <pkg>media-libs/libvisual</pkg></flag>
</use>
</pkgmetadata>