summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-22 12:52:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-22 12:52:50 +0000
commit8bb2b3632755c435ba0c7d42f9c4c0e24920f649 (patch)
treea61f1062848d0ec540a210e22a95729be806e951 /media-plugins/vdr-osdpip
parentbump (diff)
downloadgentoo-2-8bb2b3632755c435ba0c7d42f9c4c0e24920f649.tar.gz
gentoo-2-8bb2b3632755c435ba0c7d42f9c4c0e24920f649.tar.bz2
gentoo-2-8bb2b3632755c435ba0c7d42f9c4c0e24920f649.zip
fix build with ffmpeg-1, part of bug #443196
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-plugins/vdr-osdpip')
-rw-r--r--media-plugins/vdr-osdpip/ChangeLog8
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch26
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild8
3 files changed, 37 insertions, 5 deletions
diff --git a/media-plugins/vdr-osdpip/ChangeLog b/media-plugins/vdr-osdpip/ChangeLog
index 0a43842590d2..43dd1ea8c1fa 100644
--- a/media-plugins/vdr-osdpip/ChangeLog
+++ b/media-plugins/vdr-osdpip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-osdpip
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.16 2012/10/20 18:02:23 hd_brummy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.17 2013/01/22 12:52:50 aballier Exp $
+
+ 22 Jan 2013; Alexis Ballier <aballier@gentoo.org> vdr-osdpip-0.1.1-r1.ebuild,
+ +files/vdr-osdpip-0.1.1-ffmpeg-1.patch:
+ fix build with ffmpeg-1, part of bug #443196
*vdr-osdpip-0.1.1-r1 (20 Oct 2012)
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch
new file mode 100644
index 000000000000..b0304ad5adc0
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch
@@ -0,0 +1,26 @@
+Index: osdpip-0.1.1/decoder.h
+===================================================================
+--- osdpip-0.1.1.orig/decoder.h
++++ osdpip-0.1.1/decoder.h
+@@ -34,7 +34,7 @@ extern "C"
+ #include <libavcodec/avcodec.h>
+ #ifdef USE_SWSCALE
+ #include <libswscale/swscale.h>
+- #include <libavcodec/opt.h>
++ #include <libavutil/opt.h>
+ #endif
+ #else
+ #include <ffmpeg/avcodec.h>
+Index: osdpip-0.1.1/osdpip.c
+===================================================================
+--- osdpip-0.1.1.orig/osdpip.c
++++ osdpip-0.1.1/osdpip.c
+@@ -73,8 +73,6 @@ bool cPluginOsdpip::ProcessArgs(int argc
+
+ bool cPluginOsdpip::Initialize(void)
+ {
+- // must be called before using avcodec lib
+- avcodec_init();
+ // register all the codecs (you can also register only the codec
+ // you wish to have smaller code)
+ avcodec_register_all();
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
index b82ad4783a05..1d78f700a991 100644
--- a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild,v 1.1 2012/10/20 18:02:23 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.1.1-r1.ebuild,v 1.2 2013/01/22 12:52:50 aballier Exp $
EAPI="4"
VERSION="880" # every bump, new version
-inherit vdr-plugin-2 flag-o-matic
+inherit vdr-plugin-2 flag-o-matic eutils
DESCRIPTION="VDR plugin: Show another channel in the OSD"
HOMEPAGE="http://projects.vdr-developer.org/projects/plg-osdpip"
@@ -27,4 +27,6 @@ src_prepare() {
# UINT64_C is needed by ffmpeg headers
append-cxxflags -D__STDC_CONSTANT_MACROS
+
+ epatch "${FILESDIR}/${P}-ffmpeg-1.patch"
}