summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-08-07 21:13:37 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-08-07 21:13:37 +0000
commitb841fc84f9535b64612601358c79d65850d87371 (patch)
treec77c792f2e5884c54010d2d2e8d030f12b16b0e4 /media-libs
parentMasking media-libs/xine-lib-1_rc0-r1 (diff)
downloadgentoo-2-b841fc84f9535b64612601358c79d65850d87371.tar.gz
gentoo-2-b841fc84f9535b64612601358c79d65850d87371.tar.bz2
gentoo-2-b841fc84f9535b64612601358c79d65850d87371.zip
Version bump.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog7
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-1_rc0-r11
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc0-r1.ebuild135
3 files changed, 142 insertions, 1 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 13d13791f295..e7077cd7bd7d 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.59 2003/08/03 03:51:40 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.60 2003/08/07 21:13:37 agenkin Exp $
02 Aug 2003; Jason Wever <weeve@gentoo.org> xine-lib-0.9.13-r3.ebuild,
xine-lib-1_beta12-r1.ebuild:
keyword and useflag dependency updates.
+*xine-lib-1_rc0-r1 (07 Aug 2003)
+
+ 07 Aug2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump to 1-rc0a.
+
*xine-lib-1_beta12-r1 (14 Jul 2003)
14 Jul 2003; <spider@gentoo.org> xine-lib-1_beta12-r1.ebuild:
diff --git a/media-libs/xine-lib/files/digest-xine-lib-1_rc0-r1 b/media-libs/xine-lib/files/digest-xine-lib-1_rc0-r1
new file mode 100644
index 000000000000..64463eb039a2
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-1_rc0-r1
@@ -0,0 +1 @@
+MD5 923015bd49902cd43cd8f191f0720e4c xine-lib-1-rc0a.tar.gz 4211552
diff --git a/media-libs/xine-lib/xine-lib-1_rc0-r1.ebuild b/media-libs/xine-lib/xine-lib-1_rc0-r1.ebuild
new file mode 100644
index 000000000000..cc1b8071a7a8
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1_rc0-r1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc0-r1.ebuild,v 1.1 2003/08/07 21:13:37 agenkin Exp $
+
+# this build doesn't play nice with -maltivec (gcc 3.2 only option) on ppc
+# Commenting this out in this ebuild, because CFLAGS and CXXFLAGS are unset
+# at make time any way.
+# Brandon Low (29 Apr 2003)
+# inherit flag-o-matic
+# filter-flags "-maltivec -mabi=altivec"
+# replace-flags k6-3 i686
+# replace-flags k6-2 i686
+# replace-flags k6 i686
+
+#13 Jul 2003: drobbins: build failure using -j5 on a dual Xeon in 1_beta12
+MAKEOPTS="$MAKEOPTS -j1"
+
+# This should normally be empty string, unless a release has a suffix.
+MY_PKG_SUFFIX="a"
+
+DESCRIPTION="Core libraries for Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${PN}-${PV/_/-}${MY_PKG_SUFFIX}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~sparc"
+IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa gnome"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ X? ( virtual/x11 )
+ avi? ( x86? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux ) )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9
+ dev-util/pkgconfig )
+ gnome? ( >=gnome-base/gnome-vfs-2.0
+ dev-util/pkgconfig )
+ >=media-libs/flac-1.0.4
+ >=media-libs/libsdl-1.1.5
+ >=media-libs/libfame-0.9.0
+ >=media-libs/xvid-0.9.0"
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${PV/_/-}${MY_PKG_SUFFIX}
+
+src_compile() {
+ # Make sure that the older libraries are not installed (bug #15081).
+ if [ -f /usr/lib/libxine.so.0 ]
+ then
+ einfo "Please uninstall older xine libraries.";
+ einfo "The compilation cannot proceed.";
+ die
+ fi
+
+ # Use the built-in dvdnav plugin.
+ local myconf="--with-included-dvdnav"
+
+ # Most of these are not working currently, but are here for completeness
+ # don't use the --disable-XXXtest because that defaults to ON not OFF
+ use X \
+ || myconf="${myconf} --disable-x11" # --disable-xv"
+ use esd \
+ || myconf="${myconf} --disable-esd" # --disable-esdtest"
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use alsa \
+ || myconf="${myconf} --disable-alsa" # --disable-alsatest"
+ use arts \
+ || myconf="${myconf} --disable-arts" # --disable-artstest"
+ use aalib \
+ || myconf="${myconf} --disable-aalib" # --disable-aalibtest"
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-vorbis"
+ #--disable-oggtest --disable-vorbistest"
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ einfo "myconf: ${myconf}"
+
+ # Very specific optimization is set by configure
+ # Should fix problems like the one found on bug #11779
+ # raker@gentoo.org (25 Dec 2002)
+ unset CFLAGS
+ unset CXXFLAGS
+
+ econf ${myconf} || die "Configure failed"
+
+ # since there is no --disable-gnomevfs flag we have to fix config.h by hand
+
+ cp config.h config.h.sed
+
+ if [ ! `use gnome` ]
+ then
+ einfo "supposedly not using gnome. disabling gnome-vfs support"
+ cp config.h config.h.sed
+ cat config.h.sed |sed -e s/\#define\ HAVE_GNOME_VFS\ 1/\#undef\ HAVE_GNOME_VFS/g >config.h
+ rm config.h.sed
+ fi
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+
+ # Xine's makefiles install some file incorrectly. (Gentoo bug #8583, #16112).
+ dodir /usr/share/xine/libxine1/fonts
+ mv ${D}/usr/share/*.xinefont.gz ${D}/usr/share/xine/libxine1/fonts/
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo
+ einfo "This library version 1 is incompatible with the plugins,"
+ einfo "designed for the prior library versions (such as xine-d4d,"
+ einfo "xine-d5d, xine-dmd, and xine-dvdnav."
+ einfo
+ einfo "Also make sure to remove your ~/.xine if upgrading from"
+ einfo "a previous version."
+ einfo
+}