summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-22 13:47:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-22 13:47:55 +0000
commitb81433fe3d41699d516c8939b81b2a22cd803fe6 (patch)
tree54af95e188965d1eb1b546c39abb8e5639a77dfe /media-libs
parentadd eclass debugging; remove redundant comments (diff)
downloadgentoo-2-b81433fe3d41699d516c8939b81b2a22cd803fe6.tar.gz
gentoo-2-b81433fe3d41699d516c8939b81b2a22cd803fe6.tar.bz2
gentoo-2-b81433fe3d41699d516c8939b81b2a22cd803fe6.zip
Add a new revision to reduce copy-on-write pages, also fix the sed for the pkgconfig file, and disable dependency tracking.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/dssi/ChangeLog11
-rw-r--r--media-libs/dssi/dssi-0.9.1-r1.ebuild46
-rw-r--r--media-libs/dssi/files/dssi-0.9.1-constants.patch70
3 files changed, 125 insertions, 2 deletions
diff --git a/media-libs/dssi/ChangeLog b/media-libs/dssi/ChangeLog
index ace4f8c4fa5e..5b9d6e5673f9 100644
--- a/media-libs/dssi/ChangeLog
+++ b/media-libs/dssi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/dssi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/dssi/ChangeLog,v 1.14 2007/07/02 15:52:52 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dssi/ChangeLog,v 1.15 2008/02/22 13:47:54 flameeyes Exp $
+
+*dssi-0.9.1-r1 (22 Feb 2008)
+
+ 22 Feb 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/dssi-0.9.1-constants.patch, +dssi-0.9.1-r1.ebuild:
+ Add a new revision to reduce copy-on-write pages, also fix the sed for the
+ pkgconfig file, and disable dependency tracking.
02 Jul 2007; Diego Pettenò <flameeyes@gentoo.org> metadata.xml:
Hand to newly-born proaudio herd.
diff --git a/media-libs/dssi/dssi-0.9.1-r1.ebuild b/media-libs/dssi/dssi-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..216753b738d0
--- /dev/null
+++ b/media-libs/dssi/dssi-0.9.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dssi/dssi-0.9.1-r1.ebuild,v 1.1 2008/02/22 13:47:54 flameeyes Exp $
+
+inherit multilib qt3 libtool eutils
+
+IUSE="qt3"
+
+DESCRIPTION="Plugin API for software instruments with user interfaces"
+HOMEPAGE="http://dssi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dssi/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=media-libs/alsa-lib-1.0
+ >=media-libs/liblo-0.12
+ >=media-sound/jack-audio-connection-kit-0.99.0-r1
+ >=media-libs/ladspa-sdk-1.12-r2
+ >=media-libs/libsndfile-1.0.11
+ >=media-libs/libsamplerate-0.1.1-r1
+ qt3? ( $(qt_min_version 3) )"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:libdir=.*:libdir=@libdir@:" ${S}/dssi.pc.in || die
+ epatch "${FILESDIR}/${P}-constants.patch"
+ elibtoolize
+}
+
+src_compile() {
+ use qt3 || QTDIR=/WONT_BE_FOUND
+ econf \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ dodoc README doc/TODO doc/*.txt
+}
diff --git a/media-libs/dssi/files/dssi-0.9.1-constants.patch b/media-libs/dssi/files/dssi-0.9.1-constants.patch
new file mode 100644
index 000000000000..026adff8c221
--- /dev/null
+++ b/media-libs/dssi/files/dssi-0.9.1-constants.patch
@@ -0,0 +1,70 @@
+Index: dssi-0.9.1/examples/less_trivial_synth.c
+===================================================================
+--- dssi-0.9.1.orig/examples/less_trivial_synth.c
++++ dssi-0.9.1/examples/less_trivial_synth.c
+@@ -56,7 +56,7 @@ long int lrintf (float x);
+ static LADSPA_Descriptor *ltsLDescriptor = NULL;
+ static DSSI_Descriptor *ltsDDescriptor = NULL;
+
+-float *table[2];
++const float *table[2];
+
+ typedef enum {
+ inactive = 0,
+Index: dssi-0.9.1/examples/saw.h
+===================================================================
+--- dssi-0.9.1.orig/examples/saw.h
++++ dssi-0.9.1/examples/saw.h
+@@ -1,4 +1,4 @@
+-float saw_table[1025] = {
++static const float saw_table[1025] = {
+ 0.000000, 0.008187, 0.016378, 0.024569, 0.032759, 0.040950,
+ 0.049141, 0.057331, 0.065522, 0.073712, 0.081903, 0.090094,
+ 0.098284, 0.106475, 0.114666, 0.122856, 0.131047, 0.139237,
+Index: dssi-0.9.1/jack-dssi-host/jack-dssi-host.c
+===================================================================
+--- dssi-0.9.1.orig/jack-dssi-host/jack-dssi-host.c
++++ dssi-0.9.1/jack-dssi-host/jack-dssi-host.c
+@@ -105,8 +105,8 @@ static sigset_t _signals;
+
+ int exiting = 0;
+ static int verbose = 0;
+-static int autoconnect = 1;
+-static int load_guis = 1;
++static int no_autoconnect = 0;
++static int no_load_guis = 0;
+ const char *myName = NULL;
+
+ #define EVENT_BUFFER_SIZE 1024
+@@ -808,11 +808,11 @@ main(int argc, char **argv)
+ continue;
+ }
+ if (!strcmp(argv[i], "-a")) {
+- autoconnect = 0;
++ no_autoconnect = 1;
+ continue;
+ }
+ if (!strcmp(argv[i], "-n")) {
+- load_guis = 0;
++ no_load_guis = 1;
+ continue;
+ }
+
+@@ -1332,7 +1332,7 @@ main(int argc, char **argv)
+ exit(1);
+ }
+
+- if (autoconnect) {
++ if (!no_autoconnect) {
+ /* !FIX! this to more intelligently connect ports: */
+ ports = jack_get_ports(jackClient, NULL, NULL,
+ JackPortIsPhysical|JackPortIsInput);
+@@ -1357,7 +1357,7 @@ main(int argc, char **argv)
+ /* Attempt to locate and start up a GUI for the plugin -- but
+ * continue even if we can't */
+ /* -FIX- Ack! So many windows all at once! */
+- if (load_guis) {
++ if (!no_load_guis) {
+ for (i = 0; i < instance_count; i++) {
+ char tag[12];
+ plugin = instances[i].plugin;