summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-16 06:56:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-16 06:56:31 +0000
commit60f0bbd010c239e456f2fb363dfd48037fac5d53 (patch)
tree10f1b3d555e068c3c7e7e344f14dc09892857952 /media-libs
parentCode review shows that this package do not use libusb at all. (diff)
downloadgentoo-2-60f0bbd010c239e456f2fb363dfd48037fac5d53.tar.gz
gentoo-2-60f0bbd010c239e456f2fb363dfd48037fac5d53.tar.bz2
gentoo-2-60f0bbd010c239e456f2fb363dfd48037fac5d53.zip
remove old
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mlt/ChangeLog6
-rw-r--r--media-libs/mlt/files/mlt-0.3.6-avutil.patch167
-rw-r--r--media-libs/mlt/mlt-0.3.4.ebuild96
-rw-r--r--media-libs/mlt/mlt-0.3.6.ebuild121
-rw-r--r--media-libs/mlt/mlt-0.3.8.ebuild120
5 files changed, 5 insertions, 505 deletions
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index 1fab1ec2b4fc..723f4efcf4e1 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mlt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.40 2009/04/22 11:08:39 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.41 2009/05/16 06:56:31 aballier Exp $
+
+ 16 May 2009; Alexis Ballier <aballier@gentoo.org> -mlt-0.3.4.ebuild,
+ -mlt-0.3.6.ebuild, -files/mlt-0.3.6-avutil.patch, -mlt-0.3.8.ebuild:
+ remove old
*mlt-0.3.8-r1 (22 Apr 2009)
diff --git a/media-libs/mlt/files/mlt-0.3.6-avutil.patch b/media-libs/mlt/files/mlt-0.3.6-avutil.patch
deleted file mode 100644
index 64d06dd9a610..000000000000
--- a/media-libs/mlt/files/mlt-0.3.6-avutil.patch
+++ /dev/null
@@ -1,167 +0,0 @@
-http://mlt.svn.sourceforge.net/viewvc/mlt?view=rev&revision=1376
-
-Index: src/modules/avformat/filter_swscale.c
-===================================================================
---- src/modules/avformat/filter_swscale.c (revision 1375)
-+++ src/modules/avformat/filter_swscale.c (revision 1376)
-@@ -33,6 +33,11 @@
- #include <string.h>
- #include <assert.h>
-
-+#if LIBAVUTIL_VERSION_INT < (50<<16)
-+#define PIX_FMT_RGB32 PIX_FMT_RGBA32
-+#define PIX_FMT_YUYV422 PIX_FMT_YUV422
-+#endif
-+
- static inline int is_big_endian( )
- {
- union { int i; char c[ 4 ]; } big_endian_test;
-@@ -51,10 +56,10 @@
- value = PIX_FMT_RGB24;
- break;
- case mlt_image_rgb24a:
-- value = PIX_FMT_RGBA32;
-+ value = PIX_FMT_RGB32;
- break;
- case mlt_image_yuv422:
-- value = PIX_FMT_YUV422;
-+ value = PIX_FMT_YUYV422;
- break;
- case mlt_image_yuv420p:
- value = PIX_FMT_YUV420P;
-@@ -109,7 +114,7 @@
- avpicture_fill( &output, outbuf, oformat, owidth, oheight );
-
- // Extract the alpha channel
-- if ( iformat == PIX_FMT_RGBA32 && oformat == PIX_FMT_YUV422 )
-+ if ( iformat == PIX_FMT_RGB32 && oformat == PIX_FMT_YUYV422 )
- {
- // Allocate the alpha mask
- uint8_t *alpha = mlt_pool_alloc( iwidth * ( iheight + 1 ) );
-@@ -118,7 +123,7 @@
- // Convert the image and extract alpha
- mlt_convert_rgb24a_to_yuv422( *image, iwidth, iheight, iwidth * 4, outbuf, alpha );
- mlt_properties_set_data( properties, "alpha", alpha, iwidth * ( iheight + 1 ), ( mlt_destructor )mlt_pool_release, NULL );
-- iformat = PIX_FMT_YUV422;
-+ iformat = PIX_FMT_YUYV422;
- avpicture_fill( &input, outbuf, iformat, iwidth, iheight );
- avpicture_fill( &output, *image, oformat, owidth, oheight );
- }
-Index: src/modules/avformat/consumer_avformat.c
-===================================================================
---- src/modules/avformat/consumer_avformat.c (revision 1375)
-+++ src/modules/avformat/consumer_avformat.c (revision 1376)
-@@ -41,6 +41,11 @@
- #endif
- #include <opt.h>
-
-+#if LIBAVUTIL_VERSION_INT < (50<<16)
-+#define PIX_FMT_RGB32 PIX_FMT_RGBA32
-+#define PIX_FMT_YUYV422 PIX_FMT_YUV422
-+#endif
-+
- //
- // This structure should be extended and made globally available in mlt
- //
-@@ -810,7 +815,7 @@
-
- // Need two av pictures for converting
- AVFrame *output = NULL;
-- AVFrame *input = alloc_picture( PIX_FMT_YUV422, width, height );
-+ AVFrame *input = alloc_picture( PIX_FMT_YUYV422, width, height );
-
- // For receiving images from an mlt_frame
- uint8_t *image;
-@@ -1102,17 +1107,17 @@
-
- // Do the colour space conversion
- #ifdef SWSCALE
-- struct SwsContext *context = sws_getContext( width, height, PIX_FMT_YUV422,
-+ struct SwsContext *context = sws_getContext( width, height, PIX_FMT_YUYV422,
- width, height, video_st->codec->pix_fmt, SWS_FAST_BILINEAR, NULL, NULL, NULL);
- sws_scale( context, input->data, input->linesize, 0, height,
- output->data, output->linesize);
- sws_freeContext( context );
- #else
-- img_convert( ( AVPicture * )output, video_st->codec->pix_fmt, ( AVPicture * )input, PIX_FMT_YUV422, width, height );
-+ img_convert( ( AVPicture * )output, video_st->codec->pix_fmt, ( AVPicture * )input, PIX_FMT_YUYV422, width, height );
- #endif
-
- // Apply the alpha if applicable
-- if ( video_st->codec->pix_fmt == PIX_FMT_RGBA32 )
-+ if ( video_st->codec->pix_fmt == PIX_FMT_RGB32 )
- {
- uint8_t *alpha = mlt_frame_get_alpha_mask( frame );
- register int n;
-Index: src/modules/avformat/filter_avcolour_space.c
-===================================================================
---- src/modules/avformat/filter_avcolour_space.c (revision 1375)
-+++ src/modules/avformat/filter_avcolour_space.c (revision 1376)
-@@ -27,6 +27,11 @@
- #include <swscale.h>
- #endif
-
-+#if LIBAVUTIL_VERSION_INT < (50<<16)
-+#define PIX_FMT_RGB32 PIX_FMT_RGBA32
-+#define PIX_FMT_YUYV422 PIX_FMT_YUV422
-+#endif
-+
- #include <stdio.h>
- #include <stdlib.h>
-
-@@ -48,10 +53,10 @@
- value = PIX_FMT_RGB24;
- break;
- case mlt_image_rgb24a:
-- value = PIX_FMT_RGBA32;
-+ value = PIX_FMT_RGB32;
- break;
- case mlt_image_yuv422:
-- value = PIX_FMT_YUV422;
-+ value = PIX_FMT_YUYV422;
- break;
- case mlt_image_yuv420p:
- value = PIX_FMT_YUV420P;
-Index: src/modules/avformat/filter_avdeinterlace.c
-===================================================================
---- src/modules/avformat/filter_avdeinterlace.c (revision 1375)
-+++ src/modules/avformat/filter_avdeinterlace.c (revision 1376)
-@@ -81,6 +81,10 @@
- movd_r2m(mm1,dst[0]);
- #endif
-
-+#if LIBAVUTIL_VERSION_INT < (50<<16)
-+#define PIX_FMT_YUYV422 PIX_FMT_YUV422
-+#endif
-+
- /* filter parameters: [-1 4 2 4 -1] // 8 */
- static inline void deinterlace_line(uint8_t *dst,
- const uint8_t *lum_m4, const uint8_t *lum_m3,
-@@ -237,14 +241,14 @@
-
- if (pix_fmt != PIX_FMT_YUV420P &&
- pix_fmt != PIX_FMT_YUV422P &&
-- pix_fmt != PIX_FMT_YUV422 &&
-+ pix_fmt != PIX_FMT_YUYV422 &&
- pix_fmt != PIX_FMT_YUV444P &&
- pix_fmt != PIX_FMT_YUV411P)
- return -1;
- if ((width & 3) != 0 || (height & 3) != 0)
- return -1;
-
-- if ( pix_fmt != PIX_FMT_YUV422 )
-+ if ( pix_fmt != PIX_FMT_YUYV422 )
- {
- for(i=0;i<3;i++) {
- if (i == 1) {
-@@ -314,8 +318,8 @@
- // Fill the picture
- if ( *format == mlt_image_yuv422 )
- {
-- avpicture_fill( output, *image, PIX_FMT_YUV422, *width, *height );
-- mlt_avpicture_deinterlace( output, output, PIX_FMT_YUV422, *width, *height );
-+ avpicture_fill( output, *image, PIX_FMT_YUYV422, *width, *height );
-+ mlt_avpicture_deinterlace( output, output, PIX_FMT_YUYV422, *width, *height );
- }
-
- // Free the picture
diff --git a/media-libs/mlt/mlt-0.3.4.ebuild b/media-libs/mlt/mlt-0.3.4.ebuild
deleted file mode 100644
index b2eeb96da9f9..000000000000
--- a/media-libs/mlt/mlt-0.3.4.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.4.ebuild,v 1.1 2009/01/12 22:07:49 aballier Exp $
-
-EAPI=1
-
-inherit eutils toolchain-funcs qt3
-
-DESCRIPTION="MLT is an open source multimedia framework, designed and developed
-for television broadcasting"
-HOMEPAGE="http://mlt.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="dv xml jack gtk sdl vorbis sox quicktime mmx lame xine lame ogg theora xine ffmpeg libsamplerate qt3 sse"
-
-DEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
- dv? ( >=media-libs/libdv-0.104 )
- xml? ( >=dev-libs/libxml2-2.5 )
- ogg? ( >=media-libs/libogg-1.1.3 )
- vorbis? ( >=media-libs/libvorbis-1.1.2 )
- sdl? ( >=media-libs/libsdl-1.2.10
- >=media-libs/sdl-image-1.2.4 )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
- jack? ( media-sound/jack-audio-connection-kit
- media-libs/ladspa-sdk
- >=dev-libs/libxml2-2.5 )
- gtk? ( >=x11-libs/gtk+-2
- x11-libs/pango )
- sox? ( media-sound/sox )
- quicktime? ( media-libs/libquicktime )
- xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
- lame? ( >=media-sound/lame-3.97_beta2 )
- qt3? ( x11-libs/qt:3 )
- theora? ( >=media-libs/libtheora-1.0_alpha5 )"
-RDEPEND=${DEPEND}
-
-pkg_setup() {
- local fail="USE sox needs also USE libsamplerate enabled."
-
- if use sox && ! use libsamplerate; then
- eerror "${fail}"
- die "${fail}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
-}
-
-src_compile() {
- tc-export CC
-
- local myconf=" --enable-gpl --enable-shared
- --enable-pp --enable-shared-pp
- --enable-motion-est
- $(use_enable dv)
- $(use_enable mmx)
- $(use_enable sse)
- $(use_enable gtk gtk2)
- $(use_enable vorbis)
- $(use_enable ogg)
- $(use_enable sdl)
- $(use_enable jack jackrack)
- $(use_enable sox)
- $(use_enable theora)
- $(use_enable lame mp3lame)
- $(use_enable ffmpeg avformat)
- $(use_enable libsamplerate resample)
- $(use_enable qt3 qimage)
- $(use_enable xml westley)
- $(use_enable xine)"
-
- use ffmpeg && has_version ">=media-video/ffmpeg-0.4.9_p20070616-r20" &&
- myconf="${myconf} --avformat-swscale"
-
- (use quicktime && use dv) || myconf="${myconf} --disable-kino"
-
- econf ${myconf} || die "econf failed"
- sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc docs/*.txt ChangeLog README docs/TODO
-
- dodir /usr/share/${PN}
- insinto /usr/share/${PN}
- doins -r demo
-}
diff --git a/media-libs/mlt/mlt-0.3.6.ebuild b/media-libs/mlt/mlt-0.3.6.ebuild
deleted file mode 100644
index e846b1abed93..000000000000
--- a/media-libs/mlt/mlt-0.3.6.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.6.ebuild,v 1.3 2009/03/15 16:10:45 aballier Exp $
-
-EAPI=1
-
-inherit kde-functions eutils toolchain-funcs multilib
-
-DESCRIPTION="MLT is an open source multimedia framework, designed and developed
-for television broadcasting"
-HOMEPAGE="http://mlt.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="dv compressed-lumas ffmpeg gtk jack kde libsamplerate mmx qt3 qt4 quicktime sdl sox sse vorbis xine xml"
-
-RDEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
- dv? ( >=media-libs/libdv-0.104 )
- xml? ( >=dev-libs/libxml2-2.5 )
- vorbis? ( >=media-libs/libvorbis-1.1.2 )
- sdl? ( >=media-libs/libsdl-1.2.10
- >=media-libs/sdl-image-1.2.4 )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
- jack? ( media-sound/jack-audio-connection-kit
- media-libs/ladspa-sdk
- >=dev-libs/libxml2-2.5 )
- gtk? ( >=x11-libs/gtk+-2
- x11-libs/pango )
- sox? ( media-sound/sox )
- quicktime? ( media-libs/libquicktime )
- xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
- qt3? ( x11-libs/qt:3
- kde? ( kde-base/kdelibs:3.5 ) )
- !qt3? ( qt4? ( x11-libs/qt-gui:4 ) )"
-
-DEPEND="${RDEPEND}
- compressed-lumas? ( media-gfx/imagemagick )"
-
-pkg_setup() {
- local fail="USE sox needs also USE libsamplerate enabled."
-
- if use sox && ! use libsamplerate; then
- eerror "${fail}"
- die "${fail}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
- epatch "${FILESDIR}"/${P}-avutil.patch
- epatch "${FILESDIR}"/${P}-qimage.patch
-}
-
-src_compile() {
- tc-export CC
-
- local myconf=" --enable-gpl
- --enable-motion-est
- $(use_enable dv)
- $(use_enable mmx)
- $(use_enable sse)
- $(use_enable gtk gtk2)
- $(use_enable vorbis)
- $(use_enable sdl)
- $(use_enable jack jackrack)
- $(use_enable sox)
- $(use_enable ffmpeg avformat)
- $(use_enable libsamplerate resample)
- $(use_enable xml westley)
- $(use_enable xine)"
-
- use ffmpeg && has_version ">=media-video/ffmpeg-0.4.9_p20070616-r20" &&
- myconf="${myconf} --avformat-swscale"
-
- (use quicktime && use dv) || myconf="${myconf} --disable-kino"
-
- use compressed-lumas && myconf="${myconf} --luma-compress"
-
- # Waiting for media-plugins/frei0r (bug 255321)
- myconf="${myconf} --disable-frei0r"
-
- if use qt3; then
- myconf="${myconf} --disable-kdenlive"
- else
- myconf="${myconf} $(use_enable kde kdenlive)"
- fi
-
- if use qt3; then
- myconf="${myconf} --qimage-libdir=$QTDIR/$(get_libdir)
- --qimage-includedir=$QTDIR/include"
- if use kde; then
- # compile extra image formats using kde
- set-kdedir 3.5
- myconf="${myconf} --kde-libdir=$KDEDIR/$(get_libdir)
- --kde-includedir=$KDEDIR/include"
- fi
- elif use qt4; then
- myconf="${myconf} --qimage-libdir=/usr/$(get_libdir)/qt4
- --qimage-includedir=/usr/include/qt4"
- else
- myconf="${myconf} --disable-qimage"
- fi
-
- econf ${myconf} || die "econf failed"
- sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc docs/*.txt ChangeLog README docs/TODO
-
- dodir /usr/share/${PN}
- insinto /usr/share/${PN}
- doins -r demo
-}
diff --git a/media-libs/mlt/mlt-0.3.8.ebuild b/media-libs/mlt/mlt-0.3.8.ebuild
deleted file mode 100644
index 7923f8ec8b49..000000000000
--- a/media-libs/mlt/mlt-0.3.8.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.8.ebuild,v 1.1 2009/04/15 18:37:29 aballier Exp $
-
-EAPI=1
-
-inherit kde-functions eutils toolchain-funcs multilib
-
-DESCRIPTION="MLT is an open source multimedia framework, designed and developed
-for television broadcasting"
-HOMEPAGE="http://mlt.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="dv compressed-lumas ffmpeg gtk jack kde libsamplerate mmx qt3 qt4 quicktime sdl sox sse vorbis xine xml"
-
-RDEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
- dv? ( >=media-libs/libdv-0.104 )
- xml? ( >=dev-libs/libxml2-2.5 )
- vorbis? ( >=media-libs/libvorbis-1.1.2 )
- sdl? ( >=media-libs/libsdl-1.2.10
- >=media-libs/sdl-image-1.2.4 )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
- jack? ( media-sound/jack-audio-connection-kit
- media-libs/ladspa-sdk
- >=dev-libs/libxml2-2.5 )
- gtk? ( >=x11-libs/gtk+-2
- x11-libs/pango )
- sox? ( media-sound/sox )
- quicktime? ( media-libs/libquicktime )
- xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
- qt3? ( x11-libs/qt:3
- kde? ( kde-base/kdelibs:3.5 ) )
- !qt3? ( qt4? ( x11-libs/qt-gui:4 ) )"
-
-DEPEND="${RDEPEND}
- compressed-lumas? ( media-gfx/imagemagick )"
-
-pkg_setup() {
- local fail="USE sox needs also USE libsamplerate enabled."
-
- if use sox && ! use libsamplerate; then
- eerror "${fail}"
- die "${fail}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
- epatch "${FILESDIR}"/${PN}-0.3.6-qimage.patch
-}
-
-src_compile() {
- tc-export CC
-
- local myconf=" --enable-gpl
- --enable-motion-est
- $(use_enable dv)
- $(use_enable mmx)
- $(use_enable sse)
- $(use_enable gtk gtk2)
- $(use_enable vorbis)
- $(use_enable sdl)
- $(use_enable jack jackrack)
- $(use_enable sox)
- $(use_enable ffmpeg avformat)
- $(use_enable libsamplerate resample)
- $(use_enable xml westley)
- $(use_enable xine)"
-
- use ffmpeg && has_version ">=media-video/ffmpeg-0.4.9_p20070616-r20" &&
- myconf="${myconf} --avformat-swscale"
-
- (use quicktime && use dv) || myconf="${myconf} --disable-kino"
-
- use compressed-lumas && myconf="${myconf} --luma-compress"
-
- # Waiting for media-plugins/frei0r (bug 255321)
- myconf="${myconf} --disable-frei0r"
-
- if use qt3; then
- myconf="${myconf} --disable-kdenlive"
- else
- myconf="${myconf} $(use_enable kde kdenlive)"
- fi
-
- if use qt3; then
- myconf="${myconf} --qimage-libdir=$QTDIR/$(get_libdir)
- --qimage-includedir=$QTDIR/include"
- if use kde; then
- # compile extra image formats using kde
- set-kdedir 3.5
- myconf="${myconf} --kde-libdir=$KDEDIR/$(get_libdir)
- --kde-includedir=$KDEDIR/include"
- fi
- elif use qt4; then
- myconf="${myconf} --qimage-libdir=/usr/$(get_libdir)/qt4
- --qimage-includedir=/usr/include/qt4"
- else
- myconf="${myconf} --disable-qimage"
- fi
-
- econf ${myconf} || die "econf failed"
- sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc docs/*.txt ChangeLog README docs/TODO
-
- dodir /usr/share/${PN}
- insinto /usr/share/${PN}
- doins -r demo
-}