summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-09 20:47:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-09 20:47:51 +0000
commit1beebdec2de0001f022fa47a2cc3faaf73edbc78 (patch)
tree61d5baf452d9b3429df7e5096a0816f9ec093f11 /media-libs/qhull
parentamd64/x86 stable, bug #283648 (diff)
downloadgentoo-2-1beebdec2de0001f022fa47a2cc3faaf73edbc78.tar.gz
gentoo-2-1beebdec2de0001f022fa47a2cc3faaf73edbc78.tar.bz2
gentoo-2-1beebdec2de0001f022fa47a2cc3faaf73edbc78.zip
Cleaned and fixed a few minor QA issues
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog8
-rw-r--r--media-libs/qhull/qhull-2003.1-r1.ebuild27
-rw-r--r--media-libs/qhull/qhull-2003.1.ebuild51
3 files changed, 19 insertions, 67 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index 96a4cad8f27a..c3eda0f3843c 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/qhull
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.30 2009/05/17 13:01:46 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.31 2009/09/09 20:47:51 bicatali Exp $
+
+ 09 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org> -qhull-2003.1.ebuild,
+ qhull-2003.1-r1.ebuild:
+ Cleaned and fixed a few minor QA issues
17 May 2009; nixnut <nixnut@gentoo.org> qhull-2003.1-r1.ebuild:
ppc stable #245707
diff --git a/media-libs/qhull/qhull-2003.1-r1.ebuild b/media-libs/qhull/qhull-2003.1-r1.ebuild
index 5997c0df102b..2a76b0a51e8e 100644
--- a/media-libs/qhull/qhull-2003.1-r1.ebuild
+++ b/media-libs/qhull/qhull-2003.1-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2003.1-r1.ebuild,v 1.7 2009/05/17 13:01:46 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2003.1-r1.ebuild,v 1.8 2009/09/09 20:47:51 bicatali Exp $
+EAPI=2
inherit eutils flag-o-matic
MY_P="${PN}${PV}"
@@ -12,25 +13,23 @@ SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="alpha amd64 ~hppa ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="doc"
-src_compile() {
+pkg_setup() {
# anything beyond -O1 leads to bad code in libqhull on amd64
# with gcc-4.2
- if [[ "${ARCH}" == "amd64" ]]; then
- replace-flags -O? -O1
- fi
-
- econf || die "econf failed"
- emake || die "emake failed"
+ #use amd64 && replace-flags -O? -O1
+ echo
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
rm -fr "${D}"/usr/share/doc/${PN}
- dodoc Announce.txt .txt File_id.diz README.txt REGISTER.txt
- cd html
- dohtml *
- dodoc *.txt
+ dodoc Announce.txt File_id.diz README.txt REGISTER.txt
+ if use doc; then
+ cd html
+ dohtml * || die
+ dodoc *.txt || die
+ fi
}
diff --git a/media-libs/qhull/qhull-2003.1.ebuild b/media-libs/qhull/qhull-2003.1.ebuild
deleted file mode 100644
index 70b2308bb588..000000000000
--- a/media-libs/qhull/qhull-2003.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2003.1.ebuild,v 1.2 2007/11/18 13:15:43 markusle Exp $
-
-inherit eutils
-
-MY_P="${PN}${PV}"
-DESCRIPTION="Geometry library"
-HOMEPAGE="http://www.qhull.org"
-SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"/src
- mv Makefile.txt Makefile
- # Replaced sed/echo hacks by a clean patch. Fix build error on -fPIC archs
- # BUG #82646
- # Danny van Dyk <kugelfang@gentoo.org> 2005/02/22
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
-
-src_compile() {
- cd src
- emake CCOPTS1="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- cd src
-
- dolib libqhull.a || die "dolib failed"
- dolib.so libqhull.so || die "dolib.so failed"
- dobin qconvex qdelaunay qhalf qhull qvoronoi rbox || die "dobin failed"
-
- insinto /usr/include/qhull
- doins *.h
-
- cd "${S}"
- dodoc Announce.txt COPYING.txt File_id.diz README.txt REGISTER.txt
- cd html
- dohtml *
- dodoc *.txt
- for m in *man
- do
- newman ${m} ${m/.man/.1}
- done
-}