summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-18 03:42:22 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-18 03:42:22 +0000
commit8c631bef41267bffb480208f148d62a5b741cb2e (patch)
tree023627288c283008e88fbc7f667c3c5aa4514ce9 /media-libs/mesa
parentadded more stuff to gentoo-howto.xml (diff)
downloadgentoo-2-8c631bef41267bffb480208f148d62a5b741cb2e.tar.gz
gentoo-2-8c631bef41267bffb480208f148d62a5b741cb2e.tar.bz2
gentoo-2-8c631bef41267bffb480208f148d62a5b741cb2e.zip
Update
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/files/digest-mesa-3.4.22
-rw-r--r--media-libs/mesa/mesa-3.4.2.ebuild140
2 files changed, 142 insertions, 0 deletions
diff --git a/media-libs/mesa/files/digest-mesa-3.4.2 b/media-libs/mesa/files/digest-mesa-3.4.2
new file mode 100644
index 000000000000..59c04df9831f
--- /dev/null
+++ b/media-libs/mesa/files/digest-mesa-3.4.2
@@ -0,0 +1,2 @@
+MD5 9169942475db0786229079f57909f7bc MesaLib-3.4.2.tar.bz2
+MD5 b3a7b01dae8b1f09f951f9257c242b08 MesaDemos-3.4.2.tar.bz2
diff --git a/media-libs/mesa/mesa-3.4.2.ebuild b/media-libs/mesa/mesa-3.4.2.ebuild
new file mode 100644
index 000000000000..431dbc264682
--- /dev/null
+++ b/media-libs/mesa/mesa-3.4.2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-3.4.2.ebuild,v 1.1 2001/05/18 03:42:22 achim Exp $
+
+P=MesaLib-${PV}
+A0=${P}.tar.bz2
+A1=MesaDemos-${PV}.tar.bz2
+A="${A0} ${A1}"
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux"
+SRC_URI="http://download.sourceforge.net/mesa3d/${A0}
+ http://download.sourceforge.net/mesa3d/${A1}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ svga? ( >=media-libs/svgalib-1.4.2-r1 )"
+
+if [ "`use X`" ]
+then
+ PROVIDE="virtual/opengl virtual/glu virtual/glut"
+else
+ PROVIDE="virtual/opengl"
+fi
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mmx`" ]
+ then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+
+ if [ "`use 3dnow`" ]
+ then
+ myconf="${myconf} --enable-3dnow"
+ else
+ myconf="${myconf} --disable-3dnow"
+ fi
+
+ if [ "`use sse`" ]
+ then
+ myconf="${myconf} --enable-sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+
+ if [ "`use X`" ]
+ then
+ myconf="${myconf} --with-x --without-glut"
+ # --without-glut means that mesa is forced to use and install
+ # his own version of glut.
+ else
+ myconf="${myconf} --without-x"
+ rm -rf src-glut
+ fi
+
+ if [ -z "`use ggi`" ] || [ -z "`use fbcon`" ]
+ then
+ myconf="${myconf} --disable-ggi-fbdev --without-ggi"
+ fi
+
+ if [ -z "`use svga`" ]
+ then
+ myconf="${myconf} --without-svga"
+ fi
+
+ cp configure configure.orig
+ sed -e "s:^ggi_confdir.*:ggi_confdir=/etc/ggi:" \
+ -e "s:^ggi_libdir.*:ggi_libdir=\$prefix/lib:" \
+ configure.orig > configure
+
+ try ./configure --prefix=/usr --sysconfdir=/etc/mesa --host=${CHOST} $myconf
+
+ if [ "`use ggi`" ] && [ "`use fbcon`" ]
+ then
+ cd ${S}/src/GGI
+ cp Makefile Makefile.orig
+ sed -e "s:^ggimesaconfdatadir.*:ggimesaconfdatadir = \${ggi_confdir}:" \
+ Makefile.orig > Makefile
+
+ cd ${S}/src/GGI/default
+ cp stubs.c stubs.c.orig
+ sed -e "s:Texture.Enabled:Texture.ReallyEnabled:" stubs.c.orig > stubs.c
+
+ cd ${S}/src/GGI/include/ggi/mesa
+ cp display_fbdev.h display_fbdev.h.orig
+ sed -e "s:fbdev_hook:ggi_fbdev_priv:" display_fbdev.h.orig > display_fbdev.h
+
+ cd ${S}
+ mkdir gg
+ ln -s /usr/lib/libgg*.so .
+ fi
+
+ try make
+
+ if [ "`use ggi`" ]
+ then
+ cd ggi/ggiglut
+ try make libglut_la_LIBADD=\"-lggi -lgg -L${S}/src/.libs -lGL\"
+ fi
+}
+
+src_install () {
+
+
+ if [ "`use ggi`" ]
+ then
+ cd ggi/ggiglut
+ try make DESTDIR=${D} install
+ cd ${D}/usr/lib
+ cp libglut.la libglut.orig
+ sed -e "s:-L${S}/src/.libs::g" libglut.orig > libglut.la
+ rm libglut.orig
+ fi
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd ${D}/usr/lib
+ if [ "$PN" = "mesa-glu" ]
+ then
+ rm -f libGL.*
+
+ rm -f ../include/GL/gl.h
+ rm -f ../include/GL/glx.h
+ rm -f ../include/GL/osmesa.h
+ else
+ ln -s libGL.so.2.1.030402 libMesaGL.so.3
+ fi
+ ln -s libGLU.so.1.1.030402 libMesaGLU.so.3
+
+
+ cd ${S}
+ dodoc docs/*
+}
+