summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-07 23:35:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-07 23:35:04 +0000
commitc108a645e03d9decf3861213385a5bc874e43fa6 (patch)
treec63a0d881ea9e1b78b3e0ed136945ea29e3b0363 /media-libs/libsdl
parentadded longdescription to metadata (diff)
downloadgentoo-2-c108a645e03d9decf3861213385a5bc874e43fa6.tar.gz
gentoo-2-c108a645e03d9decf3861213385a5bc874e43fa6.tar.bz2
gentoo-2-c108a645e03d9decf3861213385a5bc874e43fa6.zip
Fix by Sascha Schwarz for newer DirectFB api #132571 by Heiko Baums.
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog6
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.9-DirectFB-updates.patch21
2 files changed, 26 insertions, 1 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 95b23f852e47..a6909efcbf7f 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.99 2006/04/08 00:19:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.100 2006/05/07 23:35:04 vapier Exp $
+
+ 07 May 2006; Mike Frysinger <vapier@gentoo.org>
+ files/libsdl-1.2.9-DirectFB-updates.patch:
+ Fix by Sascha Schwarz for newer DirectFB api #132571 by Heiko Baums.
08 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> libsdl-1.2.9-r1.ebuild:
Add ~x86-fbsd keyword after adding elibtoolize call.
diff --git a/media-libs/libsdl/files/libsdl-1.2.9-DirectFB-updates.patch b/media-libs/libsdl/files/libsdl-1.2.9-DirectFB-updates.patch
index fc7368dadc99..721ee78c18a2 100644
--- a/media-libs/libsdl/files/libsdl-1.2.9-DirectFB-updates.patch
+++ b/media-libs/libsdl/files/libsdl-1.2.9-DirectFB-updates.patch
@@ -36,3 +36,24 @@ http://www.directfb.org/index.php/viewcvs.cgi/DirectFB/include/directfb.h.diff?r
this->info.wm_available = 1;
this->info.hw_available = 1;
+
+http://bugs.gentoo.org/132571
+And another change:
+ DIKI_ALTGR is gone. The key right to the space bar is the right alt key.
+ No matter which map is loaded, the identifiers are just named hardware keys,
+ where you really specify the physical entity on your keyboard. In this case
+ it's always DIKI_ALT_R, no matter if it's mapped to DIKS_ALTGR or DIKS_ALT.
+ On standard keyboards it's also always the same hardware key code, no matter
+ if you by a German keyboard with AltGr or a U.$. one with Alt.
+
+--- src/video/directfb/SDL_DirectFB_events.c
++++ src/video/directfb/SDL_DirectFB_events.c
+@@ -155,7 +155,7 @@ void DirectFB_InitOSKeymap (_THIS)
+ keymap[DIKI_SHIFT_L - DIKI_UNKNOWN] = SDLK_LSHIFT;
+ keymap[DIKI_SHIFT_R - DIKI_UNKNOWN] = SDLK_RSHIFT;
+ keymap[DIKI_ALT_L - DIKI_UNKNOWN] = SDLK_LALT;
+- keymap[DIKI_ALTGR - DIKI_UNKNOWN] = SDLK_RALT;
++ keymap[DIKI_ALT_R - DIKI_UNKNOWN] = SDLK_RALT;
+ keymap[DIKI_TAB - DIKI_UNKNOWN] = SDLK_TAB;
+ keymap[DIKI_ENTER - DIKI_UNKNOWN] = SDLK_RETURN;
+ keymap[DIKI_SPACE - DIKI_UNKNOWN] = SDLK_SPACE;