summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-27 23:29:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-27 23:29:54 +0000
commit7d4e5e0623718e6e12223f8e7062b3a68ff8f501 (patch)
tree785989aa348d9a3df483d8e0f4a6823ea4ed2430 /media-libs/libsdl
parentmake sure build system parses $LINUXSVGALIB correctly #107346 (diff)
downloadgentoo-2-7d4e5e0623718e6e12223f8e7062b3a68ff8f501.tar.gz
gentoo-2-7d4e5e0623718e6e12223f8e7062b3a68ff8f501.tar.bz2
gentoo-2-7d4e5e0623718e6e12223f8e7062b3a68ff8f501.zip
force --disable-nasm when USE=pic
(Portage version: 2.0.52-r1 http://www.bash.org/?136501 )
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/libsdl-1.2.8-r1.ebuild12
-rw-r--r--media-libs/libsdl/libsdl-1.2.9.ebuild12
2 files changed, 14 insertions, 10 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
index 9a2ebfbb8091..835c9a4913a8 100644
--- a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.20 2005/09/07 23:19:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.21 2005/09/27 23:29:54 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -78,10 +78,12 @@ src_unpack() {
src_compile() {
local myconf=
- if use x86 ; then
- # silly bundled asm triggers TEXTREL ... maybe someday
- # i'll fix this properly, but for now hide with USE=pic
- use pic || myconf="${myconf} $(use_enable x86 nasm)"
+ # silly bundled asm triggers TEXTREL ... maybe someday
+ # i'll fix this properly, but for now hide with USE=pic
+ if [[ $(tc-arch) != "x86" ]] || use pic ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} $(use_enable x86 nasm)"
fi
use noflagstrip || strip-flags
use noaudio && myconf="${myconf} --disable-audio"
diff --git a/media-libs/libsdl/libsdl-1.2.9.ebuild b/media-libs/libsdl/libsdl-1.2.9.ebuild
index 3db8bc34108a..731782b009bc 100644
--- a/media-libs/libsdl/libsdl-1.2.9.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9.ebuild,v 1.4 2005/09/07 23:19:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9.ebuild,v 1.5 2005/09/27 23:29:54 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -68,10 +68,12 @@ src_unpack() {
src_compile() {
local myconf=
- if use x86 ; then
- # silly bundled asm triggers TEXTREL ... maybe someday
- # i'll fix this properly, but for now hide with USE=pic
- use pic || myconf="${myconf} $(use_enable x86 nasm)"
+ # silly bundled asm triggers TEXTREL ... maybe someday
+ # i'll fix this properly, but for now hide with USE=pic
+ if [[ $(tc-arch) != "x86" ]] || use pic ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} $(use_enable x86 nasm)"
fi
use noflagstrip || strip-flags
use noaudio && myconf="${myconf} --disable-audio"