summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-02 22:36:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-02 22:36:16 +0000
commit4373bf74760619db44bb1405fad6029a07ee09de (patch)
tree929c1872b35f4adcd91d0f0118828e5bb570727e /media-libs/libclastfm/libclastfm-0.5.ebuild
parentPostgres support in calligra needs libpqxx-3* which is not in the tree anymore (diff)
downloadgentoo-2-4373bf74760619db44bb1405fad6029a07ee09de.tar.gz
gentoo-2-4373bf74760619db44bb1405fad6029a07ee09de.tar.bz2
gentoo-2-4373bf74760619db44bb1405fad6029a07ee09de.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libclastfm/libclastfm-0.5.ebuild')
-rw-r--r--media-libs/libclastfm/libclastfm-0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libclastfm/libclastfm-0.5.ebuild b/media-libs/libclastfm/libclastfm-0.5.ebuild
new file mode 100644
index 000000000000..ddb55f17601a
--- /dev/null
+++ b/media-libs/libclastfm/libclastfm-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libclastfm/libclastfm-0.5.ebuild,v 1.1 2012/06/02 22:36:16 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="C API library to the last.fm web service (unofficial)"
+HOMEPAGE="http://liblastfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/c}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib*/*.la
+}