summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-07-29 15:04:05 +0000
committerBen de Groot <yngwin@gentoo.org>2008-07-29 15:04:05 +0000
commit00fe5d157b44493be471ce00a3229b103929f9af (patch)
tree509dc551d7e8e5caa86299e4d5b389aa2d6743fd /media-libs/id3lib
parentAdd mirror restriction (diff)
downloadgentoo-2-00fe5d157b44493be471ce00a3229b103929f9af.tar.gz
gentoo-2-00fe5d157b44493be471ce00a3229b103929f9af.tar.bz2
gentoo-2-00fe5d157b44493be471ce00a3229b103929f9af.zip
Revbump to force recompilation, in order to fix bugs #233273 and #233240
(Portage version: 2.2_rc4/cvs/Linux 2.6.26-hg1 i686, RepoMan options: --force)
Diffstat (limited to 'media-libs/id3lib')
-rw-r--r--media-libs/id3lib/ChangeLog7
-rw-r--r--media-libs/id3lib/id3lib-3.8.3-r7.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/id3lib/ChangeLog b/media-libs/id3lib/ChangeLog
index a23b452a4b2c..a6c572be6cc5 100644
--- a/media-libs/id3lib/ChangeLog
+++ b/media-libs/id3lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/id3lib
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/ChangeLog,v 1.69 2008/04/11 20:45:24 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/ChangeLog,v 1.70 2008/07/29 15:04:05 yngwin Exp $
+
+*id3lib-3.8.3-r7 (29 Jul 2008)
+
+ 29 Jul 2008; Ben de Groot <yngwin@gentoo.org> +id3lib-3.8.3-r7.ebuild:
+ Rev bump to force recompilation, in order to fix bugs #233273 and #233240
11 Apr 2008; Ben de Groot <yngwin@gentoo.org>
+files/id3lib-3.8.3-gcc-4.3.patch, id3lib-3.8.3-r6.ebuild:
diff --git a/media-libs/id3lib/id3lib-3.8.3-r7.ebuild b/media-libs/id3lib/id3lib-3.8.3-r7.ebuild
new file mode 100644
index 000000000000..4446734bbc2a
--- /dev/null
+++ b/media-libs/id3lib/id3lib-3.8.3-r7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/id3lib-3.8.3-r7.ebuild,v 1.1 2008/07/29 15:04:05 yngwin Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+MY_P=${P/_/}
+S="${WORKDIR}"/${MY_P}
+
+DESCRIPTION="Id3 library for C/C++"
+HOMEPAGE="http://id3lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc"
+
+RESTRICT="test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-zlib.patch
+ epatch "${FILESDIR}"/${P}-test_io.patch
+ epatch "${FILESDIR}"/${P}-autoconf259.patch
+ epatch "${FILESDIR}"/${P}-doxyinput.patch
+ epatch "${FILESDIR}"/${P}-unicode16.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+
+ # Security fix for bug 189610.
+ epatch "${FILESDIR}"/${P}-security.patch
+
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed."
+ emake || die "emake failed."
+
+ if use doc; then
+ cd doc/
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS TODO
+
+ if use doc; then
+ dohtml -r doc
+ fi
+}