summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-12-24 09:09:54 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-12-24 09:09:54 +0000
commit7ce4cd31bf62e60526b4f5b28555e701bbb99ab3 (patch)
treed7a61e3f07a26c6028d3581572e0a28ec62fc749 /media-libs/gnonlin
parentBump to 0.10.31. Bunch of fixes, new APIs for date/time and faster, unchecked... (diff)
downloadgentoo-2-7ce4cd31bf62e60526b4f5b28555e701bbb99ab3.tar.gz
gentoo-2-7ce4cd31bf62e60526b4f5b28555e701bbb99ab3.tar.bz2
gentoo-2-7ce4cd31bf62e60526b4f5b28555e701bbb99ab3.zip
Bump to 0.10.16. Minor fixes in this release.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gnonlin')
-rw-r--r--media-libs/gnonlin/ChangeLog7
-rw-r--r--media-libs/gnonlin/gnonlin-0.10.16.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/media-libs/gnonlin/ChangeLog b/media-libs/gnonlin/ChangeLog
index 6ff734415a84..74c03147da17 100644
--- a/media-libs/gnonlin/ChangeLog
+++ b/media-libs/gnonlin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gnonlin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gnonlin/ChangeLog,v 1.15 2010/03/20 12:30:48 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gnonlin/ChangeLog,v 1.16 2010/12/24 09:09:54 ford_prefect Exp $
+
+*gnonlin-0.10.16 (24 Dec 2010)
+
+ 24 Dec 2010; Arun Raghavan <ford_prefect@gentoo.org> +gnonlin-0.10.16.ebuild:
+ Bump to 0.10.16. Minor fixes in this release.
20 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
-gnonlin-0.10.8.ebuild, -gnonlin-0.10.10.ebuild, -gnonlin-0.10.11.ebuild,
diff --git a/media-libs/gnonlin/gnonlin-0.10.16.ebuild b/media-libs/gnonlin/gnonlin-0.10.16.ebuild
new file mode 100644
index 000000000000..563afca90d94
--- /dev/null
+++ b/media-libs/gnonlin/gnonlin-0.10.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gnonlin/gnonlin-0.10.16.ebuild,v 1.1 2010/12/24 09:09:54 ford_prefect Exp $
+
+DESCRIPTION="Gnonlin is a set of GStreamer elements to ease the creation of non-linear multimedia editors."
+HOMEPAGE="http://gnonlin.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.10"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=media-libs/gstreamer-0.10.30
+ >=media-libs/gst-plugins-base-0.10.13"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( || (
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/gtk-doc-1.3 ) )
+ test? ( dev-libs/check )"
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc docbook)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README RELEASE
+
+ # For some reason, make install doesn't do this
+ if use doc; then
+ local htmldir="/usr/share/gtk-doc/html"
+ cd "${S}/docs/libs/html"
+ gtkdoc-rebase --html-dir=${htmldir} || die "gtkdoc-rebase failed"
+ insinto "${htmldir}/gnonlin"
+ doins "${S}"/docs/libs/html/* || die "doins docs failed"
+ fi
+}