summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2009-06-14 17:56:40 +0000
committerJoe Peterson <lavajoe@gentoo.org>2009-06-14 17:56:40 +0000
commit8ec34844eac44e9442a6233a427b8a6e9aff3567 (patch)
treed7a04c81e951e94fc6c897a023064615c514f7fe /media-gfx
parentAdd extra comment about system-wide support since upstream gets a lot of folk... (diff)
downloadgentoo-2-8ec34844eac44e9442a6233a427b8a6e9aff3567.tar.gz
gentoo-2-8ec34844eac44e9442a6233a427b8a6e9aff3567.tar.bz2
gentoo-2-8ec34844eac44e9442a6233a427b8a6e9aff3567.zip
Add new 3.7.0 beta 32
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/povray/ChangeLog11
-rw-r--r--media-gfx/povray/files/povray-3.7.0_beta32-print-extend-expiration-info.patch28
-rw-r--r--media-gfx/povray/povray-3.7.0_beta32.ebuild124
3 files changed, 161 insertions, 2 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index 1f57f88eb8cb..b7add6a0c14c 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/povray
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.97 2009/01/16 21:09:50 lavajoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.98 2009/06/14 17:56:40 lavajoe Exp $
+
+*povray-3.7.0_beta32 (14 Jun 2009)
+
+ 14 Jun 2009; Joe Peterson <lavajoe@gentoo.org>
+ +povray-3.7.0_beta32.ebuild,
+ +files/povray-3.7.0_beta32-print-extend-expiration-info.patch:
+ Add new 3.7.0 beta 32
*povray-3.7.0_beta29-r2 (16 Jan 2009)
diff --git a/media-gfx/povray/files/povray-3.7.0_beta32-print-extend-expiration-info.patch b/media-gfx/povray/files/povray-3.7.0_beta32-print-extend-expiration-info.patch
new file mode 100644
index 000000000000..beb6d9385c34
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0_beta32-print-extend-expiration-info.patch
@@ -0,0 +1,28 @@
+--- vfe/unix/unixconsole.cpp~ 2008-10-07 17:06:27.000000000 -0600
++++ vfe/unix/unixconsole.cpp 2008-11-08 14:11:58.000000000 -0700
+@@ -281,10 +281,21 @@
+
+ if (user_code != current_code)
+ {
+- fprintf(stderr, "%s: this pre-release version of POV-Ray for Unix %s\n",
+- PACKAGE,
+- current_week < 52 ? "has expired" : "is over twelve months old and is no longer usable"
+- );
++ if (current_week < 52)
++ {
++ fprintf(stderr, "%s: this pre-release version of POV-Ray for Unix %s\n",
++ PACKAGE,
++ "has expired"
++ );
++ fprintf(stderr, "\nTo extend the license period, you can do something like the following\n(adjust syntax for your shell):\n\n export POVRAY_BETA=`povray --betacode 2>&1`\n\n");
++ }
++ else
++ {
++ fprintf(stderr, "%s: this pre-release version of POV-Ray for Unix %s\n",
++ PACKAGE,
++ "is over twelve months old and is no longer usable"
++ );
++ }
+ exit(RETURN_ERROR);
+ }
+ current_time = EXPIRE_AT + (current_week+1)*spw - current_time;
diff --git a/media-gfx/povray/povray-3.7.0_beta32.ebuild b/media-gfx/povray/povray-3.7.0_beta32.ebuild
new file mode 100644
index 000000000000..b31d4380a7ac
--- /dev/null
+++ b/media-gfx/povray/povray-3.7.0_beta32.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.7.0_beta32.ebuild,v 1.1 2009/06/14 17:56:40 lavajoe Exp $
+
+inherit eutils autotools flag-o-matic versionator
+
+POVRAY_MAJOR_VER=$(get_version_component_range 1-3)
+POVRAY_MINOR_VER=$(get_version_component_range 4)
+if [ -n "$POVRAY_MINOR_VER" ]; then
+ POVRAY_MINOR_VER=${POVRAY_MINOR_VER/beta/beta.}
+ MY_PV="${POVRAY_MAJOR_VER}.${POVRAY_MINOR_VER}"
+else
+ MY_PV=${POVRAY_MAJOR_VER}
+fi
+
+DESCRIPTION="The Persistence of Vision Raytracer"
+HOMEPAGE="http://www.povray.org/"
+SRC_URI="http://www.povray.org/beta/source/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="povlegal-3.6"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="svga tiff X"
+
+DEPEND="media-libs/libpng
+ tiff? ( >=media-libs/tiff-3.6.1 )
+ media-libs/jpeg
+ sys-libs/zlib
+ X? ( x11-libs/libXaw )
+ svga? ( media-libs/svgalib )
+ >=dev-libs/boost-1.36"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Print info on how to extend the expiration date of the beta
+ # if it has expired.
+ epatch "${FILESDIR}"/${P}-print-extend-expiration-info.patch
+ #epatch "${FILESDIR}"/${P}-fix-expiration-bug.patch
+
+ # Change some destination directories that cannot be adjusted via configure
+ cp configure.ac configure.ac.orig
+ sed -i -e 's:${povsysconfdir}/$PACKAGE/$VERSION_BASE:${povsysconfdir}/'${PN}':g' configure.ac
+ sed -i -e 's:${povdatadir}/$PACKAGE-$VERSION_BASE:${povdatadir}/'${PN}':g' configure.ac
+ sed -i -e 's:${povdatadir}/doc/$PACKAGE-$VERSION_BASE:${povdatadir}/doc/'${PF}':g' configure.ac
+
+ cp Makefile.am Makefile.am.orig
+ sed -i -e "s:^povlibdir = .*:povlibdir = @datadir@/${PN}:" Makefile.am
+ sed -i -e "s:^povdocdir = .*:povdocdir = @datadir@/doc/${PF}:" Makefile.am
+ sed -i -e "s:^povconfdir = .*:povconfdir = @sysconfdir@/${PN}:" Makefile.am
+
+ # The "+p" option on the test command line causes a pause and
+ # prompts the user to interact, so remove it.
+ sed -i -e"s:biscuit.pov -f +d +p:biscuit.pov -f +d:" Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ # Fixes bug 71255
+ if [[ $(get-flag march) == k6-2 ]]; then
+ filter-flags -fomit-frame-pointer
+ fi
+
+ # The config files are installed correctly (e.g. povray.conf),
+ # but the code compiles using incorrect [default] paths
+ # (based on /usr/local...), so povray will not find the system
+ # config files without the following fix:
+ append-flags -DPOVLIBDIR=\\\"${ROOT}usr/share/${PN}\\\"
+ append-flags -DPOVCONFDIR=\\\"${ROOT}etc/${PN}\\\"
+
+ econf \
+ COMPILED_BY="Portage (Gentoo `uname`) on `hostname -f`" \
+ $(use_with svga) \
+ $(use_with tiff libtiff) \
+ $(use_with X x) \
+ --disable-strip \
+ || die
+
+ emake || die
+}
+
+src_test() {
+ # For the beta releases, we generate a license extension in case needed
+ POVRAY_BETA=`./unix/povray --betacode 2>&1` emake check || die "Test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_preinst() {
+ # Copy the old config files if they are in the old location
+ # but do not yet exist in the new location.
+ # This way, they can be treated by CONFIG_PROTECT as normal.
+ for conf_file in $(ls "${D}/etc/${PN}"); do
+ if [ ! -e "${ROOT}etc/${PN}/${conf_file}" ]; then
+ for version_dir in $(ls "${ROOT}etc/${PN}" | grep "^[0-9]" | sort -rn); do
+ if [ -e "${ROOT}etc/${PN}/${version_dir}/${conf_file}" ]; then
+ mv "${ROOT}etc/${PN}/${version_dir}/${conf_file}" "${ROOT}etc/${PN}"
+ elog "Note: ${conf_file} moved from ${ROOT}etc/povray/${version_dir}/ to ${ROOT}etc/povray/"
+ break
+ fi
+ done
+ fi
+ done
+}
+
+pkg_postinst() {
+ ewarn "POV-Ray betas have expiration dates, but these can be extended for up to"
+ ewarn "a year. If expired, you will get the following error when running povray:"
+ ewarn
+ ewarn " povray: this pre-release version of POV-Ray for Unix has expired"
+ ewarn
+ ewarn "To extend the license period (a week at a time), you can do"
+ ewarn "something like the following (adjust syntax for your shell):"
+ ewarn
+ ewarn " export POVRAY_BETA=\`povray --betacode 2>&1\`"
+ ewarn
+ ewarn "You will need to repeat this each time it expires."
+}