summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-06-19 09:20:30 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-06-19 09:20:30 +0000
commit53a809aed5ab6d8275013690681e086f2974782a (patch)
tree7b12413d17d5918320c2b37de4ad0ec477723089 /media-gfx
parentFixed some regression bugs caused by backport patches (bug #273741 and #274636) (diff)
downloadgentoo-2-53a809aed5ab6d8275013690681e086f2974782a.tar.gz
gentoo-2-53a809aed5ab6d8275013690681e086f2974782a.tar.bz2
gentoo-2-53a809aed5ab6d8275013690681e086f2974782a.zip
Added patch to unset LAPACK_LIBRARIES if lapack is not found, otherwise cmake sets it to NOTFOUND leading to an error.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/ChangeLog7
-rw-r--r--media-gfx/hugin/files/hugin-0.8.0_rc3-unset_lapack.patch10
-rw-r--r--media-gfx/hugin/hugin-0.8.0_rc3.ebuild4
3 files changed, 18 insertions, 3 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index a574a535037b..12de5fc90bff 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.64 2009/06/10 06:02:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.65 2009/06/19 09:20:29 dev-zero Exp $
+
+ 19 Jun 2009; Tiziano Müller <dev-zero@gentoo.org> hugin-0.8.0_rc3.ebuild,
+ +files/hugin-0.8.0_rc3-unset_lapack.patch:
+ Added patch to unset LAPACK_LIBRARIES if lapack is not found, otherwise
+ cmake sets it to NOTFOUND leading to an error.
*hugin-0.8.0_rc3 (10 Jun 2009)
diff --git a/media-gfx/hugin/files/hugin-0.8.0_rc3-unset_lapack.patch b/media-gfx/hugin/files/hugin-0.8.0_rc3-unset_lapack.patch
new file mode 100644
index 000000000000..4cf2f715dd04
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-0.8.0_rc3-unset_lapack.patch
@@ -0,0 +1,10 @@
+--- CMakeModules/FindLAPACK.cmake.orig 2009-06-19 11:13:06.922006535 +0200
++++ CMakeModules/FindLAPACK.cmake 2009-06-19 11:13:38.566170050 +0200
+@@ -17,5 +17,6 @@
+
+ IF(LAPACK_LIBRARIES)
+ SET( LAPACK_FOUND "YES" )
++ELSE(LAPACK_LIBRARIES)
++ SET( LAPACK_LIBRARIES "")
+ ENDIF(LAPACK_LIBRARIES)
+-
diff --git a/media-gfx/hugin/hugin-0.8.0_rc3.ebuild b/media-gfx/hugin/hugin-0.8.0_rc3.ebuild
index 3f2ca22d5755..019b0c260866 100644
--- a/media-gfx/hugin/hugin-0.8.0_rc3.ebuild
+++ b/media-gfx/hugin/hugin-0.8.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.8.0_rc3.ebuild,v 1.1 2009/06/10 05:41:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.8.0_rc3.ebuild,v 1.2 2009/06/19 09:20:29 dev-zero Exp $
EAPI="2"
WX_GTK_VER="2.8"
@@ -34,7 +34,7 @@ DEPEND="
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
-PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch "${FILESDIR}"/${P}-unset_lapack.patch)
DOCS="AUTHORS README TODO"
src_install() {