summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-17 17:09:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-17 17:09:53 +0000
commit189f77900d14f0979f0b905161e2501d92feef80 (patch)
treea9a40d27c0e813cc3ccebbf42754cab07c4ac1c3 /media-gfx
parentsparc stable wrt #366685 (diff)
downloadgentoo-2-189f77900d14f0979f0b905161e2501d92feef80.tar.gz
gentoo-2-189f77900d14f0979f0b905161e2501d92feef80.tar.bz2
gentoo-2-189f77900d14f0979f0b905161e2501d92feef80.zip
Fix building with libpng15 wrt #383313 by 383313 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xloadimage/ChangeLog6
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch29
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r11.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/media-gfx/xloadimage/ChangeLog b/media-gfx/xloadimage/ChangeLog
index 0ae0740a5ca3..5a1210ca81e5 100644
--- a/media-gfx/xloadimage/ChangeLog
+++ b/media-gfx/xloadimage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/xloadimage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/ChangeLog,v 1.54 2011/08/25 20:51:13 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/ChangeLog,v 1.55 2011/09/17 17:09:53 ssuominen Exp $
+
+ 17 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ xloadimage-4.1-r11.ebuild, +files/xloadimage-4.1-libpng15.patch:
+ Fix building with libpng15 wrt #383313 by 383313 by Diego Elio Pettenò
25 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
xloadimage-4.1-r10.ebuild, xloadimage-4.1-r11.ebuild,
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch b/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch
new file mode 100644
index 000000000000..ffd05f62b332
--- /dev/null
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch
@@ -0,0 +1,29 @@
+--- png.c
++++ png.c
+@@ -75,7 +75,7 @@
+ {
+ debug(" #error ");
+ output_warn( png_ptr, str);
+- longjmp(png_ptr->jmpbuf, 1); /* return control to outer routine */
++ longjmp(png_jmpbuf(png_ptr), 1); /* return control to outer routine */
+ }
+
+
+@@ -164,7 +164,7 @@
+ png_destroy_read_struct(png_pp, info_pp, end_pp);
+ return 0;
+ }
+- if (setjmp((*png_pp)->jmpbuf)) {
++ if (setjmp(png_jmpbuf(*png_pp))) {
+ /* On error */
+ png_destroy_read_struct(png_pp, info_pp, end_pp);
+ return 0;
+@@ -220,7 +220,7 @@
+ zclose(zinput_file);
+ return 0;
+ }
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* On error */
+ freeImage(image);
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild
index 338957a0dccc..3f268c4f52f1 100644
--- a/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild
+++ b/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild,v 1.3 2011/08/25 20:51:13 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r11.ebuild,v 1.4 2011/09/17 17:09:53 ssuominen Exp $
EAPI=2
inherit autotools eutils toolchain-funcs
@@ -46,6 +46,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-unaligned-access.patch
epatch "${FILESDIR}"/${P}-ldflags_and_exit.patch
+ epatch "${FILESDIR}"/${P}-libpng15.patch
sed -i \
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
png.c || die