summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2008-01-19 20:51:20 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2008-01-19 20:51:20 +0000
commitb2ce20b151b748c154810f6a3225156b87e9c1cc (patch)
tree450fb7fa372eb5ada3f1b02509d362bc363d248b /media-gfx/xsane
parentsound herd will take this ebuild. (diff)
downloadgentoo-2-b2ce20b151b748c154810f6a3225156b87e9c1cc.tar.gz
gentoo-2-b2ce20b151b748c154810f6a3225156b87e9c1cc.tar.bz2
gentoo-2-b2ce20b151b748c154810f6a3225156b87e9c1cc.zip
Version bump, bug #201432
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-gfx/xsane')
-rw-r--r--media-gfx/xsane/ChangeLog9
-rw-r--r--media-gfx/xsane/files/digest-xsane-0.9953
-rw-r--r--media-gfx/xsane/xsane-0.995.ebuild80
3 files changed, 90 insertions, 2 deletions
diff --git a/media-gfx/xsane/ChangeLog b/media-gfx/xsane/ChangeLog
index b3b161f67572..7bb790fad454 100644
--- a/media-gfx/xsane/ChangeLog
+++ b/media-gfx/xsane/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/xsane
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.63 2007/06/16 07:14:47 dertobi123 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.64 2008/01/19 20:51:20 phosphan Exp $
+
+*xsane-0.995 (19 Jan 2008)
+
+ 19 Jan 2008; Patrick Kursawe <phosphan@gentoo.org> +xsane-0.995.ebuild:
+ Version bump, bug #201432
16 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org> xsane-0.994.ebuild:
ppc stable, bug #178933
diff --git a/media-gfx/xsane/files/digest-xsane-0.995 b/media-gfx/xsane/files/digest-xsane-0.995
new file mode 100644
index 000000000000..85aae65c8bf3
--- /dev/null
+++ b/media-gfx/xsane/files/digest-xsane-0.995
@@ -0,0 +1,3 @@
+MD5 5aaedb75973c3b13b136edec714e3fe8 xsane-0.995.tar.gz 3307923
+RMD160 889f4058ce65f007cf1482901d252748e3874de5 xsane-0.995.tar.gz 3307923
+SHA256 66a042253c35a54361a8c6c45c49b7b250bd45a024c449803673fc31e72a340b xsane-0.995.tar.gz 3307923
diff --git a/media-gfx/xsane/xsane-0.995.ebuild b/media-gfx/xsane/xsane-0.995.ebuild
new file mode 100644
index 000000000000..e92c636faa25
--- /dev/null
+++ b/media-gfx/xsane/xsane-0.995.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.995.ebuild,v 1.1 2008/01/19 20:51:20 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="graphical scanning frontend"
+HOMEPAGE="http://www.xsane.org/"
+SRC_URI="http://www.xsane.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls jpeg png tiff gimp lcms"
+
+RDEPEND="media-gfx/sane-backends
+ >=x11-libs/gtk+-2.0
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ gimp? ( media-gfx/gimp )
+ lcms? ( media-libs/lcms )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ export OLDXSANE
+ if has_version '<=media-gfx/xsane-0.93'; then
+ OLDXSANE="yes"
+ else
+ OLDXSANE="no"
+ fi
+}
+
+src_compile() {
+ local extraCPPflags
+ if use lcms; then
+ extraCPPflags="-I /usr/include/lcms"
+ fi
+ CPPFLAGS="${CPPFLAGS} ${extraCPPflags}" econf --enable-gtk2 \
+ $(use_enable nls) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_enable gimp) \
+ $(use_enable lcms) \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc xsane.[A-Z]*
+ dohtml -r doc
+
+ # link xsane so it is seen as a plugin in gimp
+ if use gimp; then
+ local plugindir
+ if [ -x /usr/bin/gimptool ]; then
+ plugindir="$(gimptool --gimpplugindir)/plug-ins"
+ elif [ -x /usr/bin/gimptool-2.0 ]; then
+ plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins"
+ else
+ die "Can't find GIMP plugin directory."
+ fi
+ dodir "${plugindir}"
+ dosym /usr/bin/xsane "${plugindir}"
+ fi
+ newicon src/xsane-48x48.png ${PN}.png
+ make_desktop_entry xsane "X-Sane" ${PN}
+}
+
+pkg_postinst() {
+ if [ x${OLDXSANE} = 'xyes' ]; then
+ ewarn "If you are upgrading from <=xsane-0.93, please make sure to"
+ ewarn "remove ~/.sane/xsane/xsane.rc _before_ you start xsane for"
+ ewarn "the first time."
+ fi
+}