summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-16 10:44:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-16 10:44:23 +0000
commit492a4bae5faac6865a9446f333a9a55024d6e2ef (patch)
tree2d8185e152e3ef18ede855fa06846178320fca09 /media-gfx/inkscape/inkscape-0.47.ebuild
parentamd64 stable, bug 305071 (diff)
downloadgentoo-2-492a4bae5faac6865a9446f333a9a55024d6e2ef.tar.gz
gentoo-2-492a4bae5faac6865a9446f333a9a55024d6e2ef.tar.bz2
gentoo-2-492a4bae5faac6865a9446f333a9a55024d6e2ef.zip
Fix building with GCC 4.5 wrt #305749 by Daniel J.. Fix PostScript dependencies wrt #309213 by Willie Wong and Christopher Harvey. Disable strict aliasing wrt #310393 by Doktor Notor.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/inkscape/inkscape-0.47.ebuild')
-rw-r--r--media-gfx/inkscape/inkscape-0.47.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/media-gfx/inkscape/inkscape-0.47.ebuild b/media-gfx/inkscape/inkscape-0.47.ebuild
index 2e3c9d99b1d4..a3f97ea5ff19 100644
--- a/media-gfx/inkscape/inkscape-0.47.ebuild
+++ b/media-gfx/inkscape/inkscape-0.47.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.47.ebuild,v 1.11 2010/02/10 12:12:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.47.ebuild,v 1.12 2010/04/16 10:44:23 ssuominen Exp $
EAPI=2
-inherit eutils gnome2
+inherit eutils flag-o-matic gnome2
MY_P="${P/_/}"
S="${WORKDIR}/${MY_P}"
@@ -12,10 +12,11 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
DESCRIPTION="A SVG based generic vector-drawing program"
HOMEPAGE="http://www.inkscape.org/"
-SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
-IUSE="dia gnome inkjar lcms mmx nls postscript spell wmf"
+IUSE="dia gnome gs inkjar lcms mmx nls spell wmf"
+
RESTRICT="test"
COMMON_DEPEND="
@@ -54,7 +55,7 @@ RDEPEND="
${COMMON_DEPEND}
dev-python/numpy
dia? ( app-office/dia )
- postscript? ( >=media-gfx/pstoedit-3.44[plotutils] media-gfx/skencil )
+ gs? ( app-text/ghostscript-gpl )
wmf? ( media-libs/libwmf )"
DEPEND="${COMMON_DEPEND}
@@ -77,11 +78,17 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-poppler.patch
-
+ epatch "${FILESDIR}"/${P}-poppler.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
gnome2_src_prepare
}
+src_configure() {
+ # aliasing unsafe wrt #310393
+ append-flags -fno-strict-aliasing
+ gnome2_src_configure
+}
+
pkg_postinst() {
elog "local configurations (also includes extensions) are moved from"
elog "\${HOME}/.inkscape to \${HOME}/.config/inkscape within"