summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2005-11-05 15:49:25 +0000
committerLim Swee Tat <st_lim@gentoo.org>2005-11-05 15:49:25 +0000
commit00add0d8577a846b27d007d43d2175583e13658b (patch)
treeef602e8c8a7509272d1e19275c28bc6ea58ff7ff /mail-filter
parentRemove old version. (diff)
downloadgentoo-2-00add0d8577a846b27d007d43d2175583e13658b.tar.gz
gentoo-2-00add0d8577a846b27d007d43d2175583e13658b.tar.bz2
gentoo-2-00add0d8577a846b27d007d43d2175583e13658b.zip
Readded sqlite3 as a use flag
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/dspam/ChangeLog5
-rw-r--r--mail-filter/dspam/dspam-3.6.0.ebuild19
2 files changed, 18 insertions, 6 deletions
diff --git a/mail-filter/dspam/ChangeLog b/mail-filter/dspam/ChangeLog
index 1224882b294f..400dcbef6a95 100644
--- a/mail-filter/dspam/ChangeLog
+++ b/mail-filter/dspam/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-filter/dspam
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.63 2005/11/05 15:21:58 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.64 2005/11/05 15:49:25 st_lim Exp $
+
+ 05 Nov 2005; Lim Swee Tat <st_lim@gentoo.org> dspam-3.6.0.ebuild:
+ Enabling sqlite3 again
05 Nov 2005; Lim Swee Tat <st_lim@gentoo.org> dspam-3.6.0.ebuild:
Added use flag for clamav
diff --git a/mail-filter/dspam/dspam-3.6.0.ebuild b/mail-filter/dspam/dspam-3.6.0.ebuild
index 2f589f262f24..9d484a12b674 100644
--- a/mail-filter/dspam/dspam-3.6.0.ebuild
+++ b/mail-filter/dspam/dspam-3.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.6.0.ebuild,v 1.2 2005/11/05 15:21:58 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.6.0.ebuild,v 1.3 2005/11/05 15:49:25 st_lim Exp $
inherit eutils
@@ -14,14 +14,16 @@ LICENSE="GPL-2"
IUSE="clamav debug large-domain logrotate mysql neural oci8 postgres sqlite virtual-users"
DEPEND="clamav? ( >=app-antivirus/clamav-0.86 )
mysql? ( >=dev-db/mysql-3.23 )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( <dev-db/sqlite-3* )
+ sqlite3? ( =dev-db/sqlite-3* )
postgres? ( >=dev-db/postgresql-7.4.3 )
>=sys-libs/db-4.0
"
RDEPEND="sys-process/cronbase
clamav? ( >=app-antivirus/clamav-0.86 )
mysql? ( >=dev-db/mysql-3.23 )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( <dev-db/sqlite-3* )
+ sqlite3? ( =dev-db/sqlite-3* )
postgres? ( >=dev-db/postgresql-7.4.3 )
>=sys-libs/db-4.0
logrotate? ( app-admin/logrotate )"
@@ -35,7 +37,7 @@ LOGDIR="/var/log/dspam"
pkg_setup() {
local multiple_dbs="0"
- local supported_dbs="mysql postgres oci8 sqlite"
+ local supported_dbs="mysql postgres oci8 sqlite sqlite3"
for foo in ${supported_dbs}; do
if use ${foo}; then
let multiple_dbs="((multiple_dbs + 1 ))"
@@ -103,6 +105,9 @@ src_compile() {
if use sqlite ; then
myconf="${myconf} --with-storage-driver=sqlite_drv"
myconf="${myconf} --enable-virtual-users"
+ elif use sqlite3 ; then
+ myconf="${myconf} --with-storage-driver=sqlite3_drv"
+ myconf="${myconf} --enable-virtual-users"
elif use mysql; then
myconf="${myconf} --with-storage-driver=mysql_drv"
myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
@@ -218,7 +223,11 @@ src_install () {
if use sqlite; then
insinto ${CONFDIR}
insopts -m644 -o dspam -g dspam
- newins src/tools.sqlite_drv/purge.sql sqlite_purge.sql
+ newins src/tools.sqlite_drv/purge-2.sql sqlite_purge.sql
+ elif use sqlite3; then
+ insinto ${CONFDIR}
+ insopts -m644 -o dspam -g dspam
+ newins src/tools.sqlite_drv/purge-3.sql sqlite3_purge.sql
elif use mysql; then
# Use existing configuration if possible
if [[ -f ${ROOT}${CONFDIR}/mysql.data ]]; then