summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-08-17 13:46:33 +0000
committerPeter Volkov <pva@gentoo.org>2011-08-17 13:46:33 +0000
commite9493740672b5169cff848fbe2456bae1c597611 (patch)
treed13e665a56fa60d56906846525d511ca11e80018 /mail-client/roundcube
parentMark stable on AMD64 and remove stray die statement as per arch testing by Ag... (diff)
downloadgentoo-2-e9493740672b5169cff848fbe2456bae1c597611.tar.gz
gentoo-2-e9493740672b5169cff848fbe2456bae1c597611.tar.bz2
gentoo-2-e9493740672b5169cff848fbe2456bae1c597611.zip
Version bump, fixes security bug 379563
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.5.4.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index c9cf7047bb1a..799901e6a0b9 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.51 2011/06/03 08:47:10 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.52 2011/08/17 13:46:33 pva Exp $
+
+*roundcube-0.5.4 (17 Aug 2011)
+
+ 17 Aug 2011; Peter Volkov <pva@gentoo.org> +roundcube-0.5.4.ebuild:
+ Version bump, fixes security bug 379563
*roundcube-0.5.3 (03 Jun 2011)
diff --git a/mail-client/roundcube/roundcube-0.5.4.ebuild b/mail-client/roundcube/roundcube-0.5.4.ebuild
new file mode 100644
index 000000000000..405482d37b5c
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.5.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.5.4.ebuild,v 1.1 2011/08/17 13:46:33 pva Exp $
+
+EAPI="2"
+
+inherit webapp depend.php
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV/_/-}"
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap mysql postgres ssl spell +sqlite"
+
+DEPEND=""
+RDEPEND="|| ( <dev-lang/php-5.3[crypt,iconv,json,ldap?,pcre,postgres?,session,spl,sqlite?,ssl?,unicode]
+ >=dev-lang/php-5.3[crypt,iconv,json,ldap?,postgres?,session,sqlite?,ssl?,unicode] )
+ spell? ( dev-lang/php[curl,spell] )
+ dev-php/PEAR-PEAR"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ use mysql && require_php_with_any_use mysql mysqli
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,}
+ cp config/main.inc.php{.dist,}
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}