summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-11-09 10:00:30 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-11-09 10:00:30 +0000
commita9eba7202fe7ff0eade3ccef53f4b5323b896e8c (patch)
treecad123ee7028291068d7e3e13ab6448b2f9b62dc /mail-client/roundcube
parentUnused patch. (diff)
downloadgentoo-2-a9eba7202fe7ff0eade3ccef53f4b5323b896e8c.tar.gz
gentoo-2-a9eba7202fe7ff0eade3ccef53f4b5323b896e8c.tar.bz2
gentoo-2-a9eba7202fe7ff0eade3ccef53f4b5323b896e8c.zip
version bump wrt #292484
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.3.1.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index 16767421417f..d0f75566bf66 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.12 2009/09/27 20:05:12 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.13 2009/11/09 10:00:30 hollow Exp $
+
+*roundcube-0.3.1 (09 Nov 2009)
+
+ 09 Nov 2009; Benedikt Böhm <hollow@gentoo.org> +roundcube-0.3.1.ebuild:
+ version bump wrt #292484
27 Sep 2009; nixnut <nixnut@gentoo.org> roundcube-0.2.2.ebuild:
ppc stable #272423
diff --git a/mail-client/roundcube/roundcube-0.3.1.ebuild b/mail-client/roundcube/roundcube-0.3.1.ebuild
new file mode 100644
index 000000000000..f4f744c26983
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.3.1.ebuild,v 1.1 2009/11/09 10:00:30 hollow Exp $
+
+EAPI="2"
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV}"
+
+inherit confutils webapp depend.php depend.apache
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ldap mysql postgres +sqlite +ssl spell"
+
+DEPEND=""
+RDEPEND="dev-lang/php[crypt,iconv,ldap?,pcre,postgres?,session,spl,ssl?,sqlite?,unicode]
+ spell? ( dev-lang/php[curl,spell] )
+ dev-php/PEAR-PEAR
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ confutils_require_any mysql postgres sqlite
+ use mysql && require_php_with_any_use mysql mysqli
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}