summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-10 10:28:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-10 10:28:20 +0000
commit7f94f2a35571993c961acd2552e521a461a6e624 (patch)
tree99aa3288f297417c33e3c8b34cd6492a5595b267 /kde-misc/rsibreak
parentVersion bump, still need to take an in depth look at Bug #120842 (diff)
downloadgentoo-2-7f94f2a35571993c961acd2552e521a461a6e624.tar.gz
gentoo-2-7f94f2a35571993c961acd2552e521a461a6e624.tar.bz2
gentoo-2-7f94f2a35571993c961acd2552e521a461a6e624.zip
Add patch to fix parallel make issues reported by John S J Anderson in bug #132875.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'kde-misc/rsibreak')
-rw-r--r--kde-misc/rsibreak/ChangeLog7
-rw-r--r--kde-misc/rsibreak/files/rsibreak-0.6.0-parallel.patch13
-rw-r--r--kde-misc/rsibreak/rsibreak-0.6.0.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/kde-misc/rsibreak/ChangeLog b/kde-misc/rsibreak/ChangeLog
index 4f5f2ffe1ac2..42a9cb4c2c83 100644
--- a/kde-misc/rsibreak/ChangeLog
+++ b/kde-misc/rsibreak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/rsibreak
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/ChangeLog,v 1.9 2006/05/07 18:32:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/ChangeLog,v 1.10 2006/05/10 10:28:20 flameeyes Exp $
+
+ 10 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/rsibreak-0.6.0-parallel.patch, rsibreak-0.6.0.ebuild:
+ Add patch to fix parallel make issues reported by John S J Anderson in bug
+ #132875.
07 May 2006; Diego Pettenò <flameeyes@gentoo.org> -rsibreak-0.5.0.ebuild,
-rsibreak-0.6.0_rc1.ebuild:
diff --git a/kde-misc/rsibreak/files/rsibreak-0.6.0-parallel.patch b/kde-misc/rsibreak/files/rsibreak-0.6.0-parallel.patch
new file mode 100644
index 000000000000..f61469f63e7c
--- /dev/null
+++ b/kde-misc/rsibreak/files/rsibreak-0.6.0-parallel.patch
@@ -0,0 +1,13 @@
+Index: rsibreak-0.6.0/rsibreak/src/Makefile.am
+===================================================================
+--- rsibreak-0.6.0.orig/rsibreak/src/Makefile.am
++++ rsibreak-0.6.0/rsibreak/src/Makefile.am
+@@ -33,7 +33,7 @@ rsibreak_SOURCES = rsidock.cpp setup.cpp
+ rsistatwidget.cpp rsistats.cpp rsiglobals.cpp rsistatitem.cpp
+ rsibreak_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+ rsibreak_LDADD = $(LIB_KDEUI) $(LIB_KIO) $(LIBXSS) \
+- $(top_builddir)/rsibreak/src/librsibreak.la
++ librsibreak.la
+
+ # this is where the desktop file will go
+ xdg_apps_DATA = rsibreak.desktop
diff --git a/kde-misc/rsibreak/rsibreak-0.6.0.ebuild b/kde-misc/rsibreak/rsibreak-0.6.0.ebuild
index 6b7890ba6881..2d3eb59e27f7 100644
--- a/kde-misc/rsibreak/rsibreak-0.6.0.ebuild
+++ b/kde-misc/rsibreak/rsibreak-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/rsibreak-0.6.0.ebuild,v 1.2 2006/05/07 18:29:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/rsibreak-0.6.0.ebuild,v 1.3 2006/05/10 10:28:20 flameeyes Exp $
USE_KEG_PACKAGING="yes"
@@ -38,3 +38,5 @@ DEPEND="${RDEPEND}
need-kde 3.3
+PATCHES="${FILESDIR}/${P}-parallel.patch"
+