summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-10-14 00:02:13 +0000
committerJohannes Huber <johu@gentoo.org>2012-10-14 00:02:13 +0000
commit9e542520c142c416f50ec7cd7536668586ab103b (patch)
tree2bf3e832e53681f13de3b09bae7db31fd1d35599 /kde-base
parentAdd unstable version of ibus: ibus-1.4.99.20121006, which is required by gnom... (diff)
downloadgentoo-2-9e542520c142c416f50ec7cd7536668586ab103b.tar.gz
gentoo-2-9e542520c142c416f50ec7cd7536668586ab103b.tar.bz2
gentoo-2-9e542520c142c416f50ec7cd7536668586ab103b.zip
Add upstream patch to fix build when dirwatch not exists spotted by Naohiro Aota <naota@gentoo.org> needed on bsd for bug #430072.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/nepomuk-core/ChangeLog8
-rw-r--r--kde-base/nepomuk-core/files/nepomuk-core-4.9.2-build-fix-dirwatch-not-exists.patch22
-rw-r--r--kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/kde-base/nepomuk-core/ChangeLog b/kde-base/nepomuk-core/ChangeLog
index 9a6b83e48351..2ef995f52d87 100644
--- a/kde-base/nepomuk-core/ChangeLog
+++ b/kde-base/nepomuk-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/nepomuk-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/ChangeLog,v 1.11 2012/10/04 07:25:15 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/ChangeLog,v 1.12 2012/10/14 00:02:13 johu Exp $
+
+ 14 Oct 2012; Johannes Huber <johu@gentoo.org>
+ +files/nepomuk-core-4.9.2-build-fix-dirwatch-not-exists.patch,
+ nepomuk-core-4.9.2-r1.ebuild:
+ Add upstream patch to fix build when dirwatch not exists spotted by Naohiro
+ Aota <naota@gentoo.org> needed on bsd for bug #430072.
*nepomuk-core-4.9.2-r1 (04 Oct 2012)
diff --git a/kde-base/nepomuk-core/files/nepomuk-core-4.9.2-build-fix-dirwatch-not-exists.patch b/kde-base/nepomuk-core/files/nepomuk-core-4.9.2-build-fix-dirwatch-not-exists.patch
new file mode 100644
index 000000000000..e9a2cbe82567
--- /dev/null
+++ b/kde-base/nepomuk-core/files/nepomuk-core-4.9.2-build-fix-dirwatch-not-exists.patch
@@ -0,0 +1,22 @@
+commit e462f9667a6e28de948d0341768167c5d96c0f7e
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Sun Oct 7 17:37:54 2012 +0300
+
+ Fix the build without KInotify again.
+
+ CCMAIL: dvratil@redhat.com
+
+diff --git a/services/filewatch/nepomukfilewatch.cpp b/services/filewatch/nepomukfilewatch.cpp
+index 83045da..9ccf7b0 100644
+--- a/services/filewatch/nepomukfilewatch.cpp
++++ b/services/filewatch/nepomukfilewatch.cpp
+@@ -114,7 +114,9 @@ namespace {
+
+ Nepomuk2::FileWatch::FileWatch( QObject* parent, const QList<QVariant>& )
+ : Service( parent )
++#ifdef BUILD_KINOTIFY
+ , m_dirWatch( 0 )
++#endif
+ {
+ // Create the configuration instance singleton (for thread-safety)
+ // ==============================================================
diff --git a/kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild b/kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild
index ded05864b4fa..9f1f1fadea63 100644
--- a/kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild
+++ b/kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild,v 1.1 2012/10/04 07:25:15 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/nepomuk-core-4.9.2-r1.ebuild,v 1.2 2012/10/14 00:02:13 johu Exp $
EAPI=4
@@ -24,4 +24,5 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}/${P}-kinotify-delete.patch"
"${FILESDIR}/${P}-dirwatch-null.patch"
+ "${FILESDIR}/${P}-build-fix-dirwatch-not-exists.patch"
)