summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-07-04 18:04:39 +0000
committerJohannes Huber <johu@gentoo.org>2013-07-04 18:04:39 +0000
commit06296404fdd59434793328a48272e1cbed52093f (patch)
tree7bd67b25c39aae28ad924f72bb0717eb42fb1d7e /kde-base
parentAdd ruby19 support wrt bug #434076. (diff)
downloadgentoo-2-06296404fdd59434793328a48272e1cbed52093f.tar.gz
gentoo-2-06296404fdd59434793328a48272e1cbed52093f.tar.bz2
gentoo-2-06296404fdd59434793328a48272e1cbed52093f.zip
Add ruby19 support wrt bug #434078.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/korundum/ChangeLog5
-rw-r--r--kde-base/korundum/korundum-4.10.5.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 9a1247a78674..96e49817c54a 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.169 2013/07/02 16:48:05 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.170 2013/07/04 18:04:39 johu Exp $
+
+ 04 Jul 2013; Johannes Huber <johu@gentoo.org> korundum-4.10.5.ebuild:
+ Add ruby19 support wrt bug #434078.
*korundum-4.10.5 (02 Jul 2013)
diff --git a/kde-base/korundum/korundum-4.10.5.ebuild b/kde-base/korundum/korundum-4.10.5.ebuild
index f95ceeb26f76..1bbef150656f 100644
--- a/kde-base/korundum/korundum-4.10.5.ebuild
+++ b/kde-base/korundum/korundum-4.10.5.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.10.5.ebuild,v 1.1 2013/07/02 16:48:05 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.10.5.ebuild,v 1.2 2013/07/04 18:04:39 johu Exp $
EAPI=5
OPENGL_REQUIRED="always"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
# files with identical path+name will overwrite each other - difficult :(
inherit kde4-base ruby-ng