summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:40:18 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:40:18 +0000
commitbf24df3908a08f911a3fc034d7a16f95e1e9cdfc (patch)
tree60ba37169ac827240434deeb4eea9af0858b8c28 /kde-base/solid
parentVersion bump KDE 4.3.2 (diff)
downloadgentoo-2-bf24df3908a08f911a3fc034d7a16f95e1e9cdfc.tar.gz
gentoo-2-bf24df3908a08f911a3fc034d7a16f95e1e9cdfc.tar.bz2
gentoo-2-bf24df3908a08f911a3fc034d7a16f95e1e9cdfc.zip
Version bump KDE 4.3.2
(Portage version: 2.2_rc44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.3.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index d9d0eab97a1e..7ccc39151c39 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.36 2009/09/01 16:28:09 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.37 2009/10/06 20:40:18 alexxy Exp $
+
+*solid-4.3.2 (06 Oct 2009)
+
+ 06 Oct 2009; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.3.2.ebuild:
+ Version bump
*solid-4.3.1 (01 Sep 2009)
diff --git a/kde-base/solid/solid-4.3.2.ebuild b/kde-base/solid/solid-4.3.2.ebuild
new file mode 100644
index 000000000000..8b6578484084
--- /dev/null
+++ b/kde-base/solid/solid-4.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.3.2.ebuild,v 1.1 2009/10/06 20:40:18 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ >=sys-apps/hal-0.5.9
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ libs/solid/
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ "
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ elog "If you want to be notified about new plugged devices by a popup,"
+ elog "install kde-base/soliduiserver"
+
+ kde4-meta_pkg_postinst
+}