summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:46:31 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:46:31 +0000
commit61b538b0a1f7ed036bc9174c8e06b61886b02f77 (patch)
tree884d2fcc97ace26645488132d8cab2cabdae8369 /kde-base/plasma
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-61b538b0a1f7ed036bc9174c8e06b61886b02f77.tar.gz
gentoo-2-61b538b0a1f7ed036bc9174c8e06b61886b02f77.tar.bz2
gentoo-2-61b538b0a1f7ed036bc9174c8e06b61886b02f77.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/plasma')
-rw-r--r--kde-base/plasma/ChangeLog9
-rw-r--r--kde-base/plasma/files/plasma-4.0.3-kickoff.patch12
-rw-r--r--kde-base/plasma/plasma-4.0.3.ebuild50
3 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/plasma/ChangeLog b/kde-base/plasma/ChangeLog
index a2ddbb954660..747897124266 100644
--- a/kde-base/plasma/ChangeLog
+++ b/kde-base/plasma/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/plasma
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma/ChangeLog,v 1.7 2008/03/20 18:24:08 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma/ChangeLog,v 1.8 2008/04/03 21:46:30 philantrop Exp $
+
+*plasma-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/plasma-4.0.3-kickoff.patch, +plasma-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/plasma-4.0.1-linkage.patch, -plasma-4.0.1.ebuild:
diff --git a/kde-base/plasma/files/plasma-4.0.3-kickoff.patch b/kde-base/plasma/files/plasma-4.0.3-kickoff.patch
new file mode 100644
index 000000000000..3e05cabba0b7
--- /dev/null
+++ b/kde-base/plasma/files/plasma-4.0.3-kickoff.patch
@@ -0,0 +1,12 @@
+diff -Naur plasma-4.0.3.orig/plasma/applets/kickoff/main.cpp plasma-4.0.3/plasma/applets/kickoff/main.cpp
+--- plasma-4.0.3.orig/plasma/applets/kickoff/main.cpp 2008-03-27 21:34:51.000000000 +0100
++++ plasma-4.0.3/plasma/applets/kickoff/main.cpp 2008-03-30 01:59:48.000000000 +0100
+@@ -36,7 +36,7 @@
+
+ KApplication app;
+
+- Kickoff::Launcher *launcher = new Kickoff::Launcher(0);
++ Kickoff::Launcher *launcher = new Kickoff::Launcher((QWidget*) 0);
+ launcher->setWindowTitle("Kickoff KDE 4 Test Application");
+ // ensure launcher gets deleted when the app closes so that favorites,
+ // recent applications etc. are saved
diff --git a/kde-base/plasma/plasma-4.0.3.ebuild b/kde-base/plasma/plasma-4.0.3.ebuild
new file mode 100644
index 000000000000..e901a202a7e3
--- /dev/null
+++ b/kde-base/plasma/plasma-4.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma/plasma-4.0.3.ebuild,v 1.1 2008/04/03 21:46:30 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook xcomposite xinerama"
+
+COMMONDEPEND="
+ >=app-misc/strigi-0.5.7
+ >=kde-base/libkworkspace-${PV}:${SLOT}
+ >=kde-base/libtaskmanager-${PV}:${SLOT}
+ >=kde-base/libplasma-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}
+ >=kde-base/kde-menu-icons-${PV}:${SLOT}"
+PDEPEND="
+ kde-base/kdeartwork-iconthemes:${SLOT}"
+
+KMEXTRACTONLY="krunner/org.freedesktop.ScreenSaver.xml
+ krunner/org.kde.krunner.Interface.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/taskmanager/
+ libs/plasma/"
+
+PATCHES="${FILESDIR}/${PN}-4.0.2-linkage.patch
+ ${FILESDIR}/${P}-kickoff.patch"
+
+KDE4_BUILT_WITH_USE_CHECK="app-misc/strigi dbus qt4"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}