summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
commit461c1af9ab4c8cfbdc911a491f7c86af2ef043dd (patch)
tree05608ce8b58bb6826c888fa542fb8c351b8e650b /kde-base/phonon-kde
parentUse QA_PREBUILT, fix minor QA issues, wrt bug #430026 (diff)
downloadgentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.gz
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.bz2
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.zip
Version bump KDE SC 4.9.5
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog9
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.9.5.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index eaddeab7aa7d..922462733330 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.146 2012/12/08 11:53:41 dilfridge Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.147 2013/01/05 20:18:25 creffett Exp $
+
+*phonon-kde-4.9.5 (05 Jan 2013)
+
+ 05 Jan 2013; <creffett@gentoo.org> +phonon-kde-4.9.5.ebuild:
+ Version bump KDE SC 4.9.5
08 Dec 2012; Andreas K. Huettel <dilfridge@gentoo.org>
-phonon-kde-4.8.5.ebuild:
diff --git a/kde-base/phonon-kde/phonon-kde-4.9.5.ebuild b/kde-base/phonon-kde/phonon-kde-4.9.5.ebuild
new file mode 100644
index 000000000000..5a6d710bbe77
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.9.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.9.5.ebuild,v 1.1 2013/01/05 20:18:25 creffett Exp $
+
+EAPI=4
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}