summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-15 16:57:08 +0000
commitb19b0ead03dc10cdaa9aea4001d560c962a1f597 (patch)
treef22852d83a670996da46e118f610a0f6dfa2f4ba /kde-base/okular
parentsys-kernel/aufs-sources: Fix problem due to renamed tmpfs patch, #513332 (diff)
downloadgentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.gz
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.tar.bz2
gentoo-2-b19b0ead03dc10cdaa9aea4001d560c962a1f597.zip
Version bump KDE SC 4.13.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.13.2.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 178b3173ff3e..15a02b8eb984 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.250 2014/05/26 21:44:29 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.251 2014/06/15 16:56:22 kensington Exp $
+
+*okular-4.13.2 (15 Jun 2014)
+
+ 15 Jun 2014; Michael Palimaka <kensington@gentoo.org> +okular-4.13.2.ebuild:
+ Version bump KDE SC 4.13.2
*okular-4.12.5-r1 (26 May 2014)
*okular-4.13.0-r1 (26 May 2014)
diff --git a/kde-base/okular/okular-4.13.2.ebuild b/kde-base/okular/okular-4.13.2.ebuild
new file mode 100644
index 000000000000..2156d4d667c7
--- /dev/null
+++ b/kde-base/okular/okular-4.13.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.13.2.ebuild,v 1.1 2014/06/15 16:56:22 kensington Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+
+#VIRTUALX_REQUIRED=test
+RESTRICT=test
+# test 2: parttest hangs
+
+inherit kde4-base
+
+DESCRIPTION="Okular is a universal document viewer based on KPDF for KDE 4."
+HOMEPAGE="http://okular.kde.org http://www.kde.org/applications/graphics/okular"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu dpi ebook +jpeg mobi +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ dpi? ( x11-libs/libkscreen )
+ ebook? ( app-text/ebook-tools )
+ jpeg? (
+ $(add_kdebase_dep libkexiv2)
+ virtual/jpeg:0
+ )
+ mobi? ( $(add_kdebase_dep kdegraphics-mobipocket) )
+ pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with dpi LibKScreen)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with jpeg Kexiv2)
+ $(cmake-utils_use_with mobi QMobiPocket)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}