summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-05 12:29:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-05 12:29:15 +0000
commitac552133156c4576349f2f380c84cbd56467b59c (patch)
treeb5a59318c3aa2a6de0905f29880767265876a63e /kde-base/kmailcvt
parentRemove unneeded patches. (diff)
downloadgentoo-2-ac552133156c4576349f2f380c84cbd56467b59c.tar.gz
gentoo-2-ac552133156c4576349f2f380c84cbd56467b59c.tar.bz2
gentoo-2-ac552133156c4576349f2f380c84cbd56467b59c.zip
Remove unneeded patches.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'kde-base/kmailcvt')
-rw-r--r--kde-base/kmailcvt/ChangeLog6
-rw-r--r--kde-base/kmailcvt/files/fix-kmailcvt-compilation.diff169
2 files changed, 5 insertions, 170 deletions
diff --git a/kde-base/kmailcvt/ChangeLog b/kde-base/kmailcvt/ChangeLog
index 889823cbf2c4..aa851bc8332d 100644
--- a/kde-base/kmailcvt/ChangeLog
+++ b/kde-base/kmailcvt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kmailcvt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmailcvt/ChangeLog,v 1.61 2007/02/04 02:35:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmailcvt/ChangeLog,v 1.62 2007/02/05 12:29:15 flameeyes Exp $
+
+ 05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
+ -files/fix-kmailcvt-compilation.diff:
+ Remove unneeded patches.
04 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> -kmailcvt-3.5.1.ebuild:
Remove old versions.
diff --git a/kde-base/kmailcvt/files/fix-kmailcvt-compilation.diff b/kde-base/kmailcvt/files/fix-kmailcvt-compilation.diff
deleted file mode 100644
index 04ec9b34e1f7..000000000000
--- a/kde-base/kmailcvt/files/fix-kmailcvt-compilation.diff
+++ /dev/null
@@ -1,169 +0,0 @@
-bugs.gentoo.org #99643, bugs.kde.org #106274, in upstream BRANCH post 3.4.2
-
-Index: kmailcvt/filters.hxx
-===================================================================
---- kmailcvt/filters.hxx (revision 438560)
-+++ kmailcvt/filters.hxx (revision 438561)
-@@ -85,6 +85,57 @@
- };
-
-
-+
-+/**
-+* Glorified QString[N] for (a) understandability (b) older gcc compatibility.
-+*/
-+template <unsigned int size> class FolderStructureBase
-+{
-+public:
-+ typedef QString NString[size];
-+ /** Constructor. Need a default constructor for QValueList. */
-+ FolderStructureBase() {} ;
-+
-+ /** Constructor. Turn N QStrings into a folder structure
-+ * description.
-+ */
-+ FolderStructureBase(const NString &s)
-+ {
-+ for(unsigned int i=0; i<size; i++) d[i]=s[i];
-+ } ;
-+
-+ /** Copy Constructor. */
-+ FolderStructureBase(const FolderStructureBase &s)
-+ {
-+ for(unsigned int i=0; i<size; i++) d[i]=s[i];
-+ } ;
-+
-+ /** Assignment operator. Does the same thing as
-+ * the copy constructor.
-+ */
-+ FolderStructureBase &operator =(const FolderStructureBase &s)
-+ {
-+ for(unsigned int i=0; i<size; i++) d[i]=s[i];
-+ return *this;
-+ } ;
-+
-+ /** Access the different fields. There doesn't seem to
-+ * be a real semantics for the fields.
-+ */
-+ const QString operator [](unsigned int i) const
-+ {
-+ if (i<size) return d[i]; else return QString::null;
-+ } ;
-+
-+ /** Access the different fields, for writing. */
-+ QString &operator [](unsigned int i)
-+ {
-+ Q_ASSERT(i<size);
-+ if (i<size) return d[i]; else return d[0];
-+ } ;
-+private:
-+ QString d[size];
-+} ;
-+
- #endif
-
--// vim: ts=2 sw=2 et
-Index: kmailcvt/filter_pmail.cxx
-===================================================================
---- kmailcvt/filter_pmail.cxx (revision 438560)
-+++ kmailcvt/filter_pmail.cxx (revision 438561)
-@@ -325,8 +325,8 @@
-
- while (!found)
- {
-- for ( QValueList<QString[5]>::Iterator it = folderMatrix.begin(); it != folderMatrix.end(); it++) {
-- QString tmp[5] = *it;
-+ for ( FolderStructureIterator it = folderMatrix.begin(); it != folderMatrix.end(); it++) {
-+ FolderStructure tmp = *it;
-
- QString _ID = tmp[2];
- if(_ID == search) {
-Index: kmailcvt/filter_oe.cxx
-===================================================================
---- kmailcvt/filter_oe.cxx (revision 438560)
-+++ kmailcvt/filter_oe.cxx (revision 438561)
-@@ -389,15 +389,15 @@
- {
- bool found = false;
- bool foundFilename = false;
-- QString folder = "";
-+ QString folder;
- // we must do this because folder with more than one upper letter
- // at start have maybe not a file named like the folder !!!
- QString search = filename.lower();
-
- while (!found)
- {
-- for ( QValueList<QString[4]>::Iterator it = folderStructure.begin(); it != folderStructure.end(); it++) {
-- QString tmp[4] = *it;
-+ for ( FolderStructureIterator it = folderStructure.begin(); it != folderStructure.end(); it++) {
-+ FolderStructure tmp = *it;
- if(foundFilename == false) {
- QString _tmpFileName = tmp[1];
- _tmpFileName = _tmpFileName.lower();
-@@ -410,7 +410,7 @@
- QString _currentID = tmp[2];
- QString _parentID = tmp[3];
- if(_currentID == search) {
-- if(_parentID == "") { // this is the root of the folder
-+ if(_parentID.isEmpty()) { // this is the root of the folder
- found = true;
- break;
- } else {
-@@ -421,7 +421,7 @@
- }
- }
- // need to break the while loop maybe in some cases
-- if((foundFilename == false) && (folder == "")) return folder;
-+ if((foundFilename == false) && (folder.isEmpty())) return folder;
- }
- return folder;
- }
-Index: kmailcvt/filter_pmail.hxx
-===================================================================
---- kmailcvt/filter_pmail.hxx (revision 438560)
-+++ kmailcvt/filter_pmail.hxx (revision 438561)
-@@ -50,8 +50,18 @@
- QDir dir;
- /** pointer to the info */
- FilterInfo * inf;
-- /** QStringList with the foldernames, First String contains the ID, the second the folder */
-- QValueList<QString[5]> folderMatrix;
-+
-+ /** Folder structure here has 5 entries. */
-+ typedef FolderStructureBase<5> FolderStructure;
-+ /** List with the folder matrix, which contains following strings:
-+ 1. type (2 for root-folder, 1 for folder, 0 for mailarchiv)
-+ 2. type (1 for root-folder, 3 for folder, 0 for mailarchiv)
-+ 3. "ID:flag:filename" of folder/archiv
-+ 4. "ID:name" of parent folder
-+ 5. name of folder/archiv
-+ */
-+ QValueList<FolderStructure> folderMatrix;
-+ typedef QValueList<FolderStructure>::Iterator FolderStructureIterator;
-
- /** true, if the folderfile is parsed **/
- bool folderParsed;
-Index: kmailcvt/filter_oe.hxx
-===================================================================
---- kmailcvt/filter_oe.hxx (revision 438560)
-+++ kmailcvt/filter_oe.hxx (revision 438561)
-@@ -61,8 +61,17 @@
- bool parsedFolder;
- /** true if the current parsing file is the folder file */
- bool currentIsFolderFile;
-+
-+ /** Folder structure with following 4 entries:
-+ 1. descriptive folder name
-+ 2. filename
-+ 3. ID of current folder
-+ 4. ID of parent folder
-+ */
-+ typedef FolderStructureBase<4> FolderStructure;
- /** matrix with information about the folder structure*/
-- QValueList<QString[4]> folderStructure;
-+ QValueList<FolderStructure> folderStructure;
-+ typedef QValueList<FolderStructure>::Iterator FolderStructureIterator;
-
- /** name of the current folder */
- QString folderName;